Next-in-Thread Next Message

Question 3com 3c574_cs (3CCFE574BT) link beat problems 

Forum: 3Com PCMCIA Ethernet Adapter Issues
Date: 2000, Mar 08
From: Jason Puyleart puyleart

All -

I have been having a lot of difficulty getting my 3Com ethernet adapter functioning under linux. (RH Linux 6.1/PCMCIA 3.1.11)

The adapter is recognized by the pcmcia services, looks configured properly, and I can even see activity on the leds of my cable modem. Ifconfig also report receiving and transmitting packets. However, the dhcp request never completes. I also checked /proc/interrupts and the card is receiving interrupts. The biggest problem I can see is that there is an error in the log showing that autonegotiation is never completed. Is there anything I can do?

Thanks!

Jason

I have provided some information below:

(One more note - it all works under Win95 - Ahhrrr!!!)

# cardctl status
Socket 0:
  5V 16-bit PC Card
  function 0: [ready]
Socket 1:
  no card

# cardctl ident
Socket 0:
  product info: "3Com", "Megahertz 574B", "B", "001"
  manfid: 0x0101, 0x0574
  function: 6 (network)
Socket 1:
  no product info available

# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:04:8E:48:98  
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:3
          collisions:0 txqueuelen:100 
          Interrupt:15 Base address:0x120 

Mar  7 15:36:11 localhost pcmcia: Starting PCMCIA services:
Mar  7 15:36:12 localhost pcmcia:  modules
Mar  7 15:36:12 localhost kernel: Linux PCMCIA Card Services 3.1.11 
Mar  7 15:36:12 localhost kernel:   kernel build: 2.2.12-20 #1 Mon Sep 27 10:40:35 EDT 1999 
Mar  7 15:36:12 localhost kernel:   options:  [pci] [cardbus] [apm] 
Mar  7 15:36:12 localhost kernel: PCI routing table version 1.0 at 0xf09a0 
Mar  7 15:36:12 localhost kernel: Intel PCIC probe:  
Mar  7 15:36:12 localhost kernel:   TI 1225 PCI-to-CardBus at slot 00:11, mem 0x7fffe000 
Mar  7 15:36:12 localhost kernel:     host opts [0]: [ring] [pci + serial irq] [pci irq 11] [lat 66/176] [bus 2/2] 
Mar  7 15:36:12 localhost kernel:     host opts [1]: [ring] [pci + serial irq] [pci irq 11] [lat 66/176] [bus 3/3] 
Mar  7 15:36:12 localhost kernel:     ISA irqs (scanned) = 4,7,9,10,15 PCI status changes 
Mar  7 15:36:12 localhost pcmcia:  cardmgr.
Mar  7 15:36:12 localhost rc: Starting pcmcia succeeded
Mar  7 15:36:12 localhost cardmgr[364]: starting, version is 3.1.11
Mar  7 15:36:12 localhost cardmgr[364]: watching 2 sockets
Mar  7 15:36:12 localhost kernel: cs: IO port probe 0x0120-0x013f: clean. 
Mar  7 15:36:12 localhost kernel: cs: IO port probe 0x1000-0x17ff: excluding 0x1000-0x10ff 
Mar  7 15:36:12 localhost cardmgr[364]: could not adjust resource: IO ports 0x100-0x4ff: Device or resource busy
Mar  7 15:36:12 localhost kernel: cs: IO port probe 0x0a00-0x0aff: clean. 
Mar  7 15:36:12 localhost cardmgr[364]: initializing socket 0
Mar  7 15:36:12 localhost kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean. 
Mar  7 15:36:12 localhost cardmgr[364]: socket 0: 3Com 572/574 Fast Ethernet
Mar  7 15:36:12 localhost cardmgr[364]: executing: 'insmod /lib/modules/2.2.12-20/pcmcia/3c574_cs.o irq_list=15'
Mar  7 15:36:12 localhost kernel: 3c574_cs.c v1.08 9/24/98 Donald Becker/David Hinds, becker@cesdis.gsfc.nasa.gov. 
Mar  7 15:36:12 localhost kernel: eth0: Megahertz 574B at io 0x120, irq 15, hw_addr 00:50:04:8E:48:98. 
Mar  7 15:36:12 localhost kernel:   ASIC rev 10, 64K FIFO split 1:1 Rx:Tx, autoselect MII interface. 
Mar  7 15:36:12 localhost cardmgr[364]: executing: './network start eth0'
Mar  7 15:36:16 localhost kernel: eth0: found link beat 
Mar  7 15:36:16 localhost kernel: eth0: link partner did not autonegotiate 
Mar  7 15:37:13 localhost dhcpcd[425]: timed out waiting for a valid DHCP server response 
Mar  7 15:37:13 localhost cardmgr[364]: + Determining IP information for eth0... failed.
Mar  7 15:37:13 localhost cardmgr[364]: start cmd exited with status 1

If I try to add/remove the card - more errors reporting "lost link beat/found link beat/link partner did not autonegotiate" are found.

Thanks again.

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None I don't think the card is the problem by David Hinds, 2000, Mar 08

Add Message to: "3com 3c574_cs (3CCFE574BT) link beat problems"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10