Next-in-Thread Next Message

Angry HELP-3CCFE575CT eth0 at Dell Inspiron3700 

Forum: 3Com PCMCIA Ethernet Adapter Issues
Date: 2000, May 09
From: Longina Przybyszewska longina

I read all messages related to 3Com 3CFE575CT CardBus card but could not see the solution to the apparently common problem:

CArd seems to be initialized correctly during bootstrap, but routning fails. Just after bootstrap 'netstat -r' hangs a little before the last line comes up:

=========

[root@dodgson init.d]# netstat -r Kernel IP routing table Destination Gateway Genmask Flags MSS Window irtt Iface

130.225.128.0 * 255.255.255.0 U 0 0 0 eth0

127.0.0.0 * 255.0.0.0 U 0 0 0 lo

default 130.225.128.1 0.0.0.0 UG 0 0 0 eth0

======

But when I run 'ping':

============

[root@dodgson init.d]# ping 130.225.128.16 PING 130.225.128.16 (130.225.128.16) from 130.225.128.110 : 56(84) bytes of data. From dodgson.imada.sdu.dk (130.225.128.110): Destination Host Unreachable

From dodgson.imada.sdu.dk (130.225.128.110): Destination Host Unreachable

From dodgson.imada.sdu.dk (130.225.128.110): Destination Host Unreachable

From dodgson.imada.sdu.dk (130.225.128.110): Destination Host Unreachable

..... From dodgson.imada.sdu.dk (130.225.128.110): Destination Host Unreachable

Fro64 bytes from brunnhilde.imada.sdu.dk (130.225.128.16): icmp_seq=28 ttl=64 time=0.5 ms

64 bytes from brunnhilde.imada.sdu.dk (130.225.128.16): icmp_seq=29 ttl=64 time=0.5 ms

64 bytes from brunnhilde.imada.sdu.dk (130.225.128.16): icmp_seq=30 ttl=64 time=0.5 ms

========== ==========

in log file from bootstrap sequence all messages related to net & PCMCIA:

=====
May  9 10:49:15 dodgson kernel: PCI: PCI BIOS revision 2.10 entry at 0xfc0ce
May  9 10:49:15 dodgson kernel: PCI: Using configuration type 1
May  9 10:49:15 dodgson kernel: PCI: Probing PCI hardware
May  9 10:49:15 dodgson kernel: Linux NET4.0 for Linux 2.2
May  9 10:49:15 dodgson kernel: Based upon Swansea University Computer Society NET3.039
May  9 10:49:15 dodgson kernel: NET4: Unix domain sockets 1.0 for Linux NET4.0.
May  9 10:49:15 dodgson kernel: NET4: Linux TCP/IP 1.0 for NET4.0
May  9 10:49:15 dodgson kernel: IP Protocols: ICMP, UDP, TCP, IGMP
May  9 10:49:15 dodgson kernel: TCP: Hash tables configured (ehash 131072 bhash
65536)
May  9 10:49:15 dodgson kernel: Initializing RT netlink socket 
.....May  9 10:49:07 dodgson init: Entering runlevel: 5
May  9 10:49:12 dodgson kudzu:  succeeded
May  9 10:49:12 dodgson sysctl: net.ipv4.ip_forward = 0
May  9 10:49:12 dodgson sysctl: net.ipv4.conf.all.rp_filter = 1
May  9 10:49:12 dodgson sysctl: net.ipv4.ip_always_defrag = 0
May  9 10:49:12 dodgson sysctl: kernel.sysrq = 0
May  9 10:49:12 dodgson network: Setting network parameters succeeded
May  9 10:49:13 dodgson network: Bringing up interface lo succeeded
May  9 10:49:13 dodgson ifup: Delaying eth0 initialization.
May  9 10:49:13 dodgson network: Bringing up interface eth0 failed 
....... 
 May  9 10:49:18 dodgson kernel: Linux PCMCIA Card Services 3.1.13
May  9 10:49:18 dodgson kernel:   kernel build: 2.2.14-5.0 #1 Tue Mar 7 21:07:39 EST 2000
May  9 10:49:18 dodgson kernel:   options:  [pci] [cardbus] [apm]
May  9 10:49:18 dodgson kernel: PCI routing table version 1.0 at 0xfbd70
May  9 10:49:18 dodgson kernel:   00:03.0 -> irq 11
May  9 10:49:18 dodgson kernel:   00:03.1 -> irq 11
May  9 10:49:18 dodgson kernel: Intel PCIC probe:
May  9 10:49:18 dodgson kernel:   TI 1225 PCI-to-CardBus at slot 00:03, mem 0x68000000
May  9 10:49:18 dodgson kernel:     host opts [0]: [ring] [serial pci & irq] [pci irq 11] [lat 32/32] [bus 32/34]
May  9 10:49:18 dodgson kernel:     host opts [1]: [ring] [serial pci & irq] [pci irq 11] [lat 32/32] [bus 35/37]
May  9 10:49:18 dodgson kernel:     PCI irq 11 seems to be wedged!
May  9 10:49:18 dodgson kernel:     PCI irq 11 test failed
May  9 10:49:18 dodgson kernel:     ISA irqs (scanned) = 3,4,7,9,10 polling inte:         
rval = 1000 ms
May  9 10:49:18 dodgson pcmcia:  cardmgr.
May  9 10:49:18 dodgson rc: Starting pcmcia succeeded
May  9 10:49:18 dodgson cardmgr[445]: starting, version is 3.1.13
May  9 10:49:18 dodgson kernel: cs: cb_alloc(bus 32): vendor 0x10b7, device 0x5257
May  9 10:49:19 dodgson cardmgr[445]: watching 2 sockets
May  9 10:49:19 dodgson kernel: cs: IO port probe 0x1000-0x17ff: clean.
May  9 10:49:19 dodgson kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x378-0x37f 0x4d0-0x4d7
May  9 10:49:19 dodgson kernel: cs: IO port probe 0x0a00-0x0aff: clean.
May  9 10:49:19 dodgson cardmgr[445]: initializing socket 0
May  9 10:49:19 dodgson cardmgr[445]: socket 0: 3Com 3CCFE575CT/3CXFE575CT Fast
EtherLink XL
May  9 10:49:19 dodgson cardmgr[445]: executing: 'insmod /lib/mo
dules/2.2.14-5.0/pcmcia/cb_enabler.o'
May  9 10:49:19 dodgson cardmgr[445]: executing: 'insmod /lib/modules/2.2.14-5.0/pcmcia/3c575_cb.o'
May  9 10:49:19 dodgson kernel: 3c59x.c:v0.99L 5/28/99 Donald Becker http://cesdis.gsfc.nasa.gov/linux/drivers/vortex.html
May  9 10:49:19 dodgson kernel: cs: cb_config(bus 32) 
May  9 10:49:19 dodgson kernel:   fn 0 bar 1: io 0x200-0x27f
May  9 10:49:19 dodgson kernel:   fn 0 bar 2: mem 0x60021000-0x6002107f
May  9 10:49:19 dodgson kernel:   fn 0 bar 3: mem 0x60020000-0x6002007f
May  9 10:49:19 dodgson kernel:   fn 0 rom: mem 0x60000000-0x6001ffff
May  9 10:49:19 dodgson kernel: vortex_attach(bus 32, function 0, device 5257)
May  9 10:49:19 dodgson kernel: eth0: 3Com 3CCFE575CT Cyclone CardBus at 0x200,
 00:50:da:d9:bf:1e, IRQ 3
May  9 10:49:19 dodgson kernel: eth0: CardBus functions mapped 60020000->c8067000
May  9 10:49:19 dodgson kernel:   8K byte-wide RAM 5:3 Rx:Tx split, MII interface.
May  9 10:49:19 dodgson kernel:   MII transceiver found at address 0, status 7809.

May 9 10:49:19 dodgson kernel: Enabling bus-master transmits and whole-frame receives. May 9 10:49:19 dodgson cardmgr[445]: executing: './network start eth0'

......

May  9 10:49:20 dodgson cardmgr[445]: initializing socket 1
May  9 10:49:20 dodgson kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.
May  9 10:49:20 dodgson cardmgr[445]: socket 1: Serial or Modem
May  9 10:49:20 dodgson cardmgr[445]: executing: 'insmod /lib/modules/2.2.14-5.0/pcmcia/serial_cs.o'
May  9 10:49:20 dodgson kernel: tty01 at 0x02f8 (irq = 9) is a 16550A
May  9 10:49:20 dodgson cardmgr[445]: executing: './serial start ttyS1'     

....

May  9 11:13:19 dodgson kernel: eth0: transmit timed out, tx_status 00 status e000.
May  9 11:13:19 dodgson kernel: eth0: Tx Ring full, refusing to send buffer.    

-=====

I have pcmcia-cs-3.1.13 and RedHAt 6.2.

thanks for help in advance

Longina

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. Sad continue story on 3CCFE575CT & Dell Inspiron3700 by Longina Przybyszewska, 2000, May 10
1. Sad Untitled by Nor Pirzkal, 2000, May 18
2. News Maybe a fix by David Hinds, 2000, May 26

Add Message to: "HELP-3CCFE575CT eth0 at Dell Inspiron3700"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10