Next-in-Thread Next Message

Question 3ccfe575bt data corruption 

Forum: 3Com PCMCIA Ethernet Adapter Issues
Date: 2000, May 20
From: Bas Michielsen BMichielsen

Hello,

I have a 3CCFE575BT pcmcia card installed on a portable running 
SuSE Linux 6.4 (SuSE-kernel 2.2.14, this one came with pcmcia 
version 3.1.11, I added pcmcia version 3.1.15 myself). 
In principle, everything seems to be okay, but the transfer of 
files, of only a few hundred kB, gives data corruption 
(tar or JPEG image files are found erroneous by the respective 
programs). The transfer seems quite slow (less than 1MB/s) and 
the hub (a 3com OfficeConnect dual speed) signals many collisions. 

There are no error messages in /var/log/messages.
I don't think it is a hardware problem, because when I do the 
same operation repeatedly, while running Windows, the transfers 
are correct. 

lsmod gives:

Module                 Size  Used by
3c575_cb               19576   2 
cb_enabler              2632   2  [3c575_cb]
ds                      6600   2  [cb_enabler]
i82365                 23328   2
pcmcia_core            51776   0  [cb_enabler ds i82365]
parport_pc              7460   0  (unused)
parport                 7464   0  [parport_pc]
serial                 42612   0  (autoclean)
memstat                 1476   0  (unused)

cat /proc/interrupts gives:
           CPU0       
  0:     522652          XT-PIC  timer
  1:      10250          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  8:          2          XT-PIC  rtc
 11:      62467          XT-PIC  i82365, eth0
 12:      62717          XT-PIC  PS/2 Mouse
 13:          1          XT-PIC  fpu
 14:    1980555          XT-PIC  ide0
NMI:          0

the fact that the IRQ 11 is allocated to both i82365 and to eth0 
looks a bit suspect to me, but I don't know how to give the 
3c575_cb module a different interrupt.

tail /var/log/messages gives
...
May 21 02:18:34 UNIKA kernel:   fn 0 bar 1: io 0x100-0x17f
May 21 02:18:34 UNIKA kernel:   fn 0 bar 2: mem 0x60021000-0x6002107f
May 21 02:18:34 UNIKA kernel:   fn 0 bar 3: mem 0x60020000-0x6002007f
May 21 02:18:34 UNIKA kernel:   fn 0 rom: mem 0x60000000-0x6001ffff
May 21 02:18:34 UNIKA kernel: cs: cb_enable(bus 35)
May 21 02:18:34 UNIKA kernel:   bridge io map 0 (flags 0x21): 0x100-0x17f
May 21 02:18:34 UNIKA kernel:   bridge mem map 0 (flags 0x1): 0x60000000-0x60021fff
May 21 02:18:34 UNIKA kernel: vortex_attach(device 23:00.0)
May 21 02:18:34 UNIKA kernel: eth0: 3Com 3CCFE575 Cyclone CardBus at 0x100,  00:50:da:9a:80:b2, IRQ 11
May 21 02:18:34 UNIKA kernel: eth0: CardBus functions mapped 60020000->c2048000
May 21 02:18:34 UNIKA kernel:   8K byte-wide RAM 5:3 Rx:Tx split, MII interface.
May 21 02:18:34 UNIKA kernel:   MII transceiver found at address 0, status 2809.
May 21 02:18:34 UNIKA kernel:   Enabling bus-master transmits and whole-frame receives.
May 21 02:18:34 UNIKA cardmgr[3203]: executing: './network start eth0'

Has anyone got an idea what I should do?

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. Note Not a fix, but a workaround by David Hinds, 2000, Jun 16

Add Message to: "3ccfe575bt data corruption"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10