Next-in-Thread Next Message

None I don't think the problem is as bad as all that 

Forum: PCMCIA driver development
Re: Warning Change in kernel (2.3.99-pre3) causing problem with cardmgr. (Brian Mays)
Re: None Unfortunately there is no easy fix; the API is broken (David Hinds)
Re: Sad Re: Unfortunately there is no easy fix; the API is broken (Steven A. DuChene)
Date: 2000, Apr 20
From: David Hinds <dhinds@pcmcia.sourceforge.org>

No bad feelings are involved, as far as I'm concerned.  And there is
nothing preventing laptop users from migrating to 2.4 whenever it is
released.

I still distribute PCMCIA drivers that build correctly on 2.3.99* and
work correctly.  Linus and others made a choice to not include some of
that code in the kernel; I pointed out what the issues were and he
made a decision that I disagreed with, but I respect his decision.  I
think it would be very unfair to criticize me for those choices, and
Linus will tell you the same thing.

Compared to the situation with Donald Becker, I think there are a few
differences.  I'm not fighting a "turf war" here, and I'm not blowing
off PCMCIA because I didn't get my way.  I continue to release timely
updates and continue to give feedback and send contributions to Linus
and other kernel developers.

I said there was no easy fix, because there really is no easy fix, not
because I'm holding out on anyone.  It is not unsolvable, but it also
is not something I can fix on my own (and my solution has already been
explicitly rejected).

-- Dave

Next-in-Thread Next Message

Add Message to: "I don't think the problem is as bad as all that"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10