Next-in-Thread Next Message

Question Problem building 3.1.13 against kernel 2.3.99-pre4 

Forum: PCMCIA driver development
Date: 2000, Apr 10
From: Steve Ward stevewa

Please have patience, this is my first post...

Got the following from make when trying this combination:

>make[1]: Entering directory >`/usr/src/pcmcia-cs-3.1.13/clients'
>cc   -MD -c -O2 -I../include -I/usr/src/linux/include -D__KERNEL__ -DEXPORT_SYMTAB -DMODVERSIONS -include /usr/src/linux/include/linux/modversions.h -DMODULE -DCARDBUS 3c575_cb.c
>In file included from /usr/src/linux/include/asm/hardirq.h:5,
                 from /usr/src/linux/include/linux/interrupt.h:44,
                 from 3c575_cb.c:76:
/usr/src/linux/include/linux/irq.h:52: requested alignment is not a constant
>In file included from /usr/src/linux/include/linux/interrupt.h:44,
                 from 3c575_cb.c:76:
/usr/src/linux/include/asm/hardirq.h:12: requested alignment is not a constant
>In file included from 3c575_cb.c:76:
/usr/src/linux/include/linux/interrupt.h:152: requested alignment is not a constant
>In file included from 3c575_cb.c:78:
/usr/src/linux/include/linux/netdevice.h:150: requested alignment is not a constant
>In file included from 3c575_cb.c:78:
/usr/src/linux/include/linux/netdevice.h:433: requested >alignment is not a constant
>make[1]: *** [3c575_cb.o] Error 1
>make[1]: Leaving directory `/usr/src/pcmcia-cs-3.1.13/clients'
>make: *** [all] Error 2

It looks like there are other issues with the 2.3.99 series, but I thought I'd add this in as well.

Tried using the in-kernel tree version, which builds correctly, but at boot it doesn't probe for IRQs correctly. It assigns IRQ 0 to both ports on my Sony PCG-F360. I can provide bootup messages if they'd be helpful...

Steve

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None Fixed in the current 3.1.14 beta by David Hinds, 2000, Apr 10
1. Sad No joy with 3.1.14 beta by Steve Ward, 2000, Apr 11
1. None Re: Sad: No joy with 3.1.14 beta by David Hinds, 2000, Apr 11
... 2 Message(s)
2. Sad 2.3.99-pre5 + Apr-06 errors + odd BogoMIPS by Cosmo, 2000, Apr 14
1. None The 06-Apr beta is not the newest; use 3.1.14 by David Hinds, 2000, Apr 14

Add Message to: "Problem building 3.1.13 against kernel 2.3.99-pre4"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10