Next-in-Thread Next Message

Note Re: two separate issues 

Forum: PCMCIA ATA/IDE Device Issues
Re: Question PCMCIA card reader problems with ISA controller (Steve McClure)
Re: None Two separate issues (David Hinds)
Date: 2000, Feb 26
From: Steve McClure smcclure

>>     ISA irqs (default) = none! polling interval = 1000 ms
>
> It looks like you're specifying an irq_list that doesn't >include any
> interrupts that are actually available?
>
> But that isn't your immediate problem.

I removed the irq_list from /etc/sysconfig/pcmcia and now dmesg reports:

Linux PCMCIA Card Services 3.1.10
  kernel build: 2.0.36 #3 Sat Oct 2 12:56:34 EDT 1999
  options:  [pci] [cardbus]
Intel PCIC probe: 
  VIA VT83C469 ISA-to-PCMCIA at port 0x3e0 ofs 0x00
    host opts [0]: [ring]
    host opts [1]: [ring]
    ISA irqs (default) = 4,7,10,11,14 polling interval = 1000 ms
cs: IO port probe 0x03e0-0x03e1: clean.
cs: memory probe 0x0d0000-0x0dffff: clean.

>
> > When I insert the card I get this from dmesg:
> > ide_cs: GetNextTuple: No more items
>
> The IDE driver isn't finding the information it needs.  Can >you post
> the output of "dump_cis"?

This is a different CF card than in my first post but same result.

dump_cis reports:

Socket 0:
  dev_info
    fn_specific 400ns, 2kb
  common_jedec 0xdf 0x01
  manfid 0x0007, 0x0000
  vers_1 4.1, "HITACHI", "FLASH", "4.0"
  funcid fixed_disk [post]
  disk_interface [ide]
  disk_features [silicon] [unique] [single]
    [sleep] [standby] [idle] [low power]
  config base 0x0200 mask 0x000f last_index 0x03
  cftable_entry 0x00 [default]
    [rdybsy] [pwrdown]
    Vcc Vnom 5V
    memory 0x0000-0x07ff @ 0x0000
  cftable_entry 0x00
    Vcc Vnom 3300mV Ipeak 45mA
  cftable_entry 0x01 [default]
    [rdybsy] [pwrdown]
    Vcc Vnom 5V
    io 0x0000-0x000f [lines=4] [8bit] [16bit]
    irq mask 0xffff [level] [pulse] [shared]
  cftable_entry 0x01
    Vcc Vnom 3300mV Ipeak 45mA
  cftable_entry 0x02 [default]
    [rdybsy] [pwrdown]
    Vcc Vnom 5V
    io 0x01f0-0x01f7, 0x03f6-0x03f7 [lines=10] [8bit] [16bit] [range]
    irq 14 [level] [pulse] [shared]
  cftable_entry 0x02
    Vcc Vnom 3300mV Ipeak 45mA
  cftable_entry 0x03 [default]
    [rdybsy] [pwrdown]
    Vcc Vnom 5V
    io 0x0170-0x0177, 0x0376-0x0377 [lines=10] [8bit] [16bit] [range]
    irq 14 [level] [pulse] [shared]
  cftable_entry 0x03
    Vcc Vnom 3300mV Ipeak 45mA

Socket 1:
  no CIS present

>
> -- Dave

Thanks, Steve

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None Re: Note: Re: two separate issues by David Hinds, 2000, Feb 26

Add Message to: "Re: two separate issues"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10