Next-in-Thread Next Message

None Smartmedia 15 second freeze  

Forum: PCMCIA ATA/IDE Device Issues
Date: 2000, Apr 02
From: J. Schmid jds

Each time a smartmedia card is inserted, my system "freezes" for approx. 15 seconds (no mouse or keyboard activity except vt-switching; display corruption in the case of switching to X). After the freeze smart media mounting, reading, writing works without (known) problems.

Hardware:

Sony-Vaio 737, simple Technology SmartMediaAdapter, OLYMPUS M-8P D3V10 SmartMedia

Software:

linux 2.2.12+patch irda3

pcmcia-packages tried: pcmcia-cs.12-Jan-00.tar.gz, pcmcia-cs-3.1.13.tar.gz, pcmcia-cs.31-Mar-00.tar.gz

The freezing is the same with all tested versions of "pcmcia"
the message:
  Apr  2 11:37:40 heidi kernel:     PCI irq 9 test failed
occurs only for the two latest versions tested.

Because of 
  Apr  2 12:03:17 heidi cardmgr[199]: error parsing CIS on socket 0: Invalid argument
I have attached the output of dump-cis.
Several error messages regarding ide follow the insertion
and a missed interrupt follows the ejection.
From the syslog:

Apr  2 11:37:40 heidi kernel: Linux PCMCIA Card Services 3.1.14
Apr  2 11:37:40 heidi kernel:   kernel build: 2.2.12 #1 Sun Mar 19 09:33:26 /etc/localtime 2000
Apr  2 11:37:40 heidi kernel:   options:  [pci] [cardbus] [apm]
Apr  2 11:37:40 heidi kernel: PCI routing table version 1.0 at 0xfdf80
Apr  2 11:37:40 heidi kernel: Intel PCIC probe: 
Apr  2 11:37:40 heidi kernel:   Ricoh RL5C478 rev 03 PCI-to-CardBus at slot 00:0a, mem 0x68000000
Apr  2 11:37:40 heidi kernel:     host opts [0]: [isa irq] [io 3/6/1] [mem 3/6/1] [pci irq 9] [lat 168/176] [bus 32/34]
Apr  2 11:37:40 heidi kernel:     host opts [1]: [isa irq] [io 3/6/1] [mem 3/6/1] [pci irq 9] [lat 168/176] [bus 35/37]
Apr  2 11:37:40 heidi kernel:     PCI irq 9 test failed
Apr  2 11:37:40 heidi kernel:     ISA irqs (default) = 3,4,5,7,10,11,12 polling interval = 1000 ms
Apr  2 11:37:41 heidi cardmgr[199]: starting, version is 3.1.14
Apr  2 11:37:42 heidi kernel: IrDA (tm) Protocols for Linux-2.3 (Dag Brattli)
Apr  2 11:37:42 heidi cardmgr[199]: config error, file './config.opts' line 45: module name not found!
Apr  2 11:37:42 heidi kernel: IrCOMM protocol (Dag Brattli)
Apr  2 11:37:42 heidi kernel: cs: IO port probe 0x1000-0x17ff: clean.
Apr  2 11:37:42 heidi kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x140-0x147 0x220-0x22f 0x320-0x327 0x378-0x37f 0x388-0x38f 0x4d0-0x4d7
Apr  2 11:37:42 heidi kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Apr  2 11:37:42 heidi cardmgr[199]: watching 2 sockets
[...]
Apr  2 12:03:17 heidi kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.
Apr  2 12:03:17 heidi cardmgr[199]: initializing socket 0
Apr  2 12:03:17 heidi cardmgr[199]: error parsing CIS on socket 0: Invalid argument
Apr  2 12:03:17 heidi cardmgr[199]: socket 0: ATA/IDE Fixed Disk
Apr  2 12:03:17 heidi cardmgr[199]: executing: 'insmod /lib/modules/2.2.12/pcmcia/ide_cs.o'
Apr  2 12:03:34 heidi kernel: hde: , ATA DISK drive
Apr  2 12:03:34 heidi kernel: hdf: no response (status = 0xeb), resetting drive
Apr  2 12:03:34 heidi kernel: hdf: no response (status = 0xeb)
Apr  2 12:03:34 heidi kernel: ide2 at 0x100-0x107,0x10e on irq 3
Apr  2 12:03:34 heidi kernel: hde: , 7MB w/1kB Cache, CHS=250/4/16
Apr  2 12:03:34 heidi kernel:  hde: hde1
Apr  2 12:03:34 heidi kernel: ide_cs: hde: Vcc = 5.0, Vpp = 12.0
Apr  2 12:03:34 heidi cardmgr[199]: executing: './ide start hde'
Apr  2 12:03:35 heidi kernel: VFS: Disk change detected on device ide2(33,0)
Apr  2 12:03:35 heidi kernel:  hde: hde1
Apr  2 12:03:35 heidi kernel: hde: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
Apr  2 12:03:35 heidi kernel: hde: drive_cmd: error=0x04 { DriveStatusError }
********ejection***************
Apr  2 12:04:31 heidi kernel: ide2: unexpected interrupt, status=0xff, count=1
Apr  2 12:04:31 heidi cardmgr[199]: shutting down socket 0
Apr  2 12:04:31 heidi cardmgr[199]: executing: './ide stop hde'
Apr  2 12:04:31 heidi cardmgr[199]: + open() failed: No such device
Apr  2 12:04:32 heidi cardmgr[199]: executing: 'rmmod ide_cs'

*******************************
/home/jschmid/software/pcmcia-cs-3.1.14/debug-tools/dump_cis -v
*******************************
Socket 0:
  offset 0x02, tuple 0x01, link 0x04
    df 4a 01 ff 
  dev_info
    fn_specific 400ns, 2kb

  offset 0x08, tuple 0x18, link 0x02
    df 01 
  common_jedec 0xdf 0x01

  offset 0x0c, tuple 0x20, link 0x02
    df 01 
  parse error: Invalid argument

  offset 0x10, tuple 0x15, link 0x15
    04 01 20 20 20 20 20 00 20 20 20 20 20 20 20 20 
    20 20 00 00 ff 
  vers_1 4.1, "     ", "          ", ""

  offset 0x27, tuple 0x21, link 0x02
    04 01 
  funcid fixed_disk [post]

  offset 0x2b, tuple 0x22, link 0x02
    01 01 
  disk_interface [ide]

  offset 0x2f, tuple 0x22, link 0x03
    02 0d 0f 
  disk_features [silicon] [unique] [single]
    [sleep] [standby] [idle] [low power]

  offset 0x34, tuple 0x1a, link 0x05
    01 03 00 02 0f 
  config base 0x0200 mask 0x000f last_index 0x03

  offset 0x3b, tuple 0x1b, link 0x0a
    c0 c0 a2 01 55 01 0e 08 00 20 
  cftable_entry 0x00 [default]
    [rdybsy] [mwait] [pwrdown]
    Vcc Vnom 5V
    Vpp1 Vnom 12V
    memory 0x0000-0x07ff @ 0x0000

  offset 0x47, tuple 0x1b, link 0x0c
    c1 41 9a 01 55 01 0e 64 f0 ff ff 20 
  cftable_entry 0x01 [default]
    [rdybsy] [pwrdown]
    Vcc Vnom 5V
    Vpp1 Vnom 12V
    io 0x0000-0x000f [lines=4] [8bit] [16bit]
    irq mask 0xffff [level] [pulse] [shared]

  offset 0x55, tuple 0x1b, link 0x0c
    82 41 18 ea 61 f0 01 07 f6 03 01 ee 
  cftable_entry 0x02
    [rdybsy]
    io 0x01f0-0x01f7, 0x03f6-0x03f7 [lines=10] [8bit] [16bit] [range]
    irq 14 [level] [pulse] [shared]

  offset 0x63, tuple 0x1b, link 0x0c
    83 41 18 ea 61 70 01 07 76 03 01 ee 
  cftable_entry 0x03
    [rdybsy]
    io 0x0170-0x0177, 0x0376-0x0377 [lines=10] [8bit] [16bit] [range]
    irq 14 [level] [pulse] [shared]

  offset 0x71, tuple 0x14, link 0x00
  no_long_link

Socket 1:
  no CIS present

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None For now, that's just the way it is by David Hinds, 2000, Apr 03
(_ None kernel knows about flash by J. Schmid, 2000, Apr 05
(_ None Changes to the IDE driver that should help by David Hinds, 2000, Apr 05
(_ None 15 second freeze solved, lockups remain by J. Schmid, 2000, Apr 08
(_ None I don't know what to suggest for the lockups by David Hinds, 2000, Apr 10

Add Message to: "Smartmedia 15 second freeze "

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10