Next-in-Thread Next Message

None smartmedia adaptor w dell inspiron 5k 

Forum: PCMCIA ATA/IDE Device Issues
Date: 2000, Apr 04
From: John Ruttenberg rutt

I have:

	pcmcia-3.1.13 + a patch
            (so that pci status changes work)
	linux-2.2.14
	dell inspiron 5k
	simple technology smartmedia adaptor

When I insert this card (with no other cards inserted) it
makes the two good beeps, but it doesn't actually work.
Here is what the syslog shows:

Apr  4 18:21:30 alice kernel: Linux PCMCIA Card Services 3.1.13 
Apr  4 18:21:30 alice kernel:   kernel build: 2.2.14-5.0 #1 Tue Mar 7 21:07:39 EST 2000 
Apr  4 18:21:30 alice kernel:   options:  [pci] [cardbus] [apm] [pnp] 
Apr  4 18:21:30 alice kernel: PCI routing table version 1.0 at 0xfdf50 
Apr  4 18:21:30 alice kernel: PnP: PNP BIOS installation structure at 0xc00f7220 
Apr  4 18:21:30 alice kernel: PnP: PNP BIOS version 1.0, entry at f0000:a77c, dseg at 400 
Apr  4 18:21:30 alice kernel: Intel PCIC probe:  
Apr  4 18:21:30 alice kernel:   TI 1225 PCI-to-CardBus at slot 00:04, mem 0x68000000 
Apr  4 18:21:30 alice kernel:     host opts [0]: [ring] [serial pci & irq] [pci irq 11] [lat 168/32] [bus 32/34] 
Apr  4 18:21:30 alice kernel:     host opts [1]: [ring] [serial pci & irq] [pci irq 11] [lat 168/32] [bus 35/37] 
Apr  4 18:21:30 alice kernel:     ISA irqs (scanned) = 9,10 PCI status changes 
Apr  4 18:21:30 alice cardmgr[1081]: starting, version is 3.1.13
Apr  4 18:21:30 alice cardmgr[1081]: watching 2 sockets
Apr  4 18:21:30 alice kernel: cs: IO port probe 0x1000-0x17ff: clean. 
Apr  4 18:21:30 alice kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x170-0x177 0x370-0x377 
Apr  4 18:21:30 alice cardmgr[1081]: could not adjust resource: IO ports 0x300-0x3ff: Device or resource busy
Apr  4 18:21:30 alice cardmgr[1081]: could not adjust resource: IO ports 0x200-0x27f: Device or resource busy
Apr  4 18:21:57 alice cardmgr[1081]: initializing socket 1
Apr  4 18:21:57 alice kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean. 
Apr  4 18:21:57 alice cardmgr[1081]: error parsing CIS on socket 1: Invalid argument
Apr  4 18:21:57 alice cardmgr[1081]: socket 1: ATA/IDE Fixed Disk
Apr  4 18:21:57 alice cardmgr[1081]: executing: 'insmod /lib/modules/2.2.14-5.0/pcmcia/ide_cs.o'
Apr  4 18:22:02 alice kernel: hdc: , ATA DISK drive 
Apr  4 18:22:02 alice kernel: ide1 at 0x100-0x107,0x10e on irq 9 
Apr  4 18:22:02 alice kernel: hdc: , 31MB w/1kB Cache, CHS=500/8/16 
Apr  4 18:22:02 alice kernel:  hdc: hdc1 
Apr  4 18:22:02 alice kernel: ide_cs: hdc: Vcc = 5.0, Vpp = 12.0 
Apr  4 18:22:02 alice cardmgr[1081]: executing: './ide start hdc'
Apr  4 18:22:02 alice kernel:  hdc: hdc1 
Apr  4 18:22:02 alice kernel: hdc: drive_cmd: status=0x51 { DriveReady SeekComplete Error } 
Apr  4 18:22:02 alice kernel: hdc: drive_cmd: error=0x04 { DriveStatusError } 
Apr  4 18:22:34 alice cardmgr[1081]: shutting down socket 1
Apr  4 18:22:34 alice cardmgr[1081]: executing: './ide stop hdc'
Apr  4 18:22:34 alice modprobe: modprobe: Can't locate module block-major-22
Apr  4 18:22:34 alice cardmgr[1081]: + open() failed: No such device
Apr  4 18:22:34 alice cardmgr[1081]: executing: 'rmmod ide_cs'

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 2 3 All

1. Ok The card actually works by David Hinds, 2000, Apr 04

Add Message to: "smartmedia adaptor w dell inspiron 5k"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10