Next-in-Thread Next Message

Note Log of same card working on desktop computer 

Forum: PCMCIA ATA/IDE Device Issues
Re: Sad ATA Flash card fails on Thinkpad 240 (Eric Smith)
Date: 2000, Jul 14
From: Eric Smith brouhaha

Last night I recorded the info from using the same card on my desktop computer. On insertion, the kernel logged:

Jul 14 00:02:20 hubbub cardmgr[419]: initializing socket 0
Jul 14 00:02:20 hubbub cardmgr[419]: socket 0: ATA/IDE Fixed Disk
Jul 14 00:02:20 hubbub cardmgr[419]: executing: 'insmod /lib/modules/2.2.12-20/pcmcia/ide_cs.o'
Jul 14 00:02:22 hubbub kernel: hdc: SunDisk SDP-10.4, ATA DISK drive 
Jul 14 00:02:22 hubbub kernel: hdd: SunDisk SDP-10.4, ATA DISK drive 
Jul 14 00:02:22 hubbub kernel: ide2: ports already in use, skipping probe 
Jul 14 00:02:22 hubbub kernel: ide1 at 0x100-0x107,0x10e on irq 9 
Jul 14 00:02:22 hubbub kernel: hdc: SunDisk SDP-10.4, 10MB w/1kB Cache, CHS=320/2/32 
Jul 14 00:02:22 hubbub kernel: hdd: SunDisk SDP-10.4, 10MB w/1kB Cache, CHS=320/2/32 
Jul 14 00:02:22 hubbub kernel:  hdc: hdc1 
Jul 14 00:02:22 hubbub kernel:  hdd: hdd1 
Jul 14 00:02:22 hubbub kernel: ide_cs: hdc: Vcc = 5.0, Vpp = 12.0 
Jul 14 00:02:22 hubbub cardmgr[419]: executing: './ide start hdc'
Jul 14 00:02:22 hubbub cardmgr[419]: + ./ide: /sbin/ide_info: No such file or di
rectory

cardctl status reported:

Socket 0:
  5V 16-bit card present
  Function 0: ready, battery dead, battery low

cardctl config reported:

Socket 0:
  Vcc = 5.0, Vpp1 = 12.0, Vpp2 = 12.0
  Interface type is memory and I/O
  IRQ 9 is exclusive, level mode, enabled
  Function 0:
    Config register base = 0x0200
      Option = 0x41, status = 0000, pin = 0000, copy = 0000
    I/O window 1: 0x0100 to 0x010f, auto sized

cardctl ident reported:

Socket 0:
  product info: "SunDisk", "SDP", "1.5"
  manfid: 0x0045, 0x0101
  function: 4 (fixed disk)

The card works fine there; any idea why the ThinkPad 240 would think that it's a 3.3V card?

I don't have Windows on the ThinkPad, so I can't determine whether that works. Maybe I can set up a DOS boot disk with the appropriate enabler and try it out.

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None I'm not sure what's wrong on the Thinkpad by David Hinds, 2000, Jul 15

Add Message to: "Log of same card working on desktop computer"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10