Next-in-Thread Next Message

More upgrade didn't solve all issues... :-( 

Forum: PCMCIA ATA/IDE Device Issues
Re: Question Problems with PCI to PCMCIA Adpater (Nicolas Malsch)
Re: None Interrupt configuration issue: driver upgrade needed (David Hinds)
Date: 2000, Aug 22
From: Nicolas Malsch nick

Dave,

I upgraded the drivers which seems to make the reader a little more normalle but then I get an interrupt failure. Here are two of my tests results...

********************************************************

/vi var/log/messages with irq_mode=0

********************************************************

Aug 21 10:44:57 idefix cardmgr[501]: exiting
Aug 21 10:44:57 idefix kernel: unloading PCMCIA Card Services
Aug 21 10:44:57 idefix kernel: Linux PCMCIA Card Services 3.1.19
Aug 21 10:44:57 idefix kernel:   kernel build: 2.2.14-5.0 #1 Tue Mar 7 21:07:39 EST 2000
Aug 21 10:44:57 idefix kernel:   options:  [pci] [cardbus] [apm]
Aug 21 10:44:57 idefix kernel: PCI routing table version 1.0 at 0xfdf20
Aug 21 10:44:57 idefix kernel: Intel PCIC probe:
Aug 21 10:44:57 idefix kernel:   Ricoh RL5C476 rev 80 PCI-to-CardBus at slot 00:10, mem 0x68000000
Aug 21 10:44:57 idefix kernel:     host opts [0]: [pci only] [io 3/6/1] [mem 3/6/1] [pci irq 9] [lat 168/176] [bus 32/34]
Aug 21 10:44:57 idefix kernel:     host opts [1]: [pci only] [io 3/6/1] [mem 3/6/1] [pci irq 11] [lat 168/176] [bus 35/37]
Aug 21 10:44:57 idefix kernel:     PCI card interrupts, PCI status changes
Aug 21 10:44:57 idefix cardmgr[961]: starting, version is 3.1.19
Aug 21 10:44:57 idefix cardmgr[961]: watching 2 sockets
Aug 21 10:44:57 idefix kernel: cs: IO port probe 0x1000-0x17ff: excluding 0x1080-0x10ff 0x1400-0x1407 0x1410-0x1417
Aug 21 10:44:57 idefix kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x200-0x207 0x330-0x337 0x378-0x37f 0x4d0-0x4d7
Aug 21 10:44:57 idefix kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Aug 21 10:45:07 idefix cardmgr[961]: initializing socket 1
Aug 21 10:45:07 idefix kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.
Aug 21 10:45:07 idefix cardmgr[961]: socket 1: ATA/IDE Fixed Disk
Aug 21 10:45:07 idefix cardmgr[961]: executing: 'modprobe ide_cs'
Aug 21 10:46:48 idefix kernel: hde: no response (status = 0xff)
Aug 21 10:47:11 idefix kernel: ide_cs: ide_register() at 0x100 & 0x10e, irq 11 failed
Aug 21 10:47:12 idefix cardmgr[961]: get dev info on socket 1 failed: Resource temporarily unavailable
Aug 21 10:47:12 idefix cardmgr[961]: shutting down socket 1
Aug 21 10:47:12 idefix cardmgr[961]: executing: 'modprobe -r ide_cs'

************************************************************************

vi /var/log/messages without any options...

************************************************************************

Aug 21 10:54:00 idefix cardmgr[961]: exiting
Aug 21 10:54:00 idefix kernel: unloading PCMCIA Card Services
Aug 21 10:54:00 idefix kernel: Linux PCMCIA Card Services 3.1.19
Aug 21 10:54:00 idefix kernel:   kernel build: 2.2.14-5.0 #1 Tue Mar 7 21:07:39 EST 2000
Aug 21 10:54:00 idefix kernel:   options:  [pci] [cardbus] [apm]
Aug 21 10:54:00 idefix kernel: PCI routing table version 1.0 at 0xfdf20
Aug 21 10:54:00 idefix kernel: Intel PCIC probe:
Aug 21 10:54:00 idefix kernel:   Ricoh RL5C476 rev 80 PCI-to-CardBus at slot 00:10, mem 0x68000000
Aug 21 10:54:00 idefix kernel:     host opts [0]: [isa irq] [io 3/6/1] [mem 3/6/1] [pci irq 9] [lat 168/176] [bus 32/34]
Aug 21 10:54:00 idefix kernel:     host opts [1]: [isa irq] [io 3/6/1] [mem 3/6/1] [pci irq 11] [lat 168/176] [bus 35/37]
Aug 21 10:54:00 idefix kernel:     ISA irqs (default) = 4,5,7 PCI status changes
Aug 21 10:54:00 idefix cardmgr[1048]: starting, version is 3.1.19
Aug 21 10:54:00 idefix cardmgr[1048]: watching 2 sockets
Aug 21 10:54:00 idefix kernel: cs: IO port probe 0x1000-0x17ff: excluding 0x1080-0x10ff 0x1400-0x1407 0x1410-0x1417
Aug 21 10:54:00 idefix kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x200-0x207 0x330-0x337 0x378-0x37f 0x4d0-0x4d7
Aug 21 10:54:00 idefix kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Aug 21 10:54:14 idefix cardmgr[1048]: initializing socket 1
Aug 21 10:54:14 idefix kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.
Aug 21 10:54:14 idefix cardmgr[1048]: socket 1: ATA/IDE Fixed Disk
Aug 21 10:54:14 idefix cardmgr[1048]: executing: 'modprobe ide_cs'
Aug 21 10:55:21 idefix kernel: hde: no response (status = 0xff)
Aug 21 10:55:43 idefix kernel: ide_cs: ide_register() at 0x100 & 0x10e, irq 5 failed
Aug 21 10:55:44 idefix cardmgr[1048]: get dev info on socket 1 failed: Resource temporarily unavailable
Aug 21 10:55:44 idefix cardmgr[1048]: shutting down socket 1
Aug 21 10:55:44 idefix cardmgr[1048]: executing: 'modprobe -r ide_cs'

Should I just try irqs randomly using the "pci_irq_list options"? Is there another issue that I am not aware of? In both case the computer hangs when inserting a card. If I take the card out, the computer reacts again (after a few seconds).

	Thanx, Nicolas

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None Hmmm, I think this is an IDE driver bug by David Hinds, 2000, Aug 23

Add Message to: "upgrade didn't solve all issues... :-("

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10