Next-in-Thread Next Message

Question Shuttle Tech PCMCIA IDE/ATA HDD 

Forum: PCMCIA ATA/IDE Device Issues
Date: 1999, Dec 21
From: Ronald Yeo ronyeo

Hi,
 I have a PCMCIA HDD, that I have not been able to get running
in Linux.  (Shuttle Technology) In Win, it is setup as a primary-slave
and it is seen when I insert the card.  
 FYI, the devs in my /dev/ dir only goes to hdh9.

Dec  6 01:40:15 pc15 cardmgr[342]: socket 0: ATA/IDE Fixed Disk
Dec  6 01:40:15 pc15 cardmgr[342]: executing: 'insmod /lib/modules/2.2.13-7mdk/pcmcia/ide_cs.o'
Dec  6 01:40:20 pc15 kernel: hdl: ST92130AG, ATA DISK drive
Dec  6 01:40:20 pc15 kernel: ide5 at 0x160-0x167,0x366 on irq 3
Dec  6 01:40:20 pc15 kernel: hdl: ST92130AG, 2062MB w/0kB Cache, CHS=4191/16/63
Dec  6 01:40:20 pc15 kernel:  hdl: [PTBL] [523/128/63] hdl1 < hdl5 hdl6 hdl7 hdl8 >
Dec  6 01:40:20 pc15 kernel: ide_cs: hdk: Vcc = 5.0, Vpp = 0.0
Dec  6 01:40:20 pc15 cardmgr[342]: executing: './ide start hdk'
Dec  6 01:40:20 pc15 cardmgr[342]: + ./MAKEDEV: don't know how to make device "hdk"
Dec  6 01:40:20 pc15 cardmgr[342]: + open() failed: No such file or directory
Dec  6 01:40:20 pc15 cardmgr[342]: + ./ide: ./ide.opts: No such file or directory
Dec  6 01:40:20 pc15 cardmgr[342]: start cmd exited with status 1  

When I have another card (modem/nic combo) in the socket, I get an additional 2 line :

Dec  6 00:50:07 pc15 kernel: ide2: ports already in use, skipping probe
Dec  6 00:50:08 pc15 kernel: ide2: ports already in use, skipping probe

Appreciate any pointers.

I'm at my wit's end as I have been struggling with this for a long time. It's also one of the few last things that's tying me to MS.

Kernel is 2.2.13-7mdk and kernel-pcmcia-cs-2.2.13-7mdk

Ronald

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None MAKEDEV is not smart enough... by David Hinds, 1999, Dec 28

Add Message to: "Shuttle Tech PCMCIA IDE/ATA HDD"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10