Next-in-Thread Next Message

Question Unresolved symbols installing pcmcia.12-May-00 under RedHat 6.2 

Forum: PCMCIA Installation and Configuration Issues
Date: 2000, May 18
From: Michael Barton mgbarton

The pcmcia package that installed with RedHat 6.2 doesn't
correctly handle my 3Com 3CCFEM656BT Ethernet card (I'll post
another thread about that...), so I decided to try the latest
version from pcmcia.sourceforge.org: pcmcia-12-May-00.tar.gz.

The config went fine:

-------------------------------

    -------- Linux PCMCIA Configuration Script --------

The default responses for each question are correct for most users.
Consult the PCMCIA-HOWTO for additional info about each option.

Linux source directory [/usr/src/linux]: 

The kernel source tree is version 2.2.14-5.0.
The current kernel build date is Tue Mar 7 21:07:39 2000.

Alternate target install directory []: 
Build 'trusting' versions of card utilities (y/n) [n]: 
Include 32-bit (CardBus) card support (y/n) [y]: 
Include PnP BIOS resource checking (y/n) [n]: 
Module install directory [/lib/modules/2.2.14-5.0]: 

Kernel configuration options:
    Symmetric multiprocessing support is disabled.
    PCI BIOS support is enabled.
    Power management (APM) support is enabled.
    SCSI support is enabled.
    Networking support is enabled.
     Radio network interface support is enabled.
     Token Ring device support is enabled.
     Fast switching is disabled.
    Module version checking is enabled.
    /proc filesystem support is enabled.
    Maximum physical memory: 1GB

It looks like you have a System V init file setup.

X Windows include files found.
Forms library not installed.
    If you wish to build the 'cardinfo' control panel, you need the Forms
    library and the X Windows include files.  See the HOWTO for details.

Configuration successful.


----------------------------------------------------------

The make went file too:

----------------------------------------------------------

make[1]: Entering directory `/home/mgb/additions/pcmcia/pcmcia-cs-3.1.15/modules'
cc   -MD -O2 -Wall -Wstrict-prototypes -pipe -I../include -I/usr/src/linux/include  -D__KERNEL__ -DMODULE -c cs.c
cc   -MD -O2 -Wall -Wstrict-prototypes -pipe -I../include -I/usr/src/linux/include  -D__KERNEL__ -DMODULE -c cistpl.c
.....

----------------------------------------------------------

But when I tried to install it, I got the following error:

----------------------------------------------------------

-> Running depmod...
depmod: *** Unresolved symbols in /lib/modules/2.2.14-5.0/pcmcia/3c575_cb.o


-----------------------------------------------------------

SO I tried to install the module manually:

/sbin/insmod /lib/modules/2.2.14-5.0/pcmcia/3c575_cb.o

and was told:

/lib/modules/2.2.14-5.0/pcmcia/3c575_cb.o: unresolved symbol outsl_ns
/lib/modules/2.2.14-5.0/pcmcia/3c575_cb.o: unresolved symbol unregister_driver
/lib/modules/2.2.14-5.0/pcmcia/3c575_cb.o: unresolved symbol insl_ns
/lib/modules/2.2.14-5.0/pcmcia/3c575_cb.o: unresolved symbol register_driver


Did I miss something?
Michael

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None Well, it is a beta, after all by David Hinds, 2000, May 18

Add Message to: "Unresolved symbols installing pcmcia.12-May-00 under RedHat 6.2"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10