Next-in-Thread Next Message

Sad adding #include <asm/errno.h> seems to help..  

Forum: PCMCIA Installation and Configuration Issues
Re: None pcmcia-3.1.14 - error during 'make all' .. (Rene Mikkelsen)
Re: None This is not really a PCMCIA problem (David Hinds)
Date: 2000, Jun 01
From: Rene Mikkelsen k2OS

hmm I added #include <asm/errno.h> to all complaining files and everything compiled ok, but. . after 'make install' and restarting pcmcia the card still didn't work.. for some reason the card is detected as memorycard? This appears *very* strange as I have been using thhe same card in this machine running Linux for almost two years now without any trouble..I can even install via net without any trouble..

this is what /var/log/messages says when starting pcmcia and inserting the card:

<snip>

Jun  3 14:28:50 slet cardmgr[4818]: starting, version is 3.1.14
Jun  3 14:28:50 slet cardmgr[4818]: no pcmcia driver in /proc/devices
Jun  3 14:28:50 slet cardmgr[4818]: exiting
Jun  3 14:29:44 slet kernel: Linux PCMCIA Card Services 3.1.14 
Jun  3 14:29:44 slet kernel:   kernel build: 2.2.14 #1 Fri Jun 2 18:24:36 CEST 2000 
Jun  3 14:29:44 slet kernel:   options:  [pci] [apm] [pnp] 
Jun  3 14:29:44 slet kernel: Intel PCIC probe:  
Jun  3 14:29:44 slet kernel:   Cirrus PD672x rev 00 ISA-to-PCMCIA at port 0x3e0 ofs 0x00 
Jun  3 14:29:44 slet kernel:     host opts [0]: [ring] [65/6/0] [1/15/0] 
Jun  3 14:29:44 slet kernel:     host opts [1]: [ring] [65/6/0] [1/15/0] 
Jun  3 14:29:44 slet kernel:     ISA irqs (default) = 3,4,5,7,9,10,11 polling interval = 1000 ms 
Jun  3 14:29:44 slet cardmgr[4833]: starting, version is 3.1.14
Jun  3 14:29:44 slet cardmgr[4833]: watching 2 sockets
Jun  3 14:29:44 slet kernel: cs: IO port probe 0x1000-0x17ff: excluding 0x11f0-0x11f7 0x1240-0x124f 0x1388-0x138f 0x13f0-0x13f7 0x15f0-0x15f7 0x1640-0x164f 0x1788-0x178f 0x17f0-0x17f7 
Jun  3 14:29:44 slet kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x240-0x24f 0x378-0x37f 0x388-0x38f 0x398-0x39f 0x3b0-0x3e7 0x408-0x40f 0x480-0x48f 0x4d0-0x4d7 
Jun  3 14:29:44 slet kernel: cs: IO port probe 0x0a00-0x0aff: excluding 0xa40-0xa4f 
Jun  3 14:30:37 slet cardmgr[4833]: initializing socket 1
Jun  3 14:30:37 slet kernel: cs: memory probe 0x0d0000-0x0dffff: excluding 0xd0000-0xdffff 
Jun  3 14:30:37 slet kernel: cs: memory probe 0x0c0000-0x0cffff: excluding 0xc0000-0xcffff 
Jun  3 14:30:37 slet cardmgr[4833]: socket 1: Anonymous Memory
Jun  3 14:30:38 slet cardmgr[4833]: executing: 'insmod /lib/modules/2.2.14/pcmcia/memory_cs.o'
Jun  3 14:30:38 slet kernel: memory_cs: mem0: anonymous: unknown size 
Jun  3 14:30:38 slet cardmgr[4833]: executing: './memory start mem0'
</snip>

this is what used to happen..

<snip>

May 12 12:30:44 slet cardmgr[647]: initializing socket 1
May 12 12:30:44 slet cardmgr[647]: socket 1: 3Com 3c589D Ethernet
May 12 12:30:44 slet cardmgr[647]: executing: 'insmod /lib/modules/2.2.14/pcmcia/3c589_cs.o'
May 12 12:30:44 slet kernel: eth0: 3Com 3c589, io 0x300, irq 3, hw_addr 00:60:97:8F:1F:9F 
May 12 12:30:44 slet kernel:   8K FIFO split 5:3 Rx:Tx, auto xcvr 
May 12 12:30:44 slet cardmgr[647]: executing: './network start eth0'
May 12 12:30:47 slet kernel: eth0: flipped to 10baseT 
May 12 12:30:56 slet kernel: eth0: flipped to 10baseT 
</snip>

veeeeery strange... I hope not that my pcmcia-card has been toasted :((

/René

Next-in-Thread Next Message

Add Message to: "adding #include <asm/errno.h> seems to help.. "

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10