Next-in-Thread Next Message

Question Lucent PCI bridge problems 

Forum: PCMCIA Installation and Configuration Issues
Date: 2000, Jul 04
From: Philippe Clérié pclerie

Hi everyone:

I am having a difficult time installing a Lucent WavelanIEEE card. I am stuck because an irq test failed. Previous attempts with pcmcia-cs 3.1.13 failed with "unknown PCI interrupt router".

I have tried several options mentionned in some of the messages on this forum and none works. Specifically, it does not matter what irq_mode value I use. No irq_list has worked. I also tried cb_pci_irq=11. Always the same results.

The computer is an AcerPower Sn with RedHat 6.0. Hope someone can give me a clue.

Thanks, Philippe

From /var/log/messages
========================
Linux PCMCIA Card Services 3.1.17
  kernel build: 2.2.5-15 #1 Mon Apr 19 21:39:28 EDT 1999
  options:  [pci] [cardbus] [apm] [pnp]
PCI routing table version 1.0 at 0xf7900
PnP: PNP BIOS installation structure at 0xc00f5f50
PnP: PNP BIOS version 1.0, entry at f9e00:0, dseg at f0000
Intel PCIC probe: 
  TI 1225 rev 01 PCI-to-CardBus at slot 00:10, mem 0x68000000
    host opts [0]: [pci only] [pci irq 11] [lat 168/176] [bus 0/34]
    host opts [1]: [pci only] [pci irq 11] [lat 168/176] [bus 0/37]
    PCI irq 11 test failed
    *NO* card interrupts, polling interval = 1000 ms
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: clean.
cs: IO port probe 0x0a00-0x0aff: clean.

Dump_irq
=========
Interrupt routing table found at address 0xf7900:
  Version 1.0, size 0x00a0
  Interrupt router is device 00:07.0
  PCI exclusive interrupt mask: 0x0000
  Compatible router: vendor 0x10b9 device 0x1533

Device 00:01.0 (slot 0):
  INTA: link 0x01, irq mask 0x1ef8
  INTB: link 0x02, irq mask 0x1ef8
  INTC: link 0x03, irq mask 0x1ef8
  INTD: link 0x04, irq mask 0x1ef8

Device 00:0b.0 (slot 0):
  INTA: link 0x04, irq mask 0x1ef8

Device 00:02.0 (slot 0):
  INTA: link 0x59, irq mask 0x1ef8

Device 00:0f.0 (slot 0):

Device 00:03.0 (slot 0):

Device 00:14.0 (slot 1):
  INTA: link 0x01, irq mask 0x1ef8
  INTB: link 0x02, irq mask 0x1ef8
  INTC: link 0x03, irq mask 0x1ef8
  INTD: link 0x04, irq mask 0x1ef8

Device 00:13.0 (slot 2):
  INTA: link 0x02, irq mask 0x1ef8
  INTB: link 0x03, irq mask 0x1ef8
  INTC: link 0x04, irq mask 0x1ef8
  INTD: link 0x01, irq mask 0x1ef8

Device 00:10.0 (slot 3):
  INTA: link 0x03, irq mask 0x1ef8
  INTB: link 0x04, irq mask 0x1ef8
  INTC: link 0x01, irq mask 0x1ef8
  INTD: link 0x02, irq mask 0x1ef8

Interrupt router at 00:07.0: AcerLabs Aladdin M1533 PCI-to-ISA bridge
  INT1 (link 1): irq 9
  INT2 (link 2): irq 10
  INT3 (link 3): irq 11
  INT4 (link 4): irq 5
  INT5 (link 5): unrouted
  INT6 (link 6): unrouted
  INT7 (link 7): unrouted
  INT8 (link 8): unrouted
  Serial IRQ: [disabled] [quiet] [frame=21] [pulse=12]

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. Ok Untitled by Philippe Clérié, 2000, Jul 05

Add Message to: "Lucent PCI bridge problems"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10