Next-in-Thread Next Message

Question IRQ problem with Ricoh R5C476II PCI-Cardbus bridge 

Forum: PCMCIA Installation and Configuration Issues
Date: 2000, Aug 06
From: Leonard Ye leonardye

I tried to make a wireless LAN card working on my Desktop. There are two adaptors: ISA-PCMCIA adaptor and PCI-PCMCIA adaptor (Ricoh R5C476II PCI-Cardbus bridge). RedHat 6.2 - pcmcia-cs-3.1.19 are used.

If the wireless card is in the ISA adaptor slot, everything works fine. But when this card is inserted into PCI adaptor, it can be configured successfully, but does not receive any packets afterwards. After reading the PCMCIA-HOWTO, I tried to set the irq_mode in PCIC_OPTS. But done of them sees to be working:

logging for irq_mode = 0:
/******************************************/
Aug  6 19:38:42 localhost kernel: Linux PCMCIA Card Services 3.1.19 
Aug  6 19:38:42 localhost kernel:   kernel build: 2.2.14-5.0 #5 Sat Jun 24 14:01:44 SGT 2000 
Aug  6 19:38:42 localhost kernel:   options:  [pci] [cardbus] [apm] [pnp] 
Aug  6 19:38:42 localhost kernel: PCI routing table version 1.0 at 0xf0c70 
Aug  6 19:38:42 localhost kernel: PnP: PNP BIOS installation structure at 0xc00fc130 
Aug  6 19:38:42 localhost kernel: PnP: PNP BIOS version 1.0, entry at f0000:c160, dseg at f0000 
Aug  6 19:38:42 localhost kernel: Intel PCIC probe:  
Aug  6 19:38:42 localhost kernel:   Ricoh RL5C476 rev 80 PCI-to-CardBus at slot 00:0c, mem 0x68000000 
Aug  6 19:38:42 localhost kernel:     host opts [0]: [pci only] [io 3/6/1] [mem 3/6/1] [pci irq 11] [lat 32/176] [bus 32/34] 
Aug  6 19:38:42 localhost kernel:     host opts [1]: [pci only] [io 3/6/1] [mem 3/6/1] [no pci irq] [lat 32/176] [bus 35/37] 
Aug  6 19:38:42 localhost kernel:     *NO* card interrupts, polling interval = 1000 ms 
/******************************************/

in this case, the wireless LAN card driver cannot find any IRQ available.

logging for irq_mode = 1
/******************************************/
Aug  6 19:40:20 localhost kernel: Linux PCMCIA Card Services 3.1.19 
Aug  6 19:40:20 localhost kernel:   kernel build: 2.2.14-5.0 #5 Sat Jun 24 14:01:44 SGT 2000 
Aug  6 19:40:20 localhost kernel:   options:  [pci] [cardbus] [apm] [pnp] 
Aug  6 19:40:20 localhost kernel: PCI routing table version 1.0 at 0xf0c70 
Aug  6 19:40:20 localhost kernel: PnP: PNP BIOS installation structure at 0xc00fc130 
Aug  6 19:40:20 localhost kernel: PnP: PNP BIOS version 1.0, entry at f0000:c160, dseg at f0000 
Aug  6 19:40:20 localhost kernel: Intel PCIC probe:  
Aug  6 19:40:20 localhost kernel:   Ricoh RL5C476 rev 80 PCI-to-CardBus at slot 00:0c, mem 0x68000000 
Aug  6 19:40:20 localhost kernel:     host opts [0]: [isa irq] [io 3/6/1] [mem 3/6/1] [pci irq 11] [lat 32/176] [bus 32/34] 
Aug  6 19:40:20 localhost kernel:     host opts [1]: [isa irq] [io 3/6/1] [mem 3/6/1] [no pci irq] [lat 32/176] [bus 35/37] 
Aug  6 19:40:20 localhost kernel:     ISA irqs (default) = 5,9 polling interval = 1000 ms 
/******************************************/

in this case, the card can be successfully configured, and IRQ 5 is registered for use. But after that, no interrupt can be received by the wireless card.

logging for irq_mode=2
/******************************************/
Aug  6 19:43:33 localhost kernel:   Ricoh RL5C476 rev 80 PCI-to-CardBus at slot 00:0c, mem 0x68000000 
Aug  6 19:43:33 localhost kernel:     host opts [0]: [serial irq] [io 3/6/1] [mem 3/6/1] [pci irq 11] [lat 32/176] [bus 32/34] 
Aug  6 19:43:33 localhost kernel:     host opts [1]: [serial irq] [io 3/6/1] [mem 3/6/1] [no pci irq] [lat 32/176] [bus 35/37] 
Aug  6 19:43:33 localhost kernel:     PCI irq 11 seems to be wedged! 
Aug  6 19:43:33 localhost kernel:     ISA irqs (<6>    PCI irq 9 seems to be wedged! 
Aug  6 19:43:33 localhost kernel: default) = 5,9 polling interval = 1000 ms 
/******************************************/

the behaviour of the wireless card is the same as that of irq_mode=1.

I have been working on this problem for 1 week with heavy casualities of my hair. Any hints or advices will be really appreciated.

Regards,
Leonard Ye

Next-in-Thread Next Message

Add Message to: "IRQ problem with Ricoh R5C476II PCI-Cardbus bridge"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10