Next-in-Thread Next Message

Question PCMCIA won't start (Kernel 2.4.0-test5, pcmcia-cs-3.1.20) 

Forum: PCMCIA Installation and Configuration Issues
Date: 2000, Aug 10
From: Talei McLeod talei

Hi,

I am having terrible troubles getting the PCMCIA package to work on my PC.

I have kernel 2.4.0-test5 installed. I originally compiled this with all of the PCMCIA options, but after reading a previous message, I have since compiled the kernel with no PCMCIA options.

Instead I have compiled the pcmcia-cs-3.1.20 package.

I should point out that I am using a PCMCIA internal ISA card reader for a desktop with a VIA VT83C479 controller chip. This should be OK.

Also, isapnp detects this PCMCIA reader.

On startup, these are the messages that are written to the log :

Aug 10 15:02:02 sydhcp131216 kernel: isapnp: Scanning for Pnp cards... 
Aug 10 15:02:02 sydhcp131216 kernel: isapnp: Card 'VIA PCMCIA CARD' 
Aug 10 15:02:02 sydhcp131216 kernel: isapnp: 1 Plug & Play card detected total 

Aug 10 15:02:03 sydhcp131216 pcmcia: Starting PCMCIA services:
Aug 10 15:02:03 sydhcp131216 kernel: Linux PCMCIA Card Services 3.1.20 
Aug 10 15:02:03 sydhcp131216 kernel:   kernel build: 2.4.0-test5 #16 SMP Thu Aug 10 12:59:18 EST 2000 
Aug 10 15:02:03 sydhcp131216 kernel:   options:  [pci] [cardbus] [apm] 
Aug 10 15:02:03 sydhcp131216 kernel: Intel PCIC probe: not found. 
Aug 10 15:02:03 sydhcp131216 pcmcia:  modules
Aug 10 15:02:03 sydhcp131216 kernel: ds: no socket drivers loaded! 
Aug 10 15:02:03 sydhcp131216 pcmcia: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
Aug 10 15:02:03 sydhcp131216 pcmcia: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
Aug 10 15:02:03 sydhcp131216 cardmgr[472]: starting, version is 3.1.20
Aug 10 15:02:03 sydhcp131216 pcmcia:  cardmgr.
Aug 10 15:02:03 sydhcp131216 pcmcia: /lib/modules/2.4.0-test5/pcmcia/i82365.o: init_module: No such device
Aug 10 15:02:03 sydhcp131216 pcmcia: /lib/modules/2.4.0-test5/pcmcia/ds.o: init_module: Operation not permitted
Aug 10 15:02:03 sydhcp131216 rc: Starting pcmcia succeeded
Aug 10 15:02:04 sydhcp131216 cardmgr[472]: no pcmcia driver in /proc/devices
Aug 10 15:02:04 sydhcp131216 cardmgr[472]: exiting

If I run "pcmcia status" this states that the cardmgr is not running.

If i try "pcmcia start" here is the error mesg :

Starting PCMCIA services: modulesinsmod: a module named pcmcia_core already exists
/lib/modules/2.4.0-test5/pcmcia/i82365.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.0-test5/pcmcia/ds.o: init_module: Operation not permitted
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
 cardmgr.       

If anyone can offer any suggestions it would be much appreciated.

Thanks in advance, Talei.

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None I don't think the PnP card has been activated by David Hinds, 2000, Aug 10
(_ Question Now all my cards are being detected as "Anonymous Memory" by Talei McLeod, 2000, Aug 10
1. None This is not a PnP issue by David Hinds, 2000, Aug 10
1. More Here are my system log messages when I insert the WLAN card. by Talei McLeod, 2000, Aug 10
2. More Some more detailed information about above problem. by Talei McLeod, 2000, Aug 10
3. More I now have 1 card working. But not Compaq WLAN card. by Talei McLeod, 2000, Aug 11

Add Message to: "PCMCIA won't start (Kernel 2.4.0-test5, pcmcia-cs-3.1.20)"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10