Next-in-Thread Next Message

None You left out the part about a 2.3.* development kernel 

Forum: PCMCIA Installation and Configuration Issues
Re: Question Compile-errors in 3.1.10 (Rolf Rander Naess)
Date: 2000, Feb 15
From: David Hinds <dhinds@pcmcia.sourceforge.org>

So... it looks like you're compiling 3.1.9 (not 3.1.10), and you're
not actually building it for the 2.2.12 kernel you mention, you're
building it against a 2.3.43 or newer development kernel.

This combination won't work, due to API changes in the latest
development kernels.  You can try the latest beta on sourceforge.org
in /pcmcia/NEW.

-- Dave

Next-in-Thread Next Message

Messages Inline: 0 1

Question better combination?

Re: None You left out the part about a 2.3.* development kernel (David Hinds)
Date: 2000, Feb 16
From: Luis Villa luge

David-

I am having the same problem, and need a 2.3.x for the USB code. So:

1) How stable are those "NEW" packages? Will I have any luck with them at all or am I just wasting my time?

2) If they aren't particularly usable, how far back into the 2.3.x tree do I have to go to get a kernel that doesn't have the "improved" API? Obviously, this isn't the ideal solution, but if that is what it'll take...

Thanks a bunch for everything you've done-

Luis Villa (long time user, first time luser :)

Question One other question

Re: Question better combination? (Luis Villa)
Date: 2000, Feb 16
From: Luis Villa luge

One more thing:

How does this package interface with the stuff in the kernel? Should I leave all that stuff compiled out, or does the package now depend on it, assuming that it is there? I'll be testing this shortly, but that kernel re-compile will take a while :)

Luis

None For post-2.3.36, you must use the modules from the kernel tree

Re: Question One other question (Luis Villa)
Date: 2000, Feb 17
From: David Hinds <dhinds@pcmcia.sourceforge.org>

If you have a post-2.3.36 kernel, and the latest PCMCIA beta release,
then you must use the PCMCIA stuff in the kernel; the PCMCIA package
itself will only build the user-level PCMCIA utilities.

-- Dave
You left out the part about a 2.3.* development kernel


Add Message to: "You left out the part about a 2.3.* development kernel"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10