Next-in-Thread Next Message

Sad Pcmcia problems on Fujitsu lifebook (TI PCI1225) 

Forum: PCMCIA Installation and Configuration Issues
Date: 2000, Feb 25
From: Wolfgang Wegner Wolfgang

Hello experts, :-)

i am having trouble installing pcmcia card services on a Fujitsu/Siemens Lifebook C6325. This is a PII laptop with Intel BX chipset using the TI PCI1225 PCI/CardBus Bridge.

The setup is attached below. Some other files can be found on http://berta.e-technik.uni-dortmund.de/m_ww/pcmcia/ I am now running kernel 2.2.14 and pcmcia 3.1.11

I just managed to avoid complete lockups by including only one memory region in config.opts, but the card is still not usable. I had one success after having Windows 98 running with the card and forgot to remove the card. The card services started, but the card could not be configured. After re-insertion of the card, it worked - but i could not reproduce this. Also, in this case "lspci -v" showed different results, but unfortunately i did not save this. The system log of this can be found in the file "log_running" (this was still with old kernel and pcmcia-package).

I am not sure if this could be a BIOS problem (look at the
memory regions in lspci!). Under Win98, the resources listed
for PCMCIA bridge and card are as follows:
Socket0: IRQ 11
         mem 08000000-08000fff
Socket1: IRQ 11
         mem 08001000-08001fff
         mem 08040000-08080fff
         i/o 1080-10ff
Network Card: IRQ 11
              mem 0808000-080803ff
              i/o 1080-10ff
              mem 08040000-0807ffff
(This is why i included this memory region in config.opts)
The complete lspci -v output can be found in the file
"lspci".

lspci -v (only PCI1225 portion):
00:04.0 CardBus bridge: Texas Instruments PCI1225 (rev 01)
        Subsystem: Texas Instruments: Unknown device ac1c
        Flags: bus master, medium devsel, latency 168, IRQ 11
        Memory at <ignored> (32-bit, non-prefetchable)
        Bus: primary=00, secondary=20, subordinate=22, sec-latency=32
        I/O window 0: 00000000-00000003
        I/O window 1: 00000000-00000003
        16-bit legacy interface ports at 0007

00:04.1 CardBus bridge: Texas Instruments PCI1225 (rev 01)
        Subsystem: Texas Instruments: Unknown device ac1c
        Flags: bus master, medium devsel, latency 168, IRQ 11
        Memory at <ignored> (32-bit, non-prefetchable)
        Bus: primary=00, secondary=23, subordinate=25, sec-latency=32
        I/O window 0: 00000000-00000003
        I/O window 1: 00000000-00000003
        16-bit legacy interface ports at 0007

uname -rv: 2.2.14 #1 Thu Feb 24 17:08:13 CET 2000

config.opts:#

# Local PCMCIA Configuration File
#
# System resources available for PCMCIA devices
#
include port 0x100-0x4ff, port 0x1000-0x17ff include memory 0x8000000-0x8080fff
# include memory 0xc0000-0xfffff
# include memory 0xa0000000-0xa0ffffff, memory 0x60000000-0x60ffffff
#
# Extra port range for IBM Token Ring
#
include port 0xa00-0xaff
#
# Resources we should not use, even if they appear to be available
#
# First built-in serial port
exclude irq 4
# Second built-in serial port
#exclude irq 3
# First built-in parallel port
exclude irq 7 #

when including the two lower memory lines, the system locks up completely upon card insertion! (Not very useful, but can be found in "log_lock").

I hope i supplied enough information to find anything out about this strange thing and did not miss anything in the documentation this time. Or perhaps anyone else already went through this and can help me.

Best regards, Wolfgang

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None Memory window is too small by David Hinds, 2000, Feb 25
1. Feedback Not yet... by Wolfgang Wegner, 2000, Feb 28
2. Ok Seems to be solved...(Fujitsu C6325 now working) by Wolfgang Wegner, 2000, Mar 03

Add Message to: "Pcmcia problems on Fujitsu lifebook (TI PCI1225)"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10