Next-in-Thread Next Message

Question sorry, more problems 

Forum: PCMCIA Installation and Configuration Issues
Re: Question memory probe failure? (Thomas Schaefer)
Date: 1999, Nov 16
From: Thomas Schaefer schaefer

 Hi:

 I'm still having problems trying to install a MultiTech 
PCMCIA card modem in my Compaq Presario 1650 notebook. I 
upgraded the system to Red Hat Linux version 6.0 (kernel 
2.2.5, PCMCIA card services 3.1.3). The card is now 
correctly identified (in the mean time, I also bought 
a 3COM ethernet card which works just fine), but I can't 
get it to work. I have been trying to use minicom. 
Minicom attempts to dial, but there is no connection, 
and minicom hangs when I try to exit. 

 I suspect it might be some sort of interrupt conflict. 
Windows 98 has the built in (Win)modem on COM2 (IRQ 3) 
and the PCMCIA modem on COM3 (IRQ 10). With the standard
/etc/pcmcia/config.opts the PCMCIA card modem is assigned
ttyS1 and IRQ 3. I tried to exclude IRQ3 rather than 
IRQ4, but that doesn't seem to help. Neither does changing
the IRQ of /dev/modem to something like 0 or 10 using
the setserial command. (IRQ10 has an interesting effect:
Minicom claims that I am already on line). 


-------------------------------------------------------------
probe
PCI bridge probe: TI 1131 found, 2 sockets
probe -m
i82365
-------------------------------------------------------------

-------------------------------------------------------------
/etc/sysconfig/pcmcia
PCMCIA=yes
PCIC=i82365
PCIC_OPTS=
CORE_OPTS=
-------------------------------------------------------------

-------------------------------------------------------------
Compaq Presario 1650
linux kernel version 2.2.5-15
Linux PCMCIA Card Services 3.1.3
MultiTech 33.6K Modem (MT3400ZLX)
-------------------------------------------------------------

-------------------------------------------------------------
/var/log/messages
Nov 16 10:33:00 localhost pcmcia: Starting PCMCIA services:
Nov 16 10:33:00 localhost pcmcia:  modules
Nov 16 10:33:00 localhost kernel: Linux PCMCIA Card Services 3.1.3 
Nov 16 10:33:00 localhost kernel:   kernel build: 2.2.5-15 #1 Mon Apr 19 23:00:46 EDT 1999 
Nov 16 10:33:00 localhost kernel:   options:  [pci] [cardbus] [apm] 
Nov 16 10:33:00 localhost kernel: Intel PCIC probe:  
Nov 16 10:33:00 localhost kernel:   TI 1131 PCI-to-CardBus at bus 0 slot 10, mem 0x68000000, 2 sockets 
Nov 16 10:33:00 localhost kernel:     host opts [0]: [ring] [pci + serial irq] [no pci irq] [lat 168/176] [bus 32/34] 
Nov 16 10:33:00 localhost kernel:     host opts [1]: [ring] [pci + serial irq] [no pci irq] [lat 168/176] [bus 35/37] 
Nov 16 10:33:00 localhost kernel:     ISA irqs (scanned) = 3,4,7,10 status change on irq 10 
Nov 16 10:33:00 localhost pcmcia:  cardmgr.
Nov 16 10:33:01 localhost rc: Starting pcmcia succeeded
Nov 16 10:33:01 localhost cardmgr[321]: starting, version is 3.1.3
Nov 16 10:33:01 localhost cardmgr[321]: watching 2 sockets
Nov 16 10:33:01 localhost kernel: cs: IO port probe 0x1000-0x17ff: clean. 
Nov 16 10:33:01 localhost kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x200-0x207 0x220-0x22f 0x330-0x337 0x378-0x37f 0x388-0x38f 0x4d0-0x4d7 
Nov 16 10:33:01 localhost kernel: cs: IO port probe 0x0a00-0x0aff: clean. 
Nov 16 10:33:01 localhost inet: inetd startup succeeded
Nov 16 10:33:01 localhost cardmgr[321]: initializing socket 1
Nov 16 10:33:01 localhost kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean. 
Nov 16 10:33:01 localhost cardmgr[321]: socket 1: Serial or Modem
Nov 16 10:33:01 localhost cardmgr[321]: executing: 'insmod /lib/modules/2.2.5-15/pcmcia/serial_cs.o'
Nov 16 10:33:01 localhost kernel: tty01 at 0x02f8 (irq = 4) is a 16550A 
Nov 16 10:33:01 localhost cardmgr[321]: executing: './serial start ttyS1'

-------------------------------------------------------------



-------------------------------------------------------------
/etc/pcmcia/config.opts 
#
# Local PCMCIA Configuration File
#
# System resources available for PCMCIA devices
#
include port 0x100-0x4ff, port 0x1000-0x17ff
include memory 0xc0000-0xfffff, memory 0xa0000000-0xa0ffffff
#
# Extra port range for IBM Token Ring
#
include port 0xa00-0xaff
#
# Resources we should not use, even if they appear to be available
#
# First built-in serial port
exclude irq 4
# Second built-in serial port
#exclude irq 3
# First built-in parallel port
exclude irq 7
-------------------------------------------------------------


-------------------------------------------------------------
setserial -a /dev/modem
/dev/modem, Line 1, UART: 16550A, Port: 0x02f8, IRQ: 3
	Baud_base: 115200, close_delay: 50, divisor: 0
	closing_wait: 3000, closing_wait2: infinte
	Flags: spd_normal skip_test

ls -l /dev/modem
lrwxrwxrwx   1 root     root           10 Nov 13 20:41 /dev/modem -> /dev/ttyS1
-------------------------------------------------------------

Next-in-Thread Next Message

Add Message to: "sorry, more problems"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10