Next-in-Thread Next Message

Question Compaq Laptop M700 hangs when card is inserted or ejected 

Forum: PCMCIA Installation and Configuration Issues
Date: 2000, Apr 22
From: Atanu Ghosh atanu

Hardware: 	Compaq laptop M700
PC card:	Lucent Wavelan/IEEE Silver card
Distribution:	Redhat 6.2
Kernel Version:	2.2.14-5.0
Pcmcia:		pcmcia-cs-3.1.14

Firstly I have the card working with this kernel with pcmcia-cs-3.1.8
and the wavelan driver wavelan2_cs-6.00 from Lucent. Insertion and
ejection of the card works.

I decided to upgrade to the new driver wvlan_cs which is in the later
pcmcia distributions. If I insert or remove the card then the machine
hangs up and requires a reboot. There are no clues in the log files.

Interestingly it is possible to stop the cardmgr insert the card and
restart the carmgr. The card is discovered correctly and works.

To remove the card it is necessary to stop the cardmgr before removing
the card.

On reboot if the card is in the machine it is correctly discovered and
works.

I believe the inserting/removing any card will cause a lockup with the
latest pcmcia-cs-3.1.14 release. I tried putting in a ethernet card
which also caused a hangup.

I have not made any significant changes to the scripts in "/etc/pcmcia".

Although the PCMCIA_HOWTO warns that insertion and ejection may be a
problem, it does work with an older version of the pcmcia code.

	Atanu.

----------------------------------------
Linux version 2.2.14-5.0 (root@lamb) (gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #2 Thu Apr 13 15:55:59 EST 2000
----------------------------------------

----------------------------------------
Linux PCMCIA Card Services 3.1.8
  kernel build: 2.2.14-5.0 #2 Thu Apr 13 15:55:59 EST 2000
  options:  [pci] [cardbus] [apm]
Intel PCIC probe: 
  TI 1450 PCI-to-CardBus at bus 0 slot 4, mem 0x7fffe000, 2 sockets
    host opts [0]: [pwr save] [pci + serial irq] [no pci irq] [lat 66/176] [bus 2/2]
    host opts [1]: [pwr save] [pci + serial irq] [no pci irq] [lat 66/176] [bus 3/3]
    ISA irqs (scanned) = 3,4,5,7,9,10,15 status change on irq 15
cs: IO port probe 0x1000-0x17ff: excluding 0x1000-0x10ff
cs: IO port probe 0x0100-0x04ff: excluding 0x100-0x107 0x170-0x177 0x370-0x37f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
eth1: WaveLAN/IEEE, io_addr 0x180, irq 3, mac_address 00:60:1D:F6:34:B0
----------------------------------------

----------------------------------------
Linux PCMCIA Card Services 3.1.14
  kernel build: 2.2.14-5.0 #2 Thu Apr 13 15:55:59 EST 2000
  options:  [pci] [cardbus] [apm]
PCI routing table version 1.0 at 0xf0970
Intel PCIC probe: 
  TI 1450 rev 03 PCI-to-CardBus at slot 00:04, mem 0x7fffe000
    host opts [0]: [pci + serial irq] [no pci irq] [lat 66/176] [bus 2/2]
    host opts [1]: [pci + serial irq] [no pci irq] [lat 66/176] [bus 3/3]
    ISA irqs (scanned) = 3,4,7,9,15 polling interval = 1000 ms
cs: IO port probe 0x1000-0x17ff: excluding 0x1000-0x10ff
cs: IO port probe 0x0100-0x04ff: excluding 0x100-0x107 0x170-0x177 0x370-0x37f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
wvlan_cs: WaveLAN/IEEE PCMCIA driver v1.0.4
wvlan_cs: (c) Andreas Neuhaus <andy@fasta.fh-dortmund.de>
wvlan_cs: index 0x01: Vcc 5.0, irq 3, io 0x0180-0x01bf
wvlan_cs: Registered netdevice wvlan0
wvlan_cs: Valid channels: 1 2 3 4 5 6 7 8 9 10 11 
wvlan_cs: MAC address on wvlan0 is 00 60 1d f6 34 b0 
----------------------------------------

----------------------------------------
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev 03)
00:04.0 CardBus bridge: Texas Instruments PCI1221 (rev 03)
00:04.1 CardBus bridge: Texas Instruments PCI1221 (rev 03)
00:07.0 Bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
----------------------------------------

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. Ok BIOS was not providing PCI interrupt information by David Hinds, 2000, May 01

Add Message to: "Compaq Laptop M700 hangs when card is inserted or ejected"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10