Next-in-Thread Next Message

Question PCMCIA not working with a TI 1450 PCI-Cardbus 

Forum: PCMCIA Installation and Configuration Issues
Date: 2000, May 09
From: Paul Hayton <pmh@robots.ox.ac.uk>

I've trying to get Linux 6.2 up and running on a Fieldworks 8000 Rugged Laptop. It uses a TI 1450 PCI-Cardbus Controller which probe happily identifies. The symptoms at face value match those of a memory probe failure and having read the previous list of problems and suggestions, I've tried restricting the probe range (many many combinations) to no avail.

The other symptom is that the ATA IDE disk I'm trying to get working (which works happily on other machines) doesn't get hot which implies it may not be getting any power, but I'm using Card Services 3.1.14 which has the TI 1220 power on bit set..

Many thanks in advance for any ideas ..

Paul

The messages log reports :

May  9 11:08:44 lafeu kernel: Linux PCMCIA Card Services 3.1.14 
May  9 11:08:44 lafeu kernel:   kernel build: 2.2.14-5.0 #1 Tue Mar 7 21:07:39 EST 2000 
May  9 11:08:44 lafeu kernel:   options:  [pci] [cardbus] [apm] 
May  9 11:08:44 lafeu kernel: PCI routing table version 1.0 at 0xfdcf0 
May  9 11:08:44 lafeu kernel: Intel PCIC probe:  
May  9 11:08:44 lafeu kernel:   TI 1450 rev 03 PCI-to-CardBus at slot 02:08, mem 0x76000000 
May  9 11:08:44 lafeu kernel:     host opts [0]: [isa irq] [no pci irq] [lat 64/176] [bus 3/3] 
May  9 11:08:44 lafeu kernel:     host opts [1]: [isa irq] [no pci irq] [lat 64/176] [bus 4/4] 
May  9 11:08:45 lafeu kernel:     ISA irqs (scanned) = 7,9 polling interval = 1000 ms 
May  9 11:08:45 lafeu cardmgr[5121]: starting, version is 3.1.14
May  9 11:08:45 lafeu cardmgr[5121]: watching 2 sockets
May  9 11:08:45 lafeu kernel: cs: IO port probe 0x1000-0x17ff: excluding 0x1028-0x102f 0x1060-0x1067 0x1158-0x115f 0x1378-0x137f 0x13f0-0x13f7 
May  9 11:08:45 lafeu kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x158-0x15f 0x378-0x37f 0x4d0-0x4d7 
May  9 11:08:45 lafeu kernel: cs: IO port probe 0x0a00-0x0aff: clean. 
May  9 11:08:45 lafeu cardmgr[5121]: initializing socket 0
May  9 11:08:45 lafeu kernel: cs: memory probe 0xc0000000-0xc0ffffff: excluding 0xc0000000-0xc0ffffff 
May  9 11:08:45 lafeu kernel: cs: memory probe 0xa0000000-0xa0ffffff: excluding 0xa0000000-0xa0ffffff 
May  9 11:08:45 lafeu kernel: cs: memory probe 0x60000000-0x60ffffff: excluding 0x60000000-0x60ffffff 
May  9 11:08:45 lafeu kernel: cs: warning: no high memory space available! 
May  9 11:08:45 lafeu kernel: cs: memory probe 0x0d0000-0x0dffff: excluding 0xd0000-0xdffff 
May  9 11:08:45 lafeu kernel: cs: memory probe 0x0c0000-0x0cffff: excluding 0xc0000-0xcffff 
May  9 11:08:45 lafeu cardmgr[5121]: socket 0: Anonymous Memory
May  9 11:08:45 lafeu cardmgr[5121]: executing: 'insmod /lib/modules/2.2.14-5.0/pcmcia/memory_cs.o'
May  9 11:08:45 lafeu kernel: memory_cs: mem0: anonymous: unknown size 
May  9 11:08:45 lafeu cardmgr[5121]: executing: './memory start mem0'

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 3 All

1. Note Additional Information by Paul Hayton, 2000, May 09
2. None Probably not a memory window issue by David Hinds, 2000, May 09
1. More cardctl can see something.... by Paul Hayton, 2000, May 11
3. Ok Success by Paul Hayton, 2000, May 31

Add Message to: "PCMCIA not working with a TI 1450 PCI-Cardbus"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10