Next-in-Thread Next Message

Question no ports available, Xircom CEM56 56K/eth (this may be a dumb question) 

Forum: PCMCIA Multifunction Card Issues
Date: 2000, Mar 09
From: Dan Flickinger flikee

The computer is a digital HiNote Ultra 2000 with a 266 MHz pentium. Kernel is 2.2.14, and pcmcia is the latest release. The installation is basically a redhat 6.1 setup.

here's what syslog says:

Mar  8 22:24:01 localhost pcmcia: Starting PCMCIA services:
Mar  8 22:24:01 localhost pcmcia:  modules
Mar  8 22:24:01 localhost kernel: Linux PCMCIA Card Services 3.1.9 
Mar  8 22:24:01 localhost kernel:   kernel build: 2.2.14 #1 Wed Mar 8 11:27:19 MST 2000 
Mar  8 22:24:01 localhost kernel:   options:  [pci] [cardbus] [apm] [pnp] 
Mar  8 22:24:01 localhost kernel: PCI routing table version 1.0 at 0xf2460 
Mar  8 22:24:01 localhost kernel:   unknown PCI interrupt router 1066:0002 
Mar  8 22:24:01 localhost kernel:   00:07.0 -> irq 9 
Mar  8 22:24:01 localhost kernel:   00:07.1 -> irq 10 

Mar  8 22:24:02 localhost kernel: Intel PCIC probe:  
Mar  8 22:24:02 localhost kernel:   TI 1131 PCI-to-CardBus at slot 00:07, mem 0x68000000 
Mar  8 22:24:02 localhost kernel:     host opts [0]: [pci + serial irq] [pci irq 9] [lat 168/176] [bus 32/34] 
Mar  8 22:24:02 localhost kernel:     host opts [1]: [pci + serial irq] [pci irq 10] [lat 168/176] [bus 35/37] 
Mar  8 22:23:58 localhost apmd: apmd startup succeeded 
Mar  8 22:23:58 localhost apmd[153]: Version 3.0beta8 (APM BIOS 1.2, Linux driver 1.9) 
Mar  8 22:24:00 localhost network: Bringing up interface lo succeeded 
Mar  8 22:24:00 localhost portmap: portmap startup succeeded 
Mar  8 22:24:00 localhost random: Initializing random number generator succeeded 

Mar  8 22:24:02 localhost kernel:     ISA irqs (scanned) = 3,4 PCI status changes 
Mar  8 22:24:02 localhost kernel:   Cirrus PD672x ISA-to-PCMCIA at port 0x3e0 ofs 0x00 
Mar  8 22:24:02 localhost kernel:     host opts [0]: [ring] [65/6/3] [1/15/3] 
Mar  8 22:24:02 localhost kernel:     host opts [1]: [ring] [65/6/3] [1/15/3] 
Mar  8 22:24:02 localhost kernel:     ISA irqs (default) = 3,4,11 polling interval = 1000 ms 

Mar  8 22:24:02 localhost pcmcia:  cardmgr.
Mar  8 22:24:02 localhost rc: Starting pcmcia succeeded
Mar  8 22:24:02 localhost cardmgr[304]: starting, version is 3.1.9
Mar  8 22:24:02 localhost cardmgr[304]: watching 4 sockets
Mar  8 22:24:02 localhost kernel: cs: IO port probe 0x1000-0x17ff: clean. 
Mar  8 22:24:02 localhost kernel: cs: IO port probe 0x0100-0x04ff: clean. 
Mar  8 22:24:02 localhost inet: inetd startup succeeded
Mar  8 22:24:02 localhost cardmgr[304]: initializing socket 2
Mar  8 22:24:03 localhost kernel: cs: memory probe 0x0d0000-0x0dffff: clean. 
Mar  8 22:24:03 localhost cardmgr[304]: socket 2: Xircom CEM56 Ethernet/Modem
Mar  8 22:24:03 localhost cardmgr[304]: executing: 'insmod /lib/modules/2.2.14/pcmcia/xirc2ps_cs.o'
Mar  8 22:24:03 localhost kernel: xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+kvh) 
Mar  8 22:24:03 localhost cardmgr[304]: executing: 'insmod /lib/modules/2.2.14/pcmcia/serial_cs.o'
Mar  8 22:24:03 localhost kernel: xirc2ps_cs: no ports available 
Mar  8 22:24:03 localhost cardmgr[304]: get dev info on socket 2 failed: No such device

(this is when a 56k modem I have is inserted and configured correctly:)

Mar  8 22:36:19 localhost cardmgr[304]: initializing socket 0
Mar  8 22:36:19 localhost cardmgr[304]: socket 0: Serial or Modem
Mar  8 22:36:19 localhost kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean. 
Mar  8 22:36:19 localhost kernel: tty16 at 0x0100 (irq = 3) is a 16550A 
Mar  8 22:36:19 localhost cardmgr[304]: executing: './serial start ttyS16'

=======

I have the feeling that the problem is widespread, but very simple to correct. Also, my in my bios, I can set up the serial, ir, sound, and parallel ports, so I know those ports and irqs, etc. A couple weeks ago, it seemed that I could get the ethernet part of the card to work, but I didn't have a network to test it on.

Also, with the kernel serial drivers, I have many_ports, and share_irqs enabled, but I don't think that makes a difference. The combo card is built in, so I assume my macine has 4 pcmcia slots. (cardctl info shows slots 0 - 3)

someone please point me in the right direction with this one. I'm not a newbie to linux, I promise.

Next-in-Thread Next Message

Add Message to: "no ports available, Xircom CEM56 56K/eth (this may be a dumb question)"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10