Next-in-Thread Next Message

None Additional Information 

Forum: PCMCIA Multifunction Card Issues
Re: Question 3CCFEM656BT doesn't work with 3.1.15 (Michael Barton)
Date: 2000, May 19
From: Michael Barton mgbarton

While reviewing the behavior of /etc/pcmcia/network, I found that the script calls on /etc/pcmcia/network.opts, which has hard coded values for IPADDR, NETMASK, and so on. I had assumed that the RedHat Network Configurator values were being used - but instead there are these hard coded values.

So I updated the network.opts script with the correct values for my machine.

Now, Either the pcmcia card initializes correctly during boot (I get a steady 100 light and I can converse with the LAN), or I get both lights off, with the 100 light blicking occasionally, and no network access.

Unfortuately, I seems to NOT initialize correctly about 70% of the time, and correctly only 30% of the time.

Are there some timing issues here?

Any input greatly appreciated, Michael

Next-in-Thread Next Message

Messages Inline: 0 All Outline: 1 2 All

None Re: Additional Information

Re: None Additional Information (Michael Barton)
Date: 2000, May 19
From: David Hinds <dhinds@pcmcia.sourceforge.org>

The network.opts thing is documented in the PCMCIA-HOWTO section about
Red Hat.

Does ejecting and reinserting the card (or "cardctl reset") help?  (or
does the not-working state persist until you reboot?)  Are there
differences in system log messages from the 3c575_cb driver for the
working and not-working states?

-- Dave
1. None Re: Additional Information by Michael Barton, 2000, May 19
Additional Information


Add Message to: "Additional Information"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10