Next-in-Thread Next Message

Sad 3CCFEM556B - modem does not work 

Forum: PCMCIA Multifunction Card Issues
Date: 2000, Jun 06
From: Micha Meier micha

I have a Toshiba Tecra 8000 with SuSE 6.2, kernel 2.2.10
and I cannot make the modem part to work on it. Pcmcia-cs
version is 3.1.11, the card is 3CCFEM556 B (probably the
European version, if that makes a difference). I have tried
all IRQ combinations as written in the HOWTO, however the
modem sort of works only when IRQ is set to 0, otherwise
minicom takes ages to echo the initialization string and
no AT commands can be input. The startup
looks quite normal (syslog below). The card works with
windows and uses the same interrupt as here, the ethernet
part works ok on both Linux and windows. Can anybody
tell me, where the problem could be?

--Micha

-------------

May 22 11:45:23 leia kernel: Linux PCMCIA Card Services 3.1.11
May 22 11:45:23 leia kernel:   kernel build: 2.2.10 #1 Sam Dez 18 12:27:52 CET 1999
May 22 11:45:23 leia kernel:   options:  [pci] [cardbus] [apm]
May 22 11:45:23 leia kernel: PCI routing table version 1.0 at 0xf0f90
May 22 11:45:23 leia kernel: Intel PCIC probe:
May 22 11:45:23 leia kernel:   Intel i82365sl B step ISA-to-PCMCIA at port 0x3e0 ofs 0x00
May 22 11:45:23 leia kernel:     host opts [0]: none
May 22 11:45:23 leia kernel:     host opts [1]: none
May 22 11:45:23 leia kernel:     ISA irqs (scanned) = 3,4,7,10 polling interval = 1000 ms
May 22 11:45:23 leia kernel: cs: IO port probe 0x1000-0x17ff: clean.
May 22 11:45:23 leia kernel: cs: IO port probe 0x0340-0x037f: clean.
May 22 11:45:23 leia kernel: cs: IO port probe 0x0100-0x032f: excluding 0x220-0x22f
May 22 11:45:23 leia kernel: cs: IO port probe 0x0a00-0x0aff: clean.
May 22 11:45:23 leia cardmgr[24880]: starting, version is 3.1.11
May 22 11:45:23 leia cardmgr[24880]: watching 2 sockets
May 22 11:45:23 leia cardmgr[24880]: initializing socket 0
May 22 11:45:23 leia kernel: cs: memory probe 0x0d0000-0x0dffff: clean.
May 22 11:45:23 leia cardmgr[24880]: socket 0: 3Com/Megahertz 3CCFEM556 Ethernet/Modem
May 22 11:45:23 leia cardmgr[24880]:   product info: "3Com", "Megahertz 3CCFEM556BI", "A", "001"
May 22 11:45:23 leia cardmgr[24880]:   manfid: 0x0101, 0x0556  function: 6 (network)
May 22 11:45:23 leia cardmgr[24880]: executing: 'insmod /lib/modules/2.2.10/pcmcia/3c574_cs.o'
May 22 11:45:23 leia kernel: 3c574_cs.c v1.08 9/24/98 Donald Becker/David Hinds, becker@cesdis.gsfc.nasa.gov.
May 22 11:45:23 leia cardmgr[24880]: executing: 'insmod /lib/modules/2.2.10/pcmcia/serial_cs.o'
May 22 11:45:24 leia kernel: eth0: 3Com 3c574 at io 0x300, irq 10, hw_addr 00:00:86:37:9D:E9.
May 22 11:45:24 leia kernel:   ASIC rev 1, 64K FIFO split 1:1 Rx:Tx, autoselect MII interface.
May 22 11:45:24 leia kernel: tty03 at 0x02e8 (irq = 10) is a 16550A
May 22 11:45:24 leia cardmgr[24880]: executing: './network start eth0'
May 22 11:45:24 leia kernel: bridge-eth0: found peer eth0
May 22 11:45:24 leia kernel: bridge-eth0: up
May 22 11:45:24 leia cardmgr[24880]: executing: './serial start ttyS3'

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None Strange combination of symptoms by David Hinds, 2000, Jun 06
1. More I have no clue by Micha Meier, 2000, Jun 07
2. Feedback 3CCFEM556B LAN+56kModem works OK on a Toshiba Portege 300CT by Piete Brooks, 2000, Jun 10

Add Message to: "3CCFEM556B - modem does not work"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10