Next-in-Thread Next Message

None Maybe this is not the appropriate driver 

Forum: PCMCIA Multifunction Card Issues
Re: Question eth0: unexpected TX-done interrupt, lasttx=20 (Zsolt Szabo)
Date: 2000, Jun 21
From: David Hinds <dhinds@pcmcia.sourceforge.org>

>     /etc/pcmcia/network.opts is not configured??
> # i don't understand why it thinks, I've set a fix IP

It is a bug in the pattern matching in the test_network script.  I'll
fix that for the next release.

This card may simply not be NE2000 compatible.  You could also try the
smc91c92_cs driver.

-- Dave

Next-in-Thread Next Message

Messages Inline: 0 All Outline: 1 2 3

Sad smc91c92: unable to find hwaddrs, 3c589: is this a 3com card?

Re: None Maybe this is not the appropriate driver (David Hinds)
Date: 2000, Jun 22
From: Zsolt Szabo szazs

Hi,

neither smc91c92_cs, nor 3c589_cs module seems to work for me:

smc91c92_cs: unable to find hardware address

# i try to add the hwaddrs detected by pcnet_cs as option in
# /etc/pcmcia/config.opts :
cardmgr[xxx]: /lib/modules/2.2.12/pcmcia/smc91c92_cs.o: invalid parameter hw_addr

# 3c589_cs is a bit more interesting (I tried 10base[2T] and AUI):
Checking network interface eth0 (3c589_cs driver):

  Kernel messages for eth0:
  eth0: switched to 10base2 port
  eth0: interrupt(s) dropped!
  eth0: 3Com 3c589, io 0x300, irq 11, hw_addr 08:00:08:00:08:00
  eth0: switched to AUI port
  eth0: lost link beat
  eth0: interrupt(s) dropped!
  eth0: 3Com 3c589, io 0x300, irq 11, hw_addr 08:00:08:00:08:00
  eth0: Transmit timed out!
  eth0: Transmit timed out!
  eth0: command 0x5800 did not complete!

  Current ifconfig settings:
  eth0 Link encap:Ethernet HWaddr 08:00:08:00:08:00
            inet addr:152.66.33.190 Bcast:152.66.33.191 Mask:255.255.255.192
            UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
            RX packets:0 errors:0 dropped:0 overruns:288 frame:0
            TX packets:162 errors:1 dropped:0 overruns:0 carrier:271
            Collisions:0
            Interrupt:11 Base address:0x300

  The interface is configured and running.
  There hasn't been any traffic on this interface!
# sometimes it says: TX looks OK, but there may be an RX problem

  There is a route to a gateway at 152.66.33.129.

  Pinging 152.66.33.129 ...eth0: Transmit timed out!
eth0: command 0x5800 did not complete!
 timed out!
  The device interrupt does not seem to be incrementing.

# the tail of the syslog:
Jun 22 13:56:05 laptop kernel: eth0: Transmit timed out!
Jun 22 13:56:05 laptop kernel: irq status 0031, rx status 0021, tx status 00
tx free 0808
Jun 22 13:56:05 laptop kernel: diagnostics: fifo 0008 net 0034 ethernet 0021 m
edia 0001
Jun 22 13:56:05 laptop kernel: eth0: command 0x5800 did not complete!
Jun 22 13:56:30 laptop kernel: eth0: Transmit timed out!
Jun 22 13:56:30 laptop kernel: irq status 0031, rx status 0021, tx status 00
tx free 0808
Jun 22 13:56:30 laptop kernel: diagnostics: fifo 0008 net 0034 ethernet 0021 m
edia 0001
Jun 22 13:59:05 laptop kernel: eth0: Transmit timed out!
Jun 22 13:59:05 laptop kernel: irq status 0031, rx status 0021, tx status 00
tx free 0808
Jun 22 13:59:05 laptop kernel: diagnostics: fifo 0008 net 0034 ethernet 0021 m
edia 0001

# xirc2ps_cs: unknown hardware manufacturer ID: 0x0175

Could someone give me any hope...?

Zsolt

1. None I think you are out of luck by David Hinds, 2000, Jun 22
Maybe this is not the appropriate driver


Add Message to: "Maybe this is not the appropriate driver"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10