Next-in-Thread Next Message

Question Problems with Kingmax KEN0100-DF Ethernet card 

Forum: PCMCIA Network Adapter Issues
Date: 2000, Jan 20
From: Albio alby

My Kingmax KEN0100-DF Ethernet card is recognized by cardmngr using the module tulip_cb, but I can't access the network (with ping for example).

I controlled several times the network configuration: IP address, DNS, Gateway etc.

Giving ifconfig the eth0 is up; the ip number and netmask are correctly setted.

Can someone help me? Thanks

Next-in-Thread Next Message

Messages Inline: 0 1

None Again... system log messages??

Re: Question Problems with Kingmax KEN0100-DF Ethernet card (Albio)
Date: 2000, Jan 20
From: David Hinds <dhinds@pcmcia.sourceforge.org>

As I seem to say in response to most problem reports.

System log messages would be helpful.  It would also be helpful to say
what kind of laptop you're using.

-- Dave

Note Sys Log messages

Re: None Again... system log messages?? (David Hinds)
Date: 2000, Jan 21
From: Albio alby

System: Geo Itinera CPU AMD II 366

Red Hat 6.0

PCMCIA Card Services 3.0.9

Jan 21 21:52:01 impacomp kernel:   kernel build: 2.2.5-15 #1 Mon Apr 19 22:21:09 EDT 1999 
Jan 21 21:52:01 impacomp kernel:   options:  [pci] [cardbus] [apm] 
Jan 21 21:52:01 impacomp kernel: Intel PCIC probe:  
Jan 21 21:52:01 impacomp kernel:   TI 1250A PCI-to-CardBus at bus 0 slot 3, mem 0x68000000, 2 sockets 
Jan 21 21:52:01 impacomp kernel:     host opts [0]: [pwr save] [serial pci & irq] [no pci irq] [lat 168/176] [bus 32/34] 
Jan 21 21:52:01 impacomp kernel:     host opts [1]: [pwr save] [serial pci & irq] [no pci irq] [lat 168/176] [bus 35/37] 
Jan 21 21:52:01 impacomp kernel:     ISA irqs (scanned) = 3,4,7,9,10,11 status change on irq 11 
Jan 21 21:52:01 impacomp cardmgr[2554]: starting, version is 3.0.14
Jan 21 21:52:01 impacomp cardmgr[2554]: watching 2 sockets
Jan 21 21:52:01 impacomp cardmgr[2554]: Card Services release does not match!
Jan 21 21:52:01 impacomp kernel: cs: IO port probe 0x1000-0x17ff: clean. 
Jan 21 21:52:01 impacomp kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x330-0x337 0x378-0x37f 0x4d0-0x4d7 
Jan 21 21:52:01 impacomp kernel: cs: IO port probe 0x0a00-0x0aff: clean. 
Jan 21 21:52:01 impacomp cardmgr[2554]: initializing socket 0
Jan 21 21:52:01 impacomp cardmgr[2554]: socket 0: CardBus
Jan 21 21:52:02 impacomp cardmgr[2554]: executing: 'insmod /lib/modules/2.2.5-15/pcmcia/cb_enabler.o'
Jan 21 21:52:02 impacomp cardmgr[2554]: executing: 'insmod /lib/modules/2.2.5-15/pcmcia/tulip_cb.o'
Jan 21 21:52:02 impacomp kernel: cs: cb_config(bus 32): vendor 0x1011, device 0x0019 
Jan 21 21:52:02 impacomp kernel:   fn 0 bar 1: io 0x280-0x2ff 
Jan 21 21:52:02 impacomp kernel:   fn 0 bar 2: mem 0x600c0000-0x600c03ff 
Jan 21 21:52:02 impacomp kernel:   fn 0 rom: mem 0x60080000-0x600bffff 
Jan 21 21:52:02 impacomp kernel: tulip_attach(bus 32, function 0) 
Jan 21 21:52:02 impacomp kernel: tulip.c:v0.89H 5/23/98 becker@cesdis.gsfc.nasa.gov 
Jan 21 21:52:02 impacomp kernel: eth0: Digital DS21142/3 Tulip at 0x280, 00 a0 0c 90 4f e3, IRQ 3. 
Jan 21 21:52:02 impacomp kernel: eth0:  EEPROM default media type Autosense. 
Jan 21 21:52:02 impacomp kernel: eth0:  Index #0 - Media 10baseT (#0) described by a 21142 Serial PHY (2) block. 
Jan 21 21:52:02 impacomp kernel: eth0:  Index #1 - Media 10baseT-FD (#4) described by a 21142 Serial PHY (2) block. 
Jan 21 21:52:02 impacomp kernel: eth0:  Index #2 - Media 100baseTx (#3) described by a 21143 SYM PHY (4) block. 
Jan 21 21:52:02 impacomp kernel: eth0:  Index #3 - Media 100baseTx-FD (#5) described by a 21143 SYM PHY (4) block. 
Jan 21 21:52:02 impacomp cardmgr[2554]: executing: './network start eth0'
Jan 21 21:52:08 impacomp kernel: eth0: 21142 100baseTx link beat good. 

**********

then I ping my_nearest_neighboor in the LAN

Jan 21 21:53:15 impacomp kernel: eth0: 21140 transmit timed out, status f0120000, SIA 000000c5 ffff0001 fffbff7f 8ff10008, resetting... 
Jan 21 21:53:15 impacomp kernel: eth0: transmit timed out, switching to 100baseTx media. 
Jan 21 21:53:20 impacomp kernel: eth0: 21142 100baseTx sensed media. 
Jan 21 21:53:20 impacomp kernel: eth0: 21140 transmit timed out, status f8128000, SIA 000000c6 ffff0001 fff87f3d 8ff10000, resetting... 
Jan 21 21:53:20 impacomp kernel: eth0: transmit timed out, switching to 10baseT media. 
Jan 21 21:53:25 impacomp kernel: eth0: 21140 transmit timed out, status f0120000, SIA 000000c6 ffff0000 fff8ffff 8ff10000, resetting... 
Jan 21 21:53:25 impacomp kernel: eth0: transmit timed out, switching to 100baseTx media. 

......

None Driver upgrade?

Re: Note Sys Log messages (Albio)
Date: 2000, Jan 22
From: David Hinds <dhinds@pcmcia.sourceforge.org>

You should probably try upgrading your PCMCIA drivers.  It looks like
maybe you've already tried to do this??  (your cardmgr is version
3.0.14, but your kernel modules are version 3.0.9)

Newer driver packages (3.0.14 and later) have a newer version of the
tulip_cb module.

-- Dave

None It doesn't work

Re: None Driver upgrade? (David Hinds)
Date: 2000, Jan 22
From: Albio alby

I istalled the package pcmcia-cs3.1.6.tar.gz

The card is recognized again, but I can't ping anywhere...

There is some other solution?

Thanks

None Re: It doesn't work

Re: None It doesn't work (Albio)
Date: 2000, Jan 24
From: David Hinds <dhinds@pcmcia.sourceforge.org>

It would again be useful to post system log messages.

Why did you pick 3.1.6?

It could be an interrupt conflict.  Try excluding interrupts in
/etc/pcmcia/config.opts, starting with irq 3, and see if that helps.

-- Dave

None It's doesn't work again.

Re: None Re: It doesn't work (David Hinds)
Date: 2000, Jan 28
From: Albio alby

> why did you pick 3.1.6?

Which version have I to pick ?

> It could be an interrupts. It could be an interrupt >conflict. Try excluding interrupts in >/etc/pcmcia/config.opts, 
> starting with irq 3, and see if that helps.

I tried to exclude irq 3 and then 9 but it doesn't work ...

A.

Ok It works !!!!

Re: None It's doesn't work again. (Albio)
Date: 2000, Feb 05
From: Albio alby

My CardBus Kingmax 10/100 KEN0100-DF works with pcmcia-cs-3.1.10 !!!!

Thank you Dave

Albio

Problems with Kingmax KEN0100-DF Ethernet card


Members Subscribe No Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10
[ Edit This Forum ]