Next-in-Thread Next Message

Question Socket EA System Hang 

Forum: PCMCIA Network Adapter Issues
Date: 2000, Jan 21
From: Robert Sanderson azaroth

Hi all, I've been trying unsuccessfully to get my eth0 card working with my new laptop.

System:  Dell Latitude CPi R400GT
PC Card:  Socket EA Ethernet
Kernel:  2.2.14
PCMCIA:  3.1.8
Changes:  Added exit 0; in pcmcia/network to prevent hangs (see below)
Messages:

------------------------
  
initializing socket 1
eth0: NE2000 Compatible: io 0x300 irq 3 auto xcvr hw_addr 00:C0:1B:00:5E:27
socket 1: Socket EA Ethernet
executing insmod /lib/modules/2.2.14/net/8390.o
executing insmod /lib/modules/2.2.14/pcmcia/pcnet_cs.o
executing ./network start eth0

----------------------------

At which point, the system hangs until the card is ejected.
When it is, the following messages are given:

----------------------------
Hw. address read/write mismap 0
Hw. address read/write mismap 1
Hw. address read/write mismap 2
Hw. address read/write mismap 3
Hw. address read/write mismap 4
Hw. address read/write mismap 5
eth0: interupt from stopped card

----------------------------

The card worked fine in my old laptop (Compaq Aero C33,
running linux 2.0.0), and the my modem card (psion dacom gold
card) works fine in the Dell as well as the Compaq.

In the documentation, it says that it's necessary to use
ifport to manually set the interface for EA cards - doing this
or not seems to make no difference, the system still hangs
with the same errors.

Occaisonally it won't hang when the interface is brought up,
but will on receiving any traffic. In this scenario the
messages are:

--------------------------------------

eth0: mismatched read page pointers 0 vs  e.
eth0: mismatched read page pointers 0 vs  ff.
eth0: mismatched read page pointers 0 vs  ff.
eth0: mismatched read page pointers 0 vs  ff.
...
eth0: unexpected TX-done interrupt, lasttx=0.
eth0: too much work at interrupt, status 0xff
eth0: interrupt from stopped card

---------------------------------------

Other miscellaneous messages from when the card is inserted 
but nothing has been done to it:

'probe' gives:

PCI bridge probe:  TI 1255 found, 2 sockets. 

'cardctl ident' gives:

product info: Socket Communications Inc, Socket EA PCMCIA LAN Adapter
Revision E, Ethernet ID 00c01b005e27
manfid: 0x0104, 0x000
function: 6 (network)

'cardctl status' gives:

5V 16-bit PC Card
funciton 0: [ready]   

------

This looks like a driver problem, does anyone have any 
information or ideas about it?

Thanks,

Rob Sanderson

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None Resource conflict? by David Hinds, 2000, Jan 21
(_ More Resource Conflict, Socket EA by Robert Sanderson, 2000, Jan 24
(_ More Socket EA hang, by Robert Sanderson, 2000, Jan 25

Add Message to: "Socket EA System Hang"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10