Next-in-Thread Next Message

More Untitled 

Forum: PCMCIA Network Adapter Issues
Re: Question card works fine, but 'tcpdump' cant see any of the traffic (Ron Flory)
Date: 2000, Feb 17
From: Ron Flory <ron.flory@adtran.com>

David Hinds wrote:
> 
> On Thu, Feb 17, 2000 at 07:10:21AM -0800, Ron Flory wrote:
> >
> >  tcpdump seems to work file on all my other machines (7-8 of various
> > types), but for some reason its deaf on this one.
> 
> What network card are you using?  (which driver is at fault?)

 Hi Dave-

The card is marked:

   Linksys EtherFast 10/100 PC Card
   model: PCMPC100

startup message from syslog:

  NE2000 Compatable: io 0x300, irq 3 ....

its loading the 8390.o module, so its probably another (klunky 'ol) ne2000 clone.

> I thought that most of the drivers implemented promisc support, but I
> can't say I've ever used it myself.

hmmm, good thought. When I startup tcpdump, I don't see the usual "eth0: Promiscuous mode enabled" message.... Apparently the promisc request isn't getting all the way through the driver-

 If it helps, here's some more info:

      kernel: 2.2.14 (unpatched, from master sources)

 Here is slightly filtered syslog:

kernel: unloading PCMCIA Card Services 
kernel: Linux PCMCIA Card Services 3.1.10 
kernel:   kernel build: 2.2.14 #1 Wed Feb 9 10:25:19 CST 2000 
kernel:   options:  [pci] [cardbus] [apm] 
kernel: PCI routing table version 1.0 at 0xf09a0 
kernel: Intel PCIC probe:  
kernel:   TI 1225 PCI-to-CardBus at slot 00:11, mem 0x7fffe000 
kernel:     host opts [0]: [ring] [pci + serial irq] [pci irq 11] [lat
66/176] [bus 2/2] kernel: host opts [1]: [ring] [pci + serial irq] [pci irq 11] [lat 66/176] [bus 3/3] kernel: ISA irqs (scanned) = 3,4,7,9,10,15 PCI status changes cardmgr[788]: starting, version is 3.1.10 cardmgr[788]: watching 2 sockets
kernel: cs: IO port probe 0x1000-0x17ff: excluding 0x1000-0x10ff 
kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x250-0x257
0x260-0x267 0x330-0x337 0x388-0x38f 0x4d0-0x4d7 kernel: cs: IO port probe 0x0a00-0x0aff: clean. cardmgr[788]: initializing socket 0 kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean. cardmgr[788]: socket 0: Linksys EtherFast 10/100 Fast Ethernet cardmgr[788]: executing: 'insmod /lib/modules/2.2.14/net/8390.o' cardmgr[788]: executing: 'insmod /lib/modules/2.2.14/pcmcia/pcnet_cs.o' kernel: eth0: NE2000 Compatible: io 0x300, irq 3, hw_addr 00:E0:98:71:19:03 cardmgr[788]: executing: './network start eth0' kernel: eth0: found link beat

 I appreciate any ideas or info-

 Thanks-

ron

Next-in-Thread Next Message

Add Message to: "Untitled"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10