Next-in-Thread Next Message

Sad upgrading PCMCIA 3.1.1 to 3.1.2 or 3.1.3 breaks certain network adapters 

Forum: PCMCIA Network Adapter Issues
Date: 1999, Nov 10
From: Patrick Hildenbrand patrick

Hi, it seams that with kernel version 2.2.13 going from 3.1.1 to 3.1.2 the following adapters will no longer work correctly:
  • IBM Ethernet Adapter II (pcnet_cs)
    various error messags on high network utilization, UDP transport not reliable (ex. host will sometimes not work, doing a tcpdump, I could see that the data gets send out, the answer returned but the system will not show the response. TCP connections are slow but work (specifiying the ip-adress).
  • Level One EPC-0100TB (pcnet_cs)
    no conectivity at all, the card gets detected and configured, eth0 is available but nothing (ping, tcp, udp) works.

going from 3.1.1 to 3.1.3 the same applies as above and in addition the IBM Etherjet cardbus adapter (tulip_cb) will no longer work. Same symptoms as for the Level One adapter. I did not try other adapters so far besides a 4lan EP100 ethernet adapter (also pcnet_cs) which just works as it has been.

The configuration had not been changed between the different test. Reinstalling the old pcmcia version did in all cases cure the problem. Hardware are IBM Thinkpad 760 and 770. TokenRing is not affected.

Anybody any hints ?

I will try to dig a bit more as I have time.

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. Ok Fixed by Patrick Hildenbrand, 1999, Dec 06

Add Message to: "upgrading PCMCIA 3.1.1 to 3.1.2 or 3.1.3 breaks certain network adapters"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10