Next-in-Thread Next Message

None PCMCIA on PowerPC is problematic 

Forum: Non-x86 PCMCIA Issues
Re: Question Panic on card insert on ppc g3, 3.1.11 / 2.2.x (Wim Lewis)
Date: 2000, Feb 22
From: David Hinds <dhinds@pcmcia.sourceforge.org>

PCMCIA setup on PowerBooks is sketchy, because I can't test it and get
very little feedback from users.

Only a subset of PCMCIA drivers have had any testing on PowerPC
systems.  The supported-cards list shows which drivers are reported to
work on PowerPC; I have not heard that the Wavelan driver works.  It
may be ok, or it may have big-endian/little-endian issues that need to
be sorted out.

/etc/pcmcia/config.opts also needs to be configured specially.  I
would try changing the default memory and IO port windows to something
like:

    include memory 0x80000000-0x80ffffff
    include port 0x100-0x1ff

(remove the 0xc0000-0xfffff memory window, and the other IO port
windows), and see if that works any better, at least for the modem
card.

-- Dave

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. Feedback PCMCIA on PowerPC by Wim Lewis, 2000, Feb 23
1. None Yes, some tips would be a good idea by David Hinds, 2000, Feb 23
2. Note WaveLAN on ppc by Wim Lewis, 2000, Feb 24
1. Question WaveLAN on PPC url? by Peter, 2000, Mar 26
2. None 3C589C works fine with changed memory address (Apple pismo) by Christoph Eyrich, 2000, May 25

Add Message to: "PCMCIA on PowerPC is problematic"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10