Next-in-Thread Next Message

None Too many things changing at once... 

Forum: PCMCIA SCSI Host Adapter Issues
Re: Sad Problem w/aha152x_cs: "soft interrupt lost"(kernel 2.2.13 only!) (Serge Winitzki)
Date: 1999, Dec 07
From: David Hinds <dhinds@pcmcia.sourceforge.org>

Ok...

according to your log, 3.0.5 worked with irq 4 and io 0x140.

3.1.5 did not work, with irq 3 and io 0x1740.

3.0.14 did not work, with irq 5 and io 0x140.

It doesn't really matter what interrupts appear to be available.  Some
interrupts may not even be physically connected to your PCMCIA bridge. 
Also, if a device is "disabled", that doesn't necessarily mean that
its interrupt is available for use by another arbitrary device.

What I would do is to try to recreate the 3.0.5 situation.  Exclude
irq 3 in your config.opts file, but don't exclude irq 4.  And exclude
the 0x1000-0x17ff io port range.

-- Dave

Next-in-Thread Next Message

Messages Inline: 0 1

Ok thank you, it works now

Re: None Too many things changing at once... (David Hinds)
Date: 1999, Dec 07
From: Serge Winitzki winitzki

Thanks, I was able to make it work.

I excluded the upper port range 0x1000-0x17ff, included irq4 and specified "irq_list=4,5,12" and the card worked after a reboot. (Was a reboot really necessary?
Now the log is the same as the old pcmcia-3.0.5 log. Thanks a lot!
Regards,
Serge
Too many things changing at once...


Add Message to: "Too many things changing at once..."

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10