Next-in-Thread Next Message

Question Adaptec 1480 + LinuxPPC: possible? 

Forum: PCMCIA SCSI Host Adapter Issues
Date: 2000, May 11
From: Albrecht Dress Albrecht.Dress

Hello!

I am new to this list, so please excuse me if this is the wrong place for this question...

I want to use an Adaptec 1480 CardBus card on an Apple PowerBook/500 (which does not have internal SCSI any more) under LinuxPPC 2.2.15pre20. The "generic" aic7xxx driver is reported to work with LinuxPPC (e.g. with the '2940), so I tried the pcmcia package. The installation went fine, I fixed the config files, the card is detected, but at some point there is a message "disabled by BIOS, ignoring" (see the log, below), and no scsi works. The card is o.k., as it works with MacOS. Does anyone know what went wrong?

Thanks for any help, Albrecht.

---from /var/log/messages

 kernel: Linux PCMCIA Card Services 3.1.14 
 kernel:   kernel build: 2.2.15pre20 #3 Thu May 11 11:18:51 CEST 2000 
 kernel:   options:  [pci] [cardbus] 
 kernel: Intel PCIC probe:  
 kernel:   TI 1211 rev 00 PCI-to-CardBus at slot 00:1a, mem 0x80080000 
 kernel:     host opts [0]: [serial pci & irq] [pci irq 58] [lat 16/32] [bus 1/1] 
 kernel: pci_scan... 
 kernel:   testing PCI irq 58 
 kernel:     PCI card interrupts, polling interval = 1000 ms 
 kernel: cs: cb_alloc(bus 1): vendor 0x9004, device 0x6075 
 cardmgr[607]: starting, version is 3.1.14
 cardmgr[607]: watching 1 sockets
 cardmgr[607]: initializing socket 0
 cardmgr[607]: socket 0: Adaptec APA-1480 SCSI Host Adapter
 cardmgr[607]: executing: 'insmod /lib/modules/2.2.15pre20/pcmcia/cb_enabler.o'
 cardmgr[607]: executing: 'insmod /lib/modules/2.2.15pre20/pcmcia/apa1480_cb.o'
 kernel: cs: cb_config(bus 1) 
 kernel:   fn 0 bar 1: io 0x0-0xff 
 kernel:   fn 0 bar 2: mem 0x90030000-0x90030fff 
 kernel:   fn 0 rom: mem 0x90020000-0x9002ffff 
 kernel: apa1480_attach(bus 1, function 0) 
 kernel: aic7xxx: <Adaptec PCMCIA SCSI controller> at PCI 1/0/0 
 kernel: aic7xxx: Initial PCI_COMMAND value was 0x7 
 kernel: aic7xxx: Initial DEVCONFIG value was 0x1000 
 kernel: aic7xxx: <Adaptec PCMCIA SCSI controller> at PCI 1/0/0 
 kernel: aic7xxx: Controller disabled by BIOS, ignoring. 
 kernel: apa1480_cs: no SCSI devices found 
 kernel: scsi : 0 hosts. 
 cardmgr[607]: get dev info on socket 0 failed: No such device

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None IO window allocation glitch by David Hinds, 2000, May 11
(_ Sad This did not work... by Albrecht Dress, 2000, May 17

Add Message to: "Adaptec 1480 + LinuxPPC: possible?"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10