Next-in-Thread Next Message

Sad Sierra Wireless Modem 

Forum: PCMCIA Serial and Modem Issues
Date: 2000, Jan 25
From: Roy Murphy Royster

I just upgraded my system from RedHat 5.2 to Mandrake 7.0 and my Sierra Wireless Modem/Cell Modem card has stopped working. I applied Jeff Schoby's patches for the aircard to a version 3.1.9 PCMCIA source and recompiled/reinstalled. I just mention this for completeness. The patch dosn't touch the serial_cs driver which is causing me the problem. I've also checked against an unpatched 3.1.9 install.

The problem is that the modem does not respond. If I load minicom, I can't get it to return an OK to ATZ and minicom hangs and will not quit if I try to shut it down until I remove the card. The card works in a Windows laptop (I can get an OK back from a terminal program) and should appear to be a generic modem. A Megahertz modem card works fine in this installation,

From /var/log/messages:

Jan 25 09:13:19 agape cardmgr[276]: initializing socket 0
Jan 25 09:13:19 agape cardmgr[276]: socket 0: Serial or Modem
Jan 25 09:13:20 agape cardmgr[276]: executing: 'insmod /lib/modules/2.2.14-15mdksecure/pcmcia/serial_cs.o'
Jan 25 09:13:20 agape kernel: tty02 at 0x13f8 (irq = 3) is a 16450
Jan 25 09:13:20 agape cardmgr[276]: executing: './serial start ttyS2'          

Two beeps on install. So far, so good.

[root@agape linux]# dump_cis
Socket 0:
  dev_info
    NULL 0ns, 512b
  vers_1 4.1, "Sierra Wireless", "Aircard Modem", "Version 1.0"
  manfid 0x0192, 0x0201
  funcid serial_port [post]
  serial_data_services
    data_rate 115200
    modulation [Bell103] [V.21] [V.23] [V.22] [Bell212A]
      [V.22bis] [V.27bis] [V.29] [V.32] [V.32bis]
    error_control [MNP2-4] [V.42/LAPM]
    compression [V.42bis] [MNP5]
    cmd_protocol [AT1] [AT2] [AT3] [MNP_AT] [V.25bis]
  serial_fax_services [class=1]
    data_rate 115200
    modulation [V.21-C2] [V.27ter] [V.29] [V.17]
    features [T.4]            
  config base 0x1000 mask 0x0007 last_index 0x23
  cftable_entry 0x20 [default]
    [rdybsy] [audio]
    Vcc Vnom 5V Istatic 180mA Ipeak 220mA
    timing ready 3705032704ns
    io 0x03f8-0x03ff [lines=10] [8bit] [range]
    irq mask 0x86bc [level]
  cftable_entry 0x21
    io 0x02f8-0x02ff [lines=10] [8bit] [range]
  cftable_entry 0x22
    io 0x03e8-0x03ef [lines=10] [8bit] [range]
  cftable_entry 0x23                                   
   io 0x02e8-0x02ef [lines=10] [8bit] [range]

everything looks cozy.

From the startup of PCMCIA services:

Jan 25 09:00:03 agape pcmcia: Starting PCMCIA services:
Jan 25 09:00:03 agape pcmcia:  modules
Jan 25 09:00:04 agape kernel: Linux PCMCIA Card Services 3.1.9
Jan 25 09:00:04 agape kernel:   kernel build: 2.2.14-15mdksecure #1 SMP Tue Jan 4 21:15:44 CET 2000
Jan 25 09:00:04 agape kernel:   options:  [pci] [cardbus]
Jan 25 09:00:04 agape kernel: Intel PCIC probe:
Jan 25 09:00:04 agape kernel:   TI 1131 PCI-to-CardBus at bus 0 slot 6, mem 0x68000000, 2 sockets
Jan 25 09:00:04 agape kernel:     host opts [0]: [ring] [clkrun irq 10] [pci + serial irq] [no pci irq] [lat 64/176] [bus 1/1]
Jan 25 09:00:04 agape kernel:     host opts [1]: [ring] [clkrun irq 10] [pci + serial irq] [no pci irq] [lat 64/176] [bus 2/2]
Jan 25 09:00:04 agape kernel:     ISA irqs (scanned) = 3,4,7,10,15 polling interval = 1000 ms
Jan 25 09:00:04 agape pcmcia:  cardmgr.
Jan 25 09:00:05 agape cardmgr[276]: starting, version is 3.1.9
Jan 25 09:00:05 agape rc: Starting pcmcia succeeded
Jan 25 09:00:05 agape cardmgr[276]: watching 2 sockets
Jan 25 09:00:05 agape kernel: cs: IO port probe 0x1000-0x17ff: clean.
Jan 25 09:00:05 agape kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x170-0x177 0x200-0x207 0x220-0x22f 0x330-0x337 0x370-0x37f 0x388-0x38f 0x398-0x39f 0x4d0-0x4d7
Jan 25 09:00:05 agape kernel: cs: IO port probe 0x0a00-0x0aff: clean.

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None It's an IO port issue by David Hinds, 2000, Jan 25

Add Message to: "Sierra Wireless Modem"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10