Next-in-Thread Next Message

Sad Tecra 700CT + Linksys = "Tx timed out" 

Forum: PCMCIA on Toshiba laptops
Date: 2000, Jan 26
From: Judah Milgram Jud

Hi,

This is either a bug report or a user problem, not sure which.

System: Toshiba Tecra 700CT
        Slackware 3.x
        Kernel 2.0.38
        pcmcia 3.0.14 (should I be using 3.1.x?)
        Brand new Linksys Etherfast PCMPC100 10/100 PC card
        removed other PC card (a modem, which works)

In /etc/rc.d/rc.pcmcia:
        uncommented PCIC=i82365
        PCIC_OPTS="do_scan=0 irq_list=9" (added this
        as part of troubleshooting; tried different
        variations along the way)

In /etc/pcmcia/pcmcia.opts:
        exclude irq 4
        ... and 3,5,7,10 along the way.

When I do /etc/rc.d/rc.pcmcia start I get the two beeps
        and dmesg tells me: 

Linux PCMCIA Card Services 3.0.14
  kernel build: 2.0.38 #6 Wed Jan 12 17:41:28 EST 2000
  options:  [pci] [apm]
Intel PCIC probe: 
  Toshiba ToPIC95-A PCI-to-CardBus at bus 0 slot 2, mem 0xffeff000, 2 sockets
    host opts [0]: [slot 0xf0] [ccr 0x00] [cdr 0x86] [rcr0x00] [no pci irq] [lat 168/176] [bus 1/1]
    host opts [1]: [slot 0xf1] [ccr 0x00] [cdr 0x86] [rcr0x00] [no pci irq] [lat 168/176] [bus 2/2]
    ISA irqs (default) = 9 polling interval = 1000 ms
cs: IO port probe 0x1000-0x17ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x378-0x37f 0x388-0x38f 0
x3b0-0x3df 0x480-0x48f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0x0d0000-0x0dffff: clean.
eth0: NE2000 Compatible: io 0x300, irq 9, hw_addr 00:E0:98:71:44:32


Also, /var/run/stab says:

Socket 0: Linksys EtherFast 10/100 Fast Ethernet
0       network pcnet_cs        0       eth0
Socket 1: empty


All this says to me that the Linksys card is recognized,
the driver loads, the irq is set to 9 (which I determined
to be free), and the ioport set to 0x300 (also free). However,
I can't ping out. And I get these
in the system logs:

eth0: Tx timed out, lost interrupt? TSR=0x43, ISR=0x3, t=1000.
eth0: Tx timed out, lost interrupt? TSR=0x43, ISR=0x3, t=6500.
eth0: Tx timed out, lost interrupt? TSR=0x43, ISR=0x3, t=12000.
eth0: Tx timed out, lost interrupt? TSR=0x43, ISR=0x3, t=12000.

NB network configuration should be OK, is essentially
unchanged from back when it worked via another network
device. Also, ifconfig reports eth0 up with sensible
parameters. route -n too.

I'm thoroughly perplexed, my research turned up only the
do_scan=0 idea, and sadly this didn't help. Any advice
greatly appreciated.

Judah

milgram@cgpp.com

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. More More info on this by Judah Milgram, 2000, Jan 26
(_ None ... and more yet by Judah Milgram, 2000, Jan 26
(_ Ok Yay! by Judah Milgram, 2000, Jan 30

Add Message to: "Tecra 700CT + Linksys = "Tx timed out""

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10