Next-in-Thread Next Message

Question ifconfig crash on a Satellite 4070CDT with D-Link DFE-660 

Forum: PCMCIA on Toshiba laptops
Date: 1999, Nov 23
From: Kai Hoefler Kai

Hi,

I had my Ethernetcard D-Link DFE-660 working with RH 6.1 and pcmcia-3.0.14. After I tried to configure my soundcard it stopped working. But since then I was not able to get my network working again. I checked that the sound modules do not get loaded any more but that changed nothing. I now upgraded to Kernel 2.2.13 and pcmcia-3.1.4 but with no success.

When the card is inserted I get 2 beeps and ifconfig -a shows:

eth0      Link encap:Ethernet  HWaddr 00:80:C8:8F:61:0C  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:5 Base address:0x200 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 

which looks good.

dmesg tells me

.....

 Linux PCMCIA Card Services 3.1.4
  kernel build: 2.2.13 #1 Tue Nov 23 14:03:51 CET 1999
  options:  [pci] [cardbus] [apm]
 Intel PCIC probe: 
  Toshiba ToPIC97 PCI-to-CardBus at bus 0 slot 2, mem  0x68000000, 2 sockets
    host opts [0]: [slot 0xf0] [ccr 0x10] [cdr 0x86] [rcr
0x02] [no pci irq] [lat 168/176] [bus 20/20]
    host opts [1]: [slot 0xf0] [ccr 0x20] [cdr 0x86] [rcr  
0x02] [no pci irq] [lat 168/176] [bus 21/21]
    ISA irqs (default) = 4,5,7,9,10,12 polling interval = 1000 ms
 cs: IO port probe 0x1000-0x17ff: clean.
 cs: IO port probe 0x0100-0x04ff: excluding 0x378-0x37f 0x4d0-0x4d7
 cs: IO port probe 0x0a00-0x0aff: clean.
 cs: cb_alloc(bus 21): vendor 0x1011, device 0x0019
 cs: cb_config(bus 21)
  fn 0 bar 1: io 0x200-0x27f
  fn 0 bar 2: mem 0x60081000-0x600813ff
  fn 0 rom: mem 0x60041000-0x60080fff
 cs: cb_enable(bus 21)
  bridge io map 0 (flags 0x21): 0x200-0x27f
  bridge mem map 0 (flags 0x1): 0x60041000-0x60081fff
 tulip_attach(bus 21, function 0)
 tulip.c:v0.91 4/14/99 becker@cesdis.gsfc.nasa.gov (modified 
by danilo@cs.uni-magdeburg.de for XIRCOM CBE, fixed by Doug Ledford)
 eth0: Digital DS21143 Tulip rev 73 at 0x200, 00:80:00:80:00:80, IRQ 5.
 eth0:  EEPROM default media type 10baseT.
 eth0:  MII transceiver #0 config 3000 status 7809 advertising 01e1.

which also looks good.

But as soon as I try to start the network either with /etc/rc.d/init.d/network start or simply with ifconfig eth0 129.69.129.119 netmask 255.255.255.0 broadcast 129.69.120.255

ifconfig crashes with the following message

 Unable to handle kernel NULL pointer dereference at virtual  address 00000000
 current->tss.cr3 = 008a0000, %cr3 = 008a0000
 *pde = 00000000
 Oops: 0000
 CPU:    0
 EIP:    0010:[<c4037051>]
 EFLAGS: 00010246
 eax: fffffff8   ebx: ffffffff   ecx: 00000000   edx: c3c58c08
 esi: 00000000   edi: c3c83c60   ebp: c06efdf0   esp: c06efda4
 ds: 0018   es: 0018   ss: 0018
 Process ifconfig (pid: 697, process nr: 26, stackpage=c06ef000)
 Stack: c3c83c60 00000000 00000286 c10183c0 00000610 00000008 c06efe48 00000003 
       0000001c c01c1cc7 0000016d c3c58c08 00000200 c3c58c00 c0557000 00000200 
       00000286 000000c8 c06efe44 c06efe44 c4036c04 c3c83c60 00000001 c3c83c60 
 Call Trace: [<c01c1cc7>] [<c4036c04>] [<c4036fb7>]  [<c0164650>] [<c016515b>] [<c
 01645a9>] [<c017c28f>] 
       [<c017c16d>] [<c017dc8a>] [<c012b0a0>] [<c016115f>] [<c0162183>] [<c010df db>] [<c012d08f>] [<c0108bdd>] 
       [<c0108ad8>] 
 Code: 8a 06 8b 55 08 88 42 3c 83 7d 0c 00 74 15 8b 45 e8 0f b6 48 

Is there anybody who knows whats wrong or what I am missing.

The strange thing is that it worked but I am not able to get back to that. The hardware seems to be fine as I am able to use the card with Windows.

Thanks for any suggestion

Kai Hoefler

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None Resource conflict? by David Hinds, 1999, Nov 23
(_ Feedback Don't think so by Kai Hoefler, 1999, Nov 24

Add Message to: "ifconfig crash on a Satellite 4070CDT with D-Link DFE-660"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10