Next-in-Thread Next Message

Question PrismII based card, WLAN device not showing up in ifconfig 

Forum: PCMCIA Wireless Network Adapter Issues
Date: 2000, May 11
From: Patrick Neill Patrick

Hello

My configuration is as follows:
- Redhat 6.2
- 3.1.8 PCMCIA package
- Compaq WL 200 PCI card (the drivers seems to think it is a WL100, the manfid for both cards is the same however)
- PrismII drivers from www.absoval.com

When the drivers have loaded, ifconfig doesn't show an additional device apart from my already installed NE2000.

The output from messages shows some unresolved symbols. Does anyone have any idea what could be preventing the wlan device from showing up in ifconfig?

Thanks


May 12 00:19:39 hsg7960 pcmcia: Starting PCMCIA services:
May 12 00:19:39 hsg7960 pcmcia: modules
May 12 00:19:39 hsg7960 kernel: Linux PCMCIA Card Services 3.1.8
May 12 00:19:39 hsg7960 kernel: kernel build: 2.2.14-5.0 #1 Tue Mar 7 20:53:41 EST 2000
May 12 00:19:39 hsg7960 kernel: options: [pci] [cardbus] [apm] [pnp]
May 12 00:19:39 hsg7960 kernel: PnP: PNP BIOS installation structure at 0xc00f9560
May 12 00:19:39 hsg7960 kernel: PnP: PNP BIOS version 1.0, entry at f0000:9660, dseg at 400
May 12 00:19:39 hsg7960 kernel: Intel PCIC probe:
May 12 00:19:39 hsg7960 kernel: Cirrus PD6729 PCI-to-PCMCIA at bus 0 slot 15, port 0xfff4, 2 sockets
May 12 00:19:39 hsg7960 kernel: host opts [0]: [ring] [1/5/0] [1/20/0]
May 12 00:19:39 hsg7960 kernel: host opts [1]: [ring] [1/5/0] [1/20/0]
May 12 00:19:40 hsg7960 kernel: ISA irqs (default) = 5,10,11 polling interval = 1000 ms
May 12 00:19:40 hsg7960 pcmcia: cardmgr.
May 12 00:19:40 hsg7960 cardmgr[480]: starting, version is 3.1.8
May 12 00:19:40 hsg7960 rc: Starting pcmcia succeeded
May 12 00:19:40 hsg7960 cardmgr[480]: watching 2 sockets
May 12 00:19:40 hsg7960 kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x470-0x477
May 12 00:19:40 hsg7960 cardmgr[480]: initializing socket 0
May 12 00:19:40 hsg7960 kernel: cs: memory probe 0x0d0000-0x0dffff: clean.
May 12 00:19:40 hsg7960 cardmgr[480]: socket 0: Compaq WL100 11Mb/s WLAN Card
May 12 00:19:40 hsg7960 lpd: lpd startup succeeded
May 12 00:19:40 hsg7960 lpd[494]: restarted
May 12 00:19:40 hsg7960 cardmgr[480]: executing: 'insmod /lib/modules/2.2.14-5.0/pcmcia/prism2_cs.o'
May 12 00:19:40 hsg7960 cardmgr[480]: + /lib/modules/2.2.14-5.0/pcmcia/prism2_cs.o: unresolved symbol p80211pb_alloc_p80211
May 12 00:19:40 hsg7960 cardmgr[480]: + /lib/modules/2.2.14-5.0/pcmcia/prism2_cs.o: unresolved symbol p80211pb_free
May 12 00:19:40 hsg7960 cardmgr[480]: + /lib/modules/2.2.14-5.0/pcmcia/prism2_cs.o: unresolved symbol register_wlandev
May 12 00:19:40 hsg7960 cardmgr[480]: + /lib/modules/2.2.14-5.0/pcmcia/prism2_cs.o: unresolved symbol p80211netdev_rx
May 12 00:19:40 hsg7960 cardmgr[480]: + /lib/modules/2.2.14-5.0/pcmcia/prism2_cs.o: unresolved symbol unregister_wlandev
May 12 00:19:40 hsg7960 cardmgr[480]: + /lib/modules/2.2.14-5.0/pcmcia/prism2_cs.o: unresolved symbol wlan_setup
May 12 00:19:40 hsg7960 cardmgr[480]: + /lib/modules/2.2.14-5.0/pcmcia/prism2_cs.o: unresolved symbol p80211ind_sniff
May 12 00:19:40 hsg7960 cardmgr[480]: + /lib/modules/2.2.14-5.0/pcmcia/prism2_cs.o: unresolved symbol wlan_unsetup
May 12 00:19:40 hsg7960 cardmgr[480]: insmod exited with status 1
May 12 00:19:40 hsg7960 cardmgr[480]: executing: 'modprobe prism2_cs'

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None Well, if the module can't be loaded, that would do it by David Hinds, 2000, May 15
2. Question Compaq WL100 WLAN Card by Talei McLeod, 2000, Aug 11
3. Sad Also greiving with a Compaq WL200, Has any one made one work?? by harry campigli, 2000, Aug 22

Add Message to: "PrismII based card, WLAN device not showing up in ifconfig"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10