Next-in-Thread Next Message

Sad Yet more fun with that PCI -> Orinoco Card 

Forum: PCMCIA Wireless Network Adapter Issues
Date: 2000, Jun 07
From: Alan Knowles alan_k

Having spent most of the afternoon trying to get it to work, Here is my current situation (with experiences!). Any helpfull hints etc would be appreciated :)

Basic Plan:
1 toshiba protable with the lucent card, - this seems to be working OK with the wvlan_cs module - eg. no error messages seem to be comming out of dmesg or /var/log/syslog.
 - its a debian install with kernel 2.2.15 (from deb package) and pcmcia 3.1.15 (from source) , seems to be quite easy - relative to the next machine! 

1 ibm netfinity using the PCI -> PCMCIA adapter. I did try this adapter at home, however it appeared not to be picked up by the bioses on 2 machines - probably needs musical chairs played with the slots..

After doing alot of experimenting - and rereading this list a number of times. I have tried

wvlan driver - got pretty much the same messages as mentioned before on this list - It seems to install but I get timeout errors on the system.

wavelan2_cs driver (6BETA)- binary from sourceforge contrib - following one of the later posts on this list.. the basic 3 points wher for this combination - only the 6BETA and PCIC_OPTS="irq_mode=0" in /etc/init.d/pcmcia (I havent bothered with /etc/pcmcia.conf (typical debian) the pretty much module "wavelan2_cs" opts "port_type=3" in /etc/pcmcia/config.opts

now WITHOUT the irq_mode=0
Intel PCIC probe:
  TI 1225 rev 01 PCI-to-CardBus at slot 00:12, mem 0xefef7000
    host opts [0]: [isa irq] [no pci irq] [lat 168/176] [bus 32/34]
    host opts [1]: [isa irq] [no pci irq] [lat 168/176] [bus 35/37]
    ISA irqs (default) = 5 polling interval = 1000 ms
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x388-0x38f
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
eth1: WaveLAN/IEEE, io_addr 0x100, irq 5, mac_address 00:60:1D:F2:38:11
eth1: Transmit timeout.
eth1: Transmit timeout.
eth1: Transmit timeout...... AND SO ON!

Now WITH the irq_mode=0
Intel PCIC probe:
  TI 1225 rev 01 PCI-to-CardBus at slot 00:12, mem 0xefef7000
    host opts [0]: [pci only] [no pci irq] [lat 168/176] [bus 32/34]
    host opts [1]: [pci only] [no pci irq] [lat 168/176] [bus 35/37]
    *NO* card interrupts, polling interval = 1000 ms
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x388-0x38f
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
wavelan2_cs: RequestIRQ: Resource in use

now WITH  PCIC_OPTS="irq_mode=0 ,pci_irq_list=5,5 "
same as above except
  TI 1225 rev 01 PCI-to-CardBus at slot 00:12, mem 0xefef7000
    host opts [0]: [pci only] [pci irq 5] [lat 168/176] [bus 32/34]
    host opts [1]: [pci only] [pci irq 5] [lat 168/176] [bus 35/37]
    PCI irq 5 test failed
    *NO* card interrupts, polling interval = 1000 ms

even trying irq_masq on the config.opt line for wavelan2_cs make no difference...

As you can see, I have definatly had enough of this for one day :( ..

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None [no pci irq] is the problem by David Hinds, 2000, Jun 07
(_ Ok pcmcia all working by Alan Knowles, 2000, Jun 08

Add Message to: "Yet more fun with that PCI -> Orinoco Card"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10