Next-in-Thread Next Message

News Same old problem, new pcmcia_cs-version. 

Forum: PCMCIA Wireless Network Adapter Issues
Re: Sad Problems with 3.1.15 + wavelan2_cs driver (Bjorn Knutsson)
Re: None Fishy modules.conf setup?? (David Hinds)
Re: Disagree No fish in my conf.modules. (Bjorn Knutsson)
Re: None Re: Disagree: No fish in my conf.modules. (David Hinds)
Date: 2000, Jul 18
From: Bjorn Knutsson bjorn

I'm sorry about not getting back about the problem, but I was swamped with work.

I just installed pcmcia-cs 3.1.18 + wavelan2_cs 6.01BETA from contrib, and my troubles continue. When I insert the Wavelan card, cardmgr dies.

> I would try issuing that modprobe command by hand, adding a "-v", and see what it does.

Loading the module is not a problem. It just echos the insmod-line and nothing more.

> The log doesn't seem to include any hints about how/when cardmgr might have died. I guess you just noticed it wasn't running any more after you inserted the card?

It now definitely dies at the point where it loads the module. It now logs no more messages after the modprobe for wavelan2_cs, and checking the system immediately after, the wavelan2_cs module is loaded, and cardmgr is not around anymore.

> I guess I'd also look at /lib/modules/.../modules.dep and examine the dependencies for wavelan2_cs.o.

No problems there either, from what I can see.

I have experimented some more. This is what happens now:

If I insert a card, say my old 3c562C, it configures OK. So I unplug it, and insert my Wavelan. It comes to the modprobe wavelan2_cs, and then I see no more messages in the logs (I run cardmgr with -v). And looking around, cardmgr is no longer running. Now, if I at this point manually run cardmgr -v -f, it will complain about "could not adjust resource" for memory and IO ports, but will then initialize socket 0 and correctly configure the wavelan2_cs driver and everything is fine.

Remove all cards and restart pcmcia. I now insert my 3c562c in socket 0. It configures OK. I then insert the Wavelan in socket 1. cardmgr dies, as before, after the modprobe. I, again, run 'cardmgr -v -f'. Lots of "could not adjust resource" as before, but the card in socket 0 is now identified as "Anonymous Memory". The wavelan2_cs driver is again configured correctly, and everything is fine with the wavelan card.

So to conclude: cardmgr seems to die when or soon after the modprobe for wavelan2_cs is issued. It seems that it will configure correctly when the module is already loaded (and whatever else cardmgr may have node). I did, however, try to modprobe the module and then insert the card, but then my machine locked up.

Here's the log:

Jul 18 17:07:14 foobar cardmgr[480]: initializing socket 0
Jul 18 17:07:14 foobar cardmgr[480]: socket 0: Lucent Technologies WaveLAN/IEEE
Jul 18 17:07:14 foobar kernel: cs: memory probe 0xa0000000-0xa0ffffff: excluding 0xa0000000-0xa0ffffff 
Jul 18 17:07:14 foobar kernel: cs: memory probe 0x60000000-0x60ffffff: clean. 
Jul 18 17:07:14 foobar cardmgr[480]:   product info: "Lucent Technologies", "WaveLAN/IEEE", "Version 01.01", ""
Jul 18 17:07:14 foobar cardmgr[480]:   manfid: 0x0156, 0x0002  function: 6 (network)
Jul 18 17:07:14 foobar cardmgr[480]: executing: 'modprobe wavelan2_cs station_name=foobar enable_encryption=y transmit_key_id=1 channel=0 port_type=1 network_name=FOOBAR key_1=\"snafu\"'

Restarted cardmgr:

Jul 18 17:07:31 foobar cardmgr[625]: starting, version is 3.1.18
Jul 18 17:07:31 foobar cardmgr[625]: watching 2 sockets
Jul 18 17:07:31 foobar cardmgr[625]: could not adjust resource: IO ports 0xc00-0xcff: Device or resource busy
Jul 18 17:07:31 foobar cardmgr[625]: could not adjust resource: IO ports 0x800-0x8ff: Device or resource busy
Jul 18 17:07:31 foobar cardmgr[625]: could not adjust resource: IO ports 0x100-0x4ff: Device or resource busy
Jul 18 17:07:31 foobar cardmgr[625]: could not adjust resource: memory 0xc0000-0xfffff: Input/output error
Jul 18 17:07:31 foobar cardmgr[625]: could not adjust resource: memory 0x60000000-0x60ffffff: Input/output error
Jul 18 17:07:31 foobar cardmgr[625]: could not adjust resource: IO ports 0xa00-0xaff: Device or resource busy
Jul 18 17:07:31 foobar cardmgr[625]: initializing socket 0
Jul 18 17:07:31 foobar cardmgr[625]: socket 0: Lucent Technologies WaveLAN/IEEE
Jul 18 17:07:31 foobar cardmgr[625]:   product info: "Lucent Technologies", "WaveLAN/IEEE", "Version 01.01", ""
Jul 18 17:07:31 foobar cardmgr[625]:   manfid: 0x0156, 0x0002  function: 6 (network)
Jul 18 17:07:31 foobar kernel: eth0: WaveLAN/IEEE, io_addr 0x100, irq 3, mac_address xx:xx:xx:xx:xx:xx 
Jul 18 17:07:31 foobar cardmgr[625]: executing: './network start eth0'
Jul 18 17:07:32 foobar pumpd[638]: starting at (uptime 0 days, 0:03:55) Tue Jul 18 17:07:32 2000  
Jul 18 17:07:32 foobar pumpd[638]: configured interface eth0
Jul 18 17:07:32 foobar cardmgr[625]: exiting

(I edited the mac_address)

Next-in-Thread Next Message

Select this message: Same old problem, new pcmcia_cs-version.

Messages Inline: 1 All Outline: 1 2 All

1. None Fixed: a really dumb bug by David Hinds, 2000, Jul 22
(_ Ok Re: Fixed: a really dumb bug by Bjorn Knutsson, 2000, Jul 22

Message Administration

This form allows you to delete, move, or copy one or more messages. You can move messages by copying and deleting the original. The action will be applied to the messages you select above and all replies to those selected messages.


If you want to copy or move messages, specify the HyperNews path of a destination forum or message that all messages will be copied or moved to. The destination must already exist, so maybe create it first.

Path of Destination (a Forum or Message): (e.g. "test")

Notify Subscribers at destination
NO


If you want to delete messages (the default), specify that here. If you want to move messages, you need to delete the original messages; placeholders will be left pointing to where they were moved.

Delete Messages
NO


Caution: After deleteing messages (the default), if you have not copied them (i.e. no destination above), then the selected messages are not be recoverable.

Members Subscribe No Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10
[ Edit This Forum ]