Next-in-Thread Next Message

Question Wavelan 11 Mb/s Problem 

Forum: PCMCIA Wireless Network Adapter Issues
Date: 2000, Jun 15
From: Randy Broman rbroman

Attempting to install Wavelan 11 Mb/s PCMCIA card(s) in "non-laptop" using Wavelan PCI adapter. RedHat system with 2.2.14 kernel. Using Wavelan 6.00 driver from their site, and PCMCIA 3.1.16. System logs below .... to me it looks like PCMCIA services comes up OK .... but when the card is inserted the system freezes. On insertion card emits one high beep, on removal a high and a low.

Ideas appreciated, Randy

Following an /etc/rc.d/init.d/pcmcia start

Jun 12 18:05:00 jboat kernel: Linux PCMCIA Card Services 3.1.16
Jun 12 18:05:00 jboat kernel:   kernel build: 2.2.14-12test8 #5 Sun Jun
11 06:11:38 EDT 2000
Jun 12 18:05:00 jboat kernel:   options:  [pci] [cardbus] [apm] [pnp]
Jun 12 18:05:00 jboat kernel: PCI routing table version 1.0 at 0xfdd50
Jun 12 18:05:00 jboat kernel:   00:12.0 -> irq 5
Jun 12 18:05:00 jboat kernel:   00:12.1 -> irq 5
Jun 12 18:05:00 jboat kernel: PnP: PNP BIOS installation structure at
0xc00fbf00 Jun 12 18:05:00 jboat kernel: PnP: PNP BIOS version 1.0, entry at f0000:bf28, dseg at f0000
Jun 12 18:05:00 jboat kernel: Intel PCIC probe:
Jun 12 18:05:00 jboat kernel:   TI 1225 rev 01 PCI-to-CardBus at slot
00:12, mem 0xdf002000 Jun 12 18:05:00 jboat kernel: host opts [0]: [pci only] [pci irq 5] [lat 32/176] [bus 32/34] Jun 12 18:05:00 jboat kernel: host opts [1]: [pci only] [pci irq 5] [lat 32/176] [bus 35/37] Jun 12 18:05:00 jboat kernel: PCI card interrupts, PCI status changes
Jun 12 18:05:00 jboat cardmgr[924]: starting, version is 3.1.16
Jun 12 18:05:00 jboat cardmgr[924]: watching 2 sockets
Jun 12 18:05:00 jboat kernel: cs: IO port probe 0x1000-0x17ff: clean.
Jun 12 18:05:00 jboat kernel: cs: IO port probe 0x0100-0x04ff: clean.

Now the Wavelan card is inseted into the PCMCIA slot ...... the machine freezes ...... and then the card is removed

It looks like the card is recognized, a socket is set up, the driver is loaded, but then something goes wrong.

Jun 12 18:05:26 jboat cardmgr[924]: initializing socket 0
Jun 12 18:05:26 jboat kernel: cs: memory probe 0xa0000000-0xa0ffffff:
clean. Jun 12 18:05:26 jboat cardmgr[924]: socket 0: Lucent Technologies WaveLAN/IEEE Jun 12 18:05:27 jboat cardmgr[924]: executing: 'modprobe wavelan2_cs network_name=Ocean station_name=Wave2' Jun 12 18:05:28 jboat kernel: eth2: WaveLAN/IEEE, HCF failure: "Card not found (ejected unexpectedly)" Jun 12 18:05:29 jboat cardmgr[924]: get dev info on socket 0 failed: No such device
Jun 12 18:05:31 jboat cardmgr[924]: shutting down socket 0
Jun 12 18:05:31 jboat cardmgr[924]: executing: 'modprobe -r wavelan2_cs'

-

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None Fixed in 6.01beta driver by David Hinds, 2000, Jun 15

Add Message to: "Wavelan 11 Mb/s Problem"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10