Next-in-Thread Next Message

None 3.1.8 can't figure out the interrupt routing 

Forum: PCMCIA Wireless Network Adapter Issues
Re: Question lucent ieee turbo pci adapter (Bob Cohen)
Date: 2000, Jan 31
From: David Hinds <dhinds@pcmcia.sourceforge.org>

Try again with pcmcia-cs-3.1.9; it should be able to deduce the PCI
interrupt assignment for the TI 1225 bridge.  Then set:

    PCIC_OPTS="irq_mode=0"

which tells the i82365 driver that the TI 1225 does not have any ISA
interrupt connections.

-- Dave

Next-in-Thread Next Message

Messages Inline: 0 1

Sad didn't work

Re: None 3.1.8 can't figure out the interrupt routing (David Hinds)
Date: 2000, Jan 31
From: Bob Cohen bonobob

That didn't work. Looks like the minimal set of options necessary to get the wavelan module to load is:

 PCIC_OPTS="pci_int=1 irq_mode=0 pci_csc=1 pci_irq_list=7,7"

With this, the module loads, but again interrupts don't work (both card services, and the driver's interrupts). Also, irq7 seems to be the only one that works. How do you find out what irqs are valid for PCI? If I don't specify pci_irq_list, it doesn't work, so obviously probing isn't working.

This may be a red herring, but my bios has a field "reserve irq5", which allows irq5 to be devoted to "legacy isa devices" (whatever that means). I tried turning this on, and using isa interrupts - this didn't work either.

None Fixed...

Re: Sad didn't work (Bob Cohen)
Date: 2000, Feb 18
From: David Hinds <dhinds@pcmcia.sourceforge.org>

The interrupt routing problem is fixed in the latest (3.1.11) drivers.

-- Dave

Question "3.1.8 can't figure out the interrupt routing"

Re: None 3.1.8 can't figure out the interrupt routing (David Hinds)
Date: 2000, Feb 18
From: Gerald Richter richter

I have the same problem with a lucent WaveLan IEEE and a CL 6729 PCI Controller. I can access the card, but no interrupts are coming thru. The lspci shows that

"pin A routed to IRQ 11"

but I am not able to set anything to irq 11. When I don't specify an irq, the irq of the wvlan_cs driver is set to 5 and no irq is comming thru (/proc/interrupts shows 0).

What are the correct irq that the wvlan_cs driver should use, how can I debug this problem further?

Thanks for any help

Gerald

None This is a somewhat rare configuration

Re: Question "3.1.8 can't figure out the interrupt routing" (Gerald Richter)
Date: 2000, Feb 18
From: David Hinds <dhinds@pcmcia.sourceforge.org>

The current PCMCIA drivers can't handle the CL 6729 PCI card properly;
the drivers are not set up to allow use of PCI interrupts with this
bridge type.  Fixing this is in my queue of things to do, but I have
not gotten to it yet.

-- Dave

None RE: This is a somewhat rare configuration

Re: None This is a somewhat rare configuration (David Hinds)
Date: 2000, Feb 18
From: Gerald Richter richter

Hi,
>
> The current PCMCIA drivers can't handle the CL 6729 PCI card properly;
> the drivers are not set up to allow use of PCI interrupts with this
> bridge type.  Fixing this is in my queue of things to do, but I have
> not gotten to it yet.
>
thanks for your fast answer. Is there a PCI card (which chip should it
contain?)  that you know that handle interrupts correctly, or is this a
general problem with all PCI PCMCIA bridges?

Gerald

None It's true for most bridges like this

Re: None RE: This is a somewhat rare configuration (Gerald Richter)
Date: 2000, Feb 18
From: David Hinds <dhinds@pcmcia.sourceforge.org>

At the moment, there is no support for PCI-to-PCMCIA (16-bit-only)
bridges that are only wired for PCI interrupts.  PCI-to-CardBus
bridges are ok.

The only exception is the TI PCI1031 PCI-to-PCMCIA bridge, which is
more like a CardBus bridge with some of the CardBus support disabled.
The 3.1.11 drivers try to support this (I don't actually have one, so
I'm working with someone to verify that this works).

-- Dave

Idea Twosamples here...

Re: None 3.1.8 can't figure out the interrupt routing (David Hinds)
Date: 2000, Feb 25
From: Jean Tourrilhes jt

	David,

	I've got two samples here (PCI). I could lend you one
for debugging if you need. I also have one ISA sample which
work fine with 3.1.11 (but not with 2.3.47 ;-).
	By the way, I plan sooner or later to get the PCI
bridges into Linux box, so I'm interested as well...

	Regards,

	Jean
3.1.8 can't figure out the interrupt routing


Members Subscribe No Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10
[ Edit This Forum ]