Next-in-Thread Next Message

Question same problems on single processor 

Forum: PCMCIA Wireless Network Adapter Issues
Re: Sad Lucent PCI/PCMCIA adapter + Wavelan IEEE silver (Douglas S. J. De Couto)
Date: 2000, Jul 16
From: Douglas S. J. De Couto decouto

Hi,

I am still having problems getting my wavelan ieee to work with a
PCI/PCMCIA adapter.  Setup is kernel 2.2.14, pcmcia-cs-3.1.18, on a
single processor machine.  Any suggestions?  I have tried to access
Jean's recent document
(http://bougret.hpl.hp.com/~jt/Linux/Wavelan-IEEE.html) but i couldn'y
get through to his web page...

when i try with /etc/sysconfig/pcmcia as follows:

PCMCIA=yes
PCIC=i82365
PCIC_OPTS=""
CORE_OPTS=""


i get the following log messages:

Jul 16 13:23:13 mindwipe kernel: Linux PCMCIA Card Services 3.1.18 
Jul 16 13:23:13 mindwipe kernel:   kernel build: 2.2.14-5.0 #1 Tue Mar 7 21:07:39 EST 2000 
Jul 16 13:23:13 mindwipe kernel:   options:  [pci] [cardbus] [apm] 
Jul 16 13:23:13 mindwipe kernel: Intel PCIC probe:  
Jul 16 13:23:13 mindwipe kernel:   TI 1225 rev 01 PCI-to-CardBus at slot 00:0f, mem 0x68000000 
Jul 16 13:23:13 mindwipe kernel:     host opts [0]: [isa irq] [no pci irq] [lat 168/176] [bus 32/34] 
Jul 16 13:23:13 mindwipe kernel:     host opts [1]: [isa irq] [no pci irq] [lat 168/176] [bus 35/37] 
Jul 16 13:23:13 mindwipe kernel:     ISA irqs (default) = 3,4,5,7,9,14 polling interval = 1000 ms 
Jul 16 13:23:13 mindwipe cardmgr[4744]: starting, version is 3.1.18
Jul 16 13:23:13 mindwipe cardmgr[4744]: watching 2 sockets
Jul 16 13:23:13 mindwipe kernel: cs: IO port probe 0x1000-0x17ff: excluding 0x12e8-0x12ef 0x16e8-0x16ef 
Jul 16 13:23:13 mindwipe kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x1c8-0x1cf 0x2e8-0x2ef 0x378-0x37f 0x3f0-0x3ff 0x4d0-0x4d7 
Jul 16 13:23:13 mindwipe kernel: cs: IO port probe 0x0a00-0x0aff: excluding 0xae8-0xaef 
Jul 16 13:23:13 mindwipe cardmgr[4744]: initializing socket 0
Jul 16 13:23:13 mindwipe kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean. 
Jul 16 13:23:13 mindwipe cardmgr[4744]: socket 0: Lucent Technologies WaveLAN/IEEE Adapter
Jul 16 13:23:13 mindwipe cardmgr[4744]: executing: 'modprobe wvlan_cs'
Jul 16 13:23:13 mindwipe kernel: wvlan_cs: WaveLAN/IEEE PCMCIA driver v1.0.4 
Jul 16 13:23:13 mindwipe kernel: wvlan_cs: (c) Andreas Neuhaus <andy@fasta.fh-dortmund.de> 
Jul 16 13:23:14 mindwipe kernel: wvlan_cs: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f 
Jul 16 13:23:14 mindwipe kernel: wvlan_cs: Registered netdevice wvlan0 
Jul 16 13:23:14 mindwipe kernel: wvlan_cs: MAC address on wvlan0 is 00 60 1d f0 77 ba  
Jul 16 13:23:14 mindwipe cardmgr[4744]: executing: './network start wvlan0'
Jul 16 13:23:39 mindwipe kernel: wvlan_cs: wvlan0 Tx timed out! Resetting card 
Jul 16 13:23:39 mindwipe kernel: wvlan_cs: MAC address on wvlan0 is 00 60 1d f0 77 ba 
<lots more Tx timeouts...>

the wavelan card does not work, e.g. pings fail, etc.

i then tried with the following options as suggested on the message
board:

PCMCIA=yes
PCIC=i82365
PCIC_OPTS="irq_mode=0"
CORE_OPTS=""

and get the following output in my log:

Jul 16 13:22:15 mindwipe kernel: Linux PCMCIA Card Services 3.1.18 
Jul 16 13:22:15 mindwipe kernel:   kernel build: 2.2.14-5.0 #1 Tue Mar 7 21:07:39 EST 2000 
Jul 16 13:22:15 mindwipe kernel:   options:  [pci] [cardbus] [apm] 
Jul 16 13:22:15 mindwipe kernel: Intel PCIC probe:  
Jul 16 13:22:15 mindwipe kernel:   TI 1225 rev 01 PCI-to-CardBus at slot 00:0f, mem 0x68000000 
Jul 16 13:22:15 mindwipe kernel:     host opts [0]: [pci only] [no pci irq] [lat 168/176] [bus 32/34] 
Jul 16 13:22:15 mindwipe kernel:     host opts [1]: [pci only] [no pci irq] [lat 168/176] [bus 35/37] 
Jul 16 13:22:15 mindwipe kernel:     *NO* card interrupts, polling interval = 1000 ms 
Jul 16 13:22:16 mindwipe cardmgr[4692]: starting, version is 3.1.18
Jul 16 13:22:16 mindwipe cardmgr[4692]: watching 2 sockets
Jul 16 13:22:16 mindwipe kernel: cs: IO port probe 0x1000-0x17ff: excluding 0x12e8-0x12ef 0x16e8-0x16ef 
Jul 16 13:22:16 mindwipe kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x1c8-0x1cf 0x2e8-0x2ef 0x378-0x37f 0x3f0-0x3ff 0x4d0-0x4d7 
Jul 16 13:22:16 mindwipe kernel: cs: IO port probe 0x0a00-0x0aff: excluding 0xae8-0xaef 
Jul 16 13:22:16 mindwipe cardmgr[4692]: initializing socket 0
Jul 16 13:22:16 mindwipe kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean. 
Jul 16 13:22:16 mindwipe cardmgr[4692]: socket 0: Lucent Technologies WaveLAN/IEEE Adapter
Jul 16 13:22:16 mindwipe cardmgr[4692]: executing: 'modprobe wvlan_cs'
Jul 16 13:22:16 mindwipe kernel: wvlan_cs: WaveLAN/IEEE PCMCIA driver v1.0.4 
Jul 16 13:22:16 mindwipe kernel: wvlan_cs: (c) Andreas Neuhaus <andy@fasta.fh-dortmund.de> 
Jul 16 13:22:16 mindwipe kernel: wvlan_cs: RequestIRQ: Resource in use 
Jul 16 13:22:17 mindwipe cardmgr[4692]: get dev info on socket 0 failed: Resource temporarily unavailable


here is the output of dump_pirq:

-------------
No PCI interrupt routing table was found.

Interrupt router at 00:07.0: Intel 82371SB PIIX3 PCI-to-ISA bridge
  PIRQ1 (link 0x60): unrouted
  PIRQ2 (link 0x61): irq 10
  PIRQ3 (link 0x62): irq 11
  PIRQ4 (link 0x63): unrouted
  Serial IRQ: [disabled] [quiet] [frame=17] [pulse=4]
---------------

and parts of lspci -vv:

---------------

00:0f.0 CardBus bridge: Texas Instruments PCI1225 (rev 01)
	Subsystem: SCM Microsystems: Unknown device 2023
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Latency: 168 set, cache line size 08
	Interrupt: pin A routed to IRQ 0
	Region 0: Memory at <ignored> (32-bit, non-prefetchable)
	Bus: primary=00, secondary=20, subordinate=22, sec-latency=176
	I/O window 0: 00000000-00000003
	I/O window 1: 00000000-00000003
	BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset+ 16bInt+ PostWrite+
	16-bit legacy interface ports at 0001

00:0f.1 CardBus bridge: Texas Instruments PCI1225 (rev 01)
	Subsystem: SCM Microsystems: Unknown device 2023
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Latency: 168 set, cache line size 08
	Interrupt: pin A routed to IRQ 0
	Region 0: Memory at <ignored> (32-bit, non-prefetchable)
	Bus: primary=00, secondary=23, subordinate=25, sec-latency=176
	I/O window 0: 00000000-00000003
	I/O window 1: 00000000-00000003
	BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset+ 16bInt+ PostWrite+
	16-bit legacy interface ports at 0001

Next-in-Thread Next Message

Select this message: same problems on single processor

Messages Inline: 1 All Outline: 1 2 All

1. None No interrupt routing table by David Hinds, 2000, Jul 17
(_ None Re: No interrupt routing table by Douglas S. J. De Couto, 2000, Jul 18
(_ None Oops, I left out something important by David Hinds, 2000, Jul 18
(_ None Re: Oops, I left out something important by Douglas S. J. De Couto, 2000, Jul 20

Message Administration

This form allows you to delete, move, or copy one or more messages. You can move messages by copying and deleting the original. The action will be applied to the messages you select above and all replies to those selected messages.


If you want to copy or move messages, specify the HyperNews path of a destination forum or message that all messages will be copied or moved to. The destination must already exist, so maybe create it first.

Path of Destination (a Forum or Message): (e.g. "test")

Notify Subscribers at destination
NO


If you want to delete messages (the default), specify that here. If you want to move messages, you need to delete the original messages; placeholders will be left pointing to where they were moved.

Delete Messages
NO


Caution: After deleteing messages (the default), if you have not copied them (i.e. no destination above), then the selected messages are not be recoverable.

Members Subscribe No Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10
[ Edit This Forum ]