Next-in-Thread Next Message

Question Lucent WaveLAN IEEE in ISA PCMCIA Brigde hangs on FTP downloads 

Forum: PCMCIA Wireless Network Adapter Issues
Date: 2000, Feb 18
From: Gerald Richter richter

Hi,

I have an Lucent WaveLan IEEE Turbo Card and have troube when makeing FTP downloads, while ping works without problems. Also FTP uploads works without problems. So it seems to me that there is a problem with receiving large packages.

The currious thing is that I have two Linux boxes. On one box it works in both directions on the other I get the trouble, also both have an identical software and configuration. Only the hardware differs slitly.

Software is Linux 2.2.13, pcmcia-cs-3.1.10
Hardware is on both boxes Intel BX chipset and VADEM VG 469 ISA to PCMCIA brigde.

I have tried various things with different irqs, setting irqs to ISA in the bios, but nothing helps. I also have tried to lower down the MTU size and exchanges the isa and pcmcia boards to exclude a hardware failiure.

Any ideas where to search?

Thanks

Gerald

Next-in-Thread Next Message

Messages Inline: 0 1

None Re: Question: Lucent WaveLAN IEEE in ISA PCMCIA Brigde hangs on FTP downloads

Re: Question Lucent WaveLAN IEEE in ISA PCMCIA Brigde hangs on FTP downloads (Gerald Richter)
Date: 2000, Feb 19
From: David Hinds <dhinds@pcmcia.sourceforge.org>

Dumb question: you say the hardware differs slightly.  So, what is the
slight hardware difference?

-- Dave

None RE: Question: Lucent WaveLAN IEEE in ISA PCMCIA Brigde hangs on FTP downloads

Re: None Re: Question: Lucent WaveLAN IEEE in ISA PCMCIA Brigde hangs on FTP downloads (David Hinds)
Date: 2000, Feb 19
From: Gerald Richter richter

> Dumb question: you say the hardware differs slightly.  So, what is the
> slight hardware difference?
>

They have different motherboards. The one that works is on a ASUS P2B
Motherboard with a Pentium II 350 Mhz and 100 MHz Bus clock, the one that
doesn't work has an other motherboard (I don't no which exactly), with
onboard network adapter (Intel 82558) and onboard vga (ati rage pro) and an
Intel 400Mhz Celeron and 66Mhz Bus clock. Both uses the Intel BX chipset.

I have tried to disable as much onboard components as possible, have choosen
different irqs and i/o port, but this doesn't make any difference. Then I
have taken the harddisk and put it in the box that works, and here this
software also works. So it can only be a problem of the hardware (or the the
combination of hard- and software).

Thanks for any hint

Gerald

News new Wavelan IEEE driver & debugging

Re: Question Lucent WaveLAN IEEE in ISA PCMCIA Brigde hangs on FTP downloads (Gerald Richter)
Date: 2000, Feb 25
From: Jean Tourrilhes jt

	A few comments...

	Debugging :
	The first thing is to really pin-point the fault on
the Wavelan. I'm sorry, FTP is not a good enough test, because
it test the file system as well. For example, in 2.3.47, I
can't run FTP because the file system is ****.
	I recommend you to fetch netperf and run it for a
while. Then we can accuse the Wavelan.

	Solving :
	If my memory serves me correctly, 2.2.14 did fix some
file system issues. You may want to upgrade.
	The most likely cause of trouble is of course the
wvlan_cs driver. Andy is about to release a new version, and
he has dramatically improved the handling of IRQs. This might
fix your problem.
	You may also want to check the system logs. Of course,
in case of a hang, it's likely that the important message
won't have been flushed to the disk.

	Regards,

	Jean

None RE: News: new Wavelan IEEE driver & debugging

Re: News new Wavelan IEEE driver & debugging (Jean Tourrilhes)
Date: 2000, Feb 28
From: Gerald Richter richter

>
>         A few comments...
>
>         Debugging :
>         The first thing is to really pin-point the fault on
> the Wavelan. I'm sorry, FTP is not a good enough test, because
> it test the file system as well. For example, in 2.3.47, I
> can't run FTP because the file system is ****.
>         I recommend you to fetch netperf and run it for a
> while. Then we can accuse the Wavelan.
>

I don't found netperf on the net, but it's surely not an ftp problem. FTP
works via ethernet (some files, some hosts). I get the same problem with an
HTTP Request which is just printed to stdout...

>         Solving :
>         If my memory serves me correctly, 2.2.14 did fix some
> file system issues. You may want to upgrade.

2.2.14 is still beta, I will do as soon as it is out.

>         The most likely cause of trouble is of course the
> wvlan_cs driver. Andy is about to release a new version, and
> he has dramatically improved the handling of IRQs. This might
> fix your problem.

I think I wait for new driver.

>         You may also want to check the system logs. Of course,
> in case of a hang, it's likely that the important message
> won't have been flushed to the disk.
>

I really checked out everything. Nothing in the syslog, even not if I
compile and run with debug on.

Thanks for your help

Gerald



-------------------------------------------------------------
Gerald Richter    ecos electronic communication services gmbh
Internetconnect * Webserver/-design/-datenbanken * Consulting

Post:       Tulpenstrasse 5         D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de         Voice:    +49 6133 925151
WWW:        http://www.ecos.de      Fax:      +49 6133 925152
-------------------------------------------------------------

None A Wavelan update is imminent

Re: None RE: News: new Wavelan IEEE driver & debugging (Gerald Richter)
Date: 2000, Feb 28
From: David Hinds <dhinds@pcmcia.sourceforge.org>

> 2.2.14 is still beta, I will do as soon as it is out.

2.2.14 has been out for a couple months.  2.2.15 is still in beta.

> I think I wait for new driver.

I just got a wvlan_cs update and it will be in the next PCMCIA beta.

-- Dave

None RE: A Wavelan update is imminent

Re: None A Wavelan update is imminent (David Hinds)
Date: 2000, Feb 29
From: Gerald Richter richter

>
> If you reply to this message at HyperNews@pcmcia.sourceforge.org, include:
> In-Reply-To: <20000228125448.B5441@valinux.com>
>
> > 2.2.14 is still beta, I will do as soon as it is out.
>
> 2.2.14 has been out for a couple months.  2.2.15 is still in beta.
>

Oops, sorry you are right. My browser fooled me. I look just before I wrote
you the last mail, but my browser load the page out of his cache and showed
me the old one. After a Reload I see that 2.2.14 is really there since two
month. I try to upgrade.

> > I think I wait for new driver.
>
> I just got a wvlan_cs update and it will be in the next PCMCIA beta.
>

Good news :-)

Gerald




-------------------------------------------------------------
Gerald Richter    ecos electronic communication services gmbh
Internetconnect * Webserver/-design/-datenbanken * Consulting

Post:       Tulpenstrasse 5         D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de         Voice:    +49 6133 925151
WWW:        http://www.ecos.de      Fax:      +49 6133 925152
-------------------------------------------------------------

Ok Already there !!!

Re: None RE: A Wavelan update is imminent (Gerald Richter)
Date: 2000, Feb 29
From: Jean Tourrilhes jt

	Gosh !!! David is so quick that the beta is already
released, and you'll find it in the NEW directory as
pcmcia-cs.28-Feb-00...
	Enjoy !!!

	Jean

None RE: A Wavelan update is imminent

Re: None A Wavelan update is imminent (David Hinds)
Date: 2000, Mar 01
From: Gerald Richter richter

>
> 2.2.14 has been out for a couple months.  2.2.15 is still in beta.
>

I have upgraded to 2.2.14, but no changes...

> > I think I wait for new driver.
>
> I just got a wvlan_cs update and it will be in the next PCMCIA beta.
>
>...
>         Gosh !!! David is so quick that the beta is already
> released, and you'll find it in the NEW directory as
> pcmcia-cs.28-Feb-00...

I have also tested this new driver, but still the same problem:

ping works, ftp and http makes the initial tcp connection (things like "ls"
works, also), but a download of a file (also if it's not saved to the
filesystem) hangs (ping still works at the same time).

Since it must be a hardware problem (because it works with all other
computers I tested), the next I will try is to use the TI PCI1031
PCI-to-PCMCIA bridge, which David told me that it should work, which I will
get soon.

Thanks for all the help

Gerald


-------------------------------------------------------------
Gerald Richter    ecos electronic communication services gmbh
Internetconnect * Webserver/-design/-datenbanken * Consulting

Post:       Tulpenstrasse 5         D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de         Voice:    +49 6133 925151
WWW:        http://www.ecos.de      Fax:      +49 6133 925152
-------------------------------------------------------------
Lucent WaveLAN IEEE in ISA PCMCIA Brigde hangs on FTP downloads


Members Subscribe No Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10
[ Edit This Forum ]