Next-in-Thread Next Message

Question rbe-100, almost works 

Forum: Xircom PCMCIA Ethernet Adapter Issues
Date: 2000, Jul 10
From: visnu pitiyanuvath visnu

hello. i have a xircom rbe-100 on a toshiba tecra 8000, running redhat 6.2 (2.2.14 kernel). my card is recognized as a CBEII-10/100, and all pertinent drivers seem to load correctly, but when it looks for the dhcp server, it gets nothing.

i looked at the network, and the card is sending out dhcp discover packets and my dhcp server is sending out offers, but pump doesn't seem to want to cooperate, so it sends out yet another discover packet.

i've tried configuring the interface statically and also in promiscuous mode, but i still don't get any response from my pings of the gateway or computers on the subnet. again, i can see broadcasts coming out of my laptop, but it doesn't want to hear the responses.

everything works under w2k, and i've tried the latest tulip_cb drivers that come in the 3.1.17 tarball, but no change.

any suggestions??

here's a log file for fun:

Jul 10 10:48:13 visnup pcmcia: Starting PCMCIA services:
Jul 10 10:48:13 visnup pcmcia: modules
Jul 10 10:48:13 visnup kernel: Linux PCMCIA Card Services 3.1.8
Jul 10 10:48:13 visnup kernel: kernel build: 2.2.14-12 #1 Tue Apr 25 13:04:07 EDT 2000
Jul 10 10:48:13 visnup kernel: options: [pci] [cardbus] [apm]
Jul 10 10:48:13 visnup kernel: Intel PCIC probe:
Jul 10 10:48:13 visnup kernel: Toshiba ToPIC97 PCI-to-CardBus at bus 0 slot 11, mem 0x68000000, 2 sockets
Jul 10 10:48:13 visnup kernel: host opts [0]: [slot 0xf0] [ccr 0x10] [cdr 0x86] [rcr 0x02] [no pci irq] [lat 168/176] [bus 20/20]
Jul 10 10:48:13 visnup kernel: host opts [1]: [slot 0xf0] [ccr 0x20] [cdr 0x86] [rcr 0x02] [no pci irq] [lat 168/176] [bus 21/21]
Jul 10 10:48:13 visnup kernel: ISA irqs (default) = 3,4,5,7,9,10,12 polling interval = 1000 ms
Jul 10 10:48:14 visnup pcmcia: cardmgr.
Jul 10 10:48:14 visnup rc: Starting pcmcia succeeded
Jul 10 10:48:14 visnup cardmgr[452]: starting, version is 3.1.8
Jul 10 10:48:14 visnup apmd[331]: Now using AC Power
Jul 10 10:48:14 visnup cardmgr[452]: watching 2 sockets
Jul 10 10:48:14 visnup kernel: cs: IO port probe 0x1000-0x17ff: clean.
Jul 10 10:48:14 visnup kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x330-0x337 0x378-0x37f 0x388-0x38f 0x4d0-0x4d7
Jul 10 10:48:14 visnup kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Jul 10 10:48:14 visnup kernel: cs: cb_alloc(bus 20): vendor 0x115d, device 0x0003
Jul 10 10:48:14 visnup cardmgr[452]: initializing socket 0
Jul 10 10:48:14 visnup kernel: ROM image dump:
Jul 10 10:48:14 visnup kernel: image 0: 0x000000-0xffffffff, signature PCIR
Jul 10 10:48:14 visnup cardmgr[452]: socket 0: Xircom CardBus 10/100 Ethernet
Jul 10 10:48:14 visnup cardmgr[452]: executing: 'insmod /lib/modules/2.2.14-12/pcmcia/cb_enabler.o'
Jul 10 10:48:14 visnup cardmgr[452]: executing: 'insmod /lib/modules/2.2.14-12/pcmcia/tulip_cb.o'
Jul 10 10:48:14 visnup kernel: cs: cb_config(bus 20)
Jul 10 10:48:14 visnup kernel: fn 0 bar 1: io 0x400-0x47f
Jul 10 10:48:14 visnup kernel: fn 0 bar 2: mem 0x6000d000-0x6000d7ff
Jul 10 10:48:14 visnup kernel: fn 0 bar 3: mem 0x6000c000-0x6000c7ff
Jul 10 10:48:14 visnup kernel: fn 0 rom: mem 0x60008000-0x6000bfff
Jul 10 10:48:14 visnup kernel: cs: cb_enable(bus 20)
Jul 10 10:48:14 visnup kernel: bridge io map 0 (flags 0x21): 0x400-0x47f
Jul 10 10:48:14 visnup kernel: bridge mem map 0 (flags 0x1): 0x60008000-0x6000dfff
Jul 10 10:48:14 visnup kernel: tulip_attach(bus 20, function 0)
Jul 10 10:48:14 visnup kernel: tulip.c:v0.91 4/14/99 becker@cesdis.gsfc.nasa.gov (modified by danilo@cs.uni-magdeburg.de for XIRCOM CBE, fixed by Doug Ledford)
Jul 10 10:48:14 visnup kernel: eth0: Xircom Cardbus Adapter (DEC 21143 compatible mode) rev 3 at 0x400, 00:10:A4:E9:62:DB, IRQ 3.
Jul 10 10:48:14 visnup kernel: eth0: MII transceiver #0 config 3100 status 7809 advertising 01e1.
Jul 10 10:48:14 visnup cardmgr[452]: executing: './network start eth0'
Jul 10 10:48:15 visnup pumpd[519]: starting at (uptime 0 days, 0:00:30) Mon Jul 10 10:48:15 2000
Jul 10 10:48:30 visnup kernel: eth0: Transmit timed out, status 686980c7, CSR12 000000c4, resetting...
Jul 10 10:48:40 visnup last message repeated 2 times
Jul 10 10:49:15 visnup cardmgr[452]: + Determining IP information for eth0...Operation failed.
Jul 10 10:49:15 visnup cardmgr[452]: + failed.
Jul 10 10:49:15 visnup cardmgr[452]: start cmd exited with status 1
Jul 10 10:49:31 visnup gpm: gpm startup succeeded
Jul 10 10:49:31 visnup gpm[570]: Skipping a data packet (?)
Jul 10 10:49:31 visnup gpm[570]: Error in protocol
Jul 10 10:49:32 visnup last message repeated 64 times
Jul 10 10:49:52 visnup PAM_pwdb[646]: (login) session opened for user root by LOGIN(uid=0)
Jul 10 10:50:41 visnup kernel: eth0: Promiscuous mode enabled.
Jul 10 10:50:41 visnup kernel: device eth0 entered promiscuous mode
Jul 10 10:51:05 visnup kernel: eth0: Transmit timed out, status 686980c7, CSR12 000000c4, resetting...
Jul 10 10:51:40 visnup last message repeated 7 times

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. None What about the messages with the newer drivers? by David Hinds, 2000, Jul 10
(_ Ok Untitled by visnu pitiyanuvath, 2000, Jul 10

Add Message to: "rbe-100, almost works"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10