Next-in-Thread Next Message

Question No network using Xircom RBEM56G-100 

Forum: Xircom PCMCIA Ethernet Adapter Issues
Date: 2000, Aug 25
From: Stuart Pedler <stuart.pedler@sbs.siemens.co.uk>

I have a Siemens Scenic 510 Mobile and a Xircom RBEM56G-100 CardBus. I am running Red Hat 2.2.5-15 and cannot get the card to see the network. The distribution package of card services always tried to set IRQ 0 on the card and failed to start the network. I therefore installed card services 3.1.19 and the card now configures. I cannot however ping anything on the network. Everything looks ok so I have included the syslog and the output of ifconfig,
Any ideas anyone.

Aug 25 13:58:11 SBS_ESCOM network: Bringing up interface lo succeeded
Aug 25 13:58:18 SBS_ESCOM kernel: Linux PCMCIA Card Services 3.1.19
Aug 25 13:58:18 SBS_ESCOM kernel: kernel build: 2.2.5-15 #1 Mon Apr 19 23:00:46 EDT 1999
Aug 25 13:58:18 SBS_ESCOM kernel: options: [pci] [cardbus] [apm] [pnp]
Aug 25 13:58:18 SBS_ESCOM kernel: PCI routing table version 1.0 at 0xf57d0
Aug 25 13:58:18 SBS_ESCOM kernel: PnP: PNP BIOS installation structure at 0xc00fdab0
Aug 25 13:58:18 SBS_ESCOM kernel: PnP: PNP BIOS version 1.0, entry at f0000:3cb7, dseg at f0000
Aug 25 13:58:18 SBS_ESCOM kernel: Intel PCIC probe:
Aug 25 13:58:18 SBS_ESCOM kernel: O2Micro OZ6832/33 rev 02 PCI-to-CardBus at slot 00:0a, mem 0x68000000
Aug 25 13:58:18 SBS_ESCOM kernel: host opts [0]: [pci irq 9] [lat 168/176] [bus 32/34]
Aug 25 13:58:18 SBS_ESCOM kernel: host opts [1]: [pci irq 10] [lat 168/176] [bus 35/37]
Aug 25 13:58:18 SBS_ESCOM kernel: PCI card interrupts, PCI status changes
Aug 25 13:58:18 SBS_ESCOM kernel: cs: IO port probe 0x0c00-0x0cff: clean.
Aug 25 13:58:18 SBS_ESCOM kernel: cs: IO port probe 0x0800-0x08ff: clean.
Aug 25 13:58:18 SBS_ESCOM kernel: cs: IO port probe 0x0100-0x04ff: clean.
Aug 25 13:58:18 SBS_ESCOM kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Aug 25 13:58:18 SBS_ESCOM cardmgr[923]: starting, version is 3.1.19
Aug 25 13:58:18 SBS_ESCOM cardmgr[923]: watching 2 sockets
Aug 25 13:58:19 SBS_ESCOM kernel: cs: cb_alloc(bus 32): vendor 0x115d, device 0x0003
Aug 25 13:58:19 SBS_ESCOM cardmgr[923]: initializing socket 0
Aug 25 13:58:19 SBS_ESCOM cardmgr[923]: socket 0: Xircom CBEM56G-100 CardBus 10/100 Ethernet + 56K Modem
Aug 25 13:58:19 SBS_ESCOM cardmgr[923]: product info: "Xircom", "CardBus Ethernet 10/100 + Modem 56", "CBEM56G", "1.03"
Aug 25 13:58:19 SBS_ESCOM cardmgr[923]: manfid: 0x0105, 0x0103 function: 6 (network)
Aug 25 13:58:19 SBS_ESCOM cardmgr[923]: executing: 'modprobe cb_enabler'
Aug 25 13:58:19 SBS_ESCOM cardmgr[923]: executing: 'modprobe tulip_cb'
Aug 25 13:58:19 SBS_ESCOM cardmgr[923]: executing: 'modprobe serial_cb'
Aug 25 13:58:19 SBS_ESCOM kernel: cs: cb_config(bus 32)
Aug 25 13:58:19 SBS_ESCOM kernel: fn 0 bar 2: mem 0x60013000-0x600137ff
Aug 25 13:58:19 SBS_ESCOM kernel: fn 0 bar 3: mem 0x60012000-0x600127ff
Aug 25 13:58:19 SBS_ESCOM kernel: fn 1 bar 1: io 0x480-0x487
Aug 25 13:58:19 SBS_ESCOM kernel: fn 1 bar 2: mem 0x60011000-0x600117ff
Aug 25 13:58:19 SBS_ESCOM kernel: fn 1 bar 3: mem 0x60010000-0x600107ff
Aug 25 13:58:19 SBS_ESCOM kernel: fn 0 bar 1: io 0x400-0x47f
Aug 25 13:58:19 SBS_ESCOM kernel: fn 0 rom: mem 0x6000c000-0x6000ffff
Aug 25 13:58:19 SBS_ESCOM kernel: fn 1 rom: mem 0x60008000-0x6000bfff
Aug 25 13:58:19 SBS_ESCOM kernel: irq 9
Aug 25 13:58:19 SBS_ESCOM kernel: tulip_attach(device 20:00.0)
Aug 25 13:58:19 SBS_ESCOM kernel: tulip.c:v0.91g-ppc 7/16/99 becker@cesdis.gsfc.nasa.gov (modified by danilo@cs.uni-magdeburg.de for XIRCOM CBE, fixed by Doug Ledford)
Aug 25 13:58:19 SBS_ESCOM kernel: eth0: Xircom Cardbus Adapter (DEC 21143 compatible mode) rev 3 at 0x400, 00:10:A4:C5:BB:F1, IRQ 9.
Aug 25 13:58:19 SBS_ESCOM kernel: eth0: MII transceiver #0 config 3100 status 7809 advertising 01e1.
Aug 25 13:58:19 SBS_ESCOM kernel: serial_attach(device 20:00.1)
Aug 25 13:58:19 SBS_ESCOM kernel: tty01 at 0x0480 (irq = 9) is a 16550A
Aug 25 13:58:19 SBS_ESCOM cardmgr[923]: executing: './network start eth0'
Aug 25 13:58:19 SBS_ESCOM cardmgr[923]: executing: './serial start ttyS1'
Aug 25 13:58:20 SBS_ESCOM cardmgr[923]: exiting


IFCONFIG--------------------------------------------

eth0 Link encap:Ethernet HWaddr 00:10:A4:C5:BB:F1
          inet addr:51.128.176.9 Bcast:51.128.176.255 Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:9 Base address:0x400

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          UP LOOPBACK RUNNING MTU:3924 Metric:1
          RX packets:59 errors:0 dropped:0 overruns:0 frame:0
          TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. Feedback Here is how it worked for me by Stefan Kluth, 2000, Aug 25
1. Sad Untitled by Stuart Pedler, 2000, Aug 25
1. News here is more detail of my setup by Stefan Kluth, 2000, Aug 25
... 3 Message(s)
2. News similiar problem solved by Sven Höfer, 2000, Sep 13
2. None You can try putting the card in promisc mode by David Hinds, 2000, Aug 25

Add Message to: "No network using Xircom RBEM56G-100"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10