Next-in-Thread Next Message

Question Problem with Intel EtherExpress 100 (16 bits) 

Forum: Xircom PCMCIA Ethernet Adapter Issues
Date: 2000, Jan 16
From: Jean-Francois Gadoury RedStorm

Hello,

I have been trying to get my Intel EtherExpress 100 16 bits card to work for while now without sucess. I would appreciate any ideas of what I could try to resolve my problem

I am Running Redhat v6.1 on a IBM ThinkPad 600e. The tests I have conducted were with version 2.2.12 and 2.2.14 of the linu Kernel. I am using pcmcia 3.0.14 package.

From what I see the pcmcia package is functionning correctly I hear the usual beeps for insertion and removal of cards from the pcmcia sockets. The scripts for initting the Ethernet card functions properly also I have tried the pcmcia default scripts as well as using the modification to conserve the Redhat init mechanism.

When I insert the card I the proper module is loaded xirc2ps_cs.o. I have specifying direct IP related information and have also tried DHCP. If I specify the IP and net info myself the interface eth0 is setup properly and if I ifconfig I get the proper output.

When using DHCP the interface is not mounted and an error is reported in /var/log/messages.

When setting the IP address and net information directly I tried to ping computers on the locl subnet without success I receive Network Unreachable messages. I also notice that the card does not show activity though the dongle leds.

Here is a terminal log of hopefully usefulll information:

#
# Local PCMCIA Configuration File
#
# System resources available for PCMCIA devices
#
# include port 0x100-0x4ff, port 0x1000-0x17ff
include port 0x1000-0x17ff include memory 0xc0000-0xfffff exclude memory 0xa0000000-0xa0ffffff include memory 0x60000000-0x60ffffff

exclude port 0x100-0x4ff

# First built-in serial port exclude irq 4 # Second built-in serial port exclude irq 3 # First built-in parallel port exclude irq 7 #exclude irq 9

[root@localhost /root]# cardctl ident
Socket 0:
  no product info available
Socket 1:
  product info: "Intel", "EtherExpress(TM) PRO/100 PC Card Mobile Adapter16", "PRO/100 M16A", "1.00"
  manfid: 0x0089, 0x010a
  function: 6 (network)
[root@localhost /root]# 

[root@localhost /root]# cardctl config
Socket 0:
  not configured
Socket 1:
  Vcc = 5.0, Vpp1 = 0.0, Vpp2 = 0.0
  Interface type is memory and I/O
  IRQ 9 is exclusive, level mode, enabled
  Function 0:
    Config register base = 0x0800
      Option = 0x41, status = 0000
    I/O window 1: 0x1000 to 0x100f, 16 bit
[root@localhost /root]# 

[root@localhost /root]# tail /var/log/messages

Jan 16 21:08:35 localhost cardmgr[2035]: socket 1: Intel EtherExpress PRO/100
Jan 16 21:08:35 localhost cardmgr[2035]: executing: 'insmod /lib/modules/2.2.14/pcmcia/xirc2ps_cs.o'
Jan 16 21:08:35 localhost kernel: xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+kvh) 
Jan 16 21:08:35 localhost kernel: eth0: Intel: port 0x1000, irq 9, hwaddr 00:A0:C9:BA:20:9D 
Jan 16 21:08:35 localhost cardmgr[2035]: executing: './network start eth0'
Jan 16 21:08:40 localhost kernel: eth0: auto negotation failed; using 10mbs 
Jan 16 21:08:40 localhost kernel: eth0: media 10BaseT, silicon revision 4 
Jan 16 21:09:11 localhost kernel: eth0: media 10BaseT, silicon revision 4 
Jan 16 21:09:41 localhost cardmgr[2035]: + Determining IP information for eth0...Operation failed.
Jan 16 21:09:41 localhost cardmgr[2035]: +  failed.
[root@localhost /root]#

This card has already functioned under linux with Linux v6.0

thanks for any help :-)

alp!

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. Ok Nevermind 3.1.8 fixes my problems! by Jean-Francois Gadoury, 2000, Jan 17

Add Message to: "Problem with Intel EtherExpress 100 (16 bits)"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10