Next-in-Thread Next Message

Question CEM-28 combo card stopped working.... 

Forum: Xircom PCMCIA Ethernet Adapter Issues
Date: 1999, Nov 04
From: bboett

Hello,

suddenly last wek my xircom combo card stopped working, after some manipulations of my system (among others the latest update to the latest debian potato...) the next reboot resulted in the loss of the ethernet ability of my laptop...

I tryed to recompile the pcmcia package, i installed the package 3.1.3, recompiled the kernel, tryed with the kernel 2.2.9 and 2.2.12, ntohing helps...

the exerpt of the /var/log/messages:
Nov  4 01:07:53 localhost kernel: Linux PCMCIA Card Services 3.1.3
Nov  4 01:07:53 localhost kernel:   kernel build: 2.2.12 #1 Fri Sep 3 07:39:42 C
EST 1999
Nov  4 01:07:53 localhost kernel:   options:  [pci] [cardbus] [apm] [pnp]
Nov  4 01:07:53 localhost kernel: PnP: PNP BIOS installation structure at 0xc00f
66d0
Nov  4 01:07:53 localhost kernel: PnP: PNP BIOS version 1.0, entry at f0000:a62f
, dseg at 400
Nov  4 01:07:53 localhost kernel: PCI routing table version 1.0 at 0xfdf90
Nov  4 01:07:53 localhost kernel: Intel PCIC probe: 
Nov  4 01:07:53 localhost kernel:   TI 1131 PCI-to-CardBus at bus 0 slot 10, mem
 0x68000000, 2 sockets
Nov  4 01:07:53 localhost kernel:     host opts [0]: [ring] [clkrun irq 12] [pci
 + serial irq] [no pci irq] [lat 168/176] [bus 32/34]
Nov  4 01:07:53 localhost kernel:     host opts [1]: [ring] [clkrun irq 12] [pci
 + serial irq] [no pci irq] [lat 168/176] [bus 35/37]
Nov  4 01:07:53 localhost kernel:     ISA irqs (scanned) = 3,4,7,10,11,15 status
 change on irq 15
Nov  4 01:07:54 localhost kernel: cs: IO port probe 0x1000-0x17ff: clean.
Nov  4 01:07:54 localhost kernel: cs: IO port probe 0x0100-0x04ff: clean.
Nov  4 01:07:54 localhost kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Nov  4 01:07:54 localhost kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.
Nov  4 01:07:54 localhost kernel: xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+k
vh)
Nov  4 01:07:54 localhost kernel: xirc2ps_cs: no ports available
Nov  4 01:09:55 localhost kernel: xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+k
vh)
Nov  4 01:09:55 localhost kernel: xirc2ps_cs: no ports available

while the daemon.log reports:

Nov  4 01:09:55 localhost cardmgr[389]: initializing socket 0
Nov  4 01:09:55 localhost cardmgr[389]: socket 0: Xircom CEM28 Ethernet/Modem
Nov  4 01:09:55 localhost cardmgr[389]: executing: 'insmod /lib/modules/2.2.12/p
cmcia/xirc2ps_cs.o'
Nov  4 01:09:55 localhost cardmgr[389]: module /lib/modules/2.2.12/pcmcia/p<80>^
N@p<80>^N@x.o not available
Nov  4 01:09:55 localhost cardmgr[389]: get dev info on socket 0 failed: No such
 device

especially the line Nov 4 01:09:55 localhost cardmgr[389]: module /lib/modules/2.2.12/pcmcia/p<80>^ N@p<80>^N@x.o not available seems really strange....

BTW, here'S the shortened output of lsmod and 2x carctl:

Module Size Used by xirc2ps_cs 13564 0 (unused) ds 6408 4 [xirc2ps_cs] i82365 28440 2 pcmcia_core 50944 0 [xirc2ps_cs ds i82365]

erm7:/etc/pcmcia# cardctl status
Socket 0:
  5V 16-bit PC Card
  function 0: [ready]
Socket 1:
  no card
erm7:/etc/pcmcia# cardctl ident 
Socket 0:
  product info: "Xircom", "CreditCard Ethernet+Modem 28.8", "CEM28", "2.00"
  manfid: 0x0105, 0x110b
  function: 2 (serial)
Socket 1:
  no product info available

I find it strange that cardctl ident recognizes the card, but that cardctl status shows off nothing...

so what's going wrong? Do i have to assume that my card is fryed? But in that case i wonder why the system is able to recognize it correctly as a xircom card...

So i suppose there is something else....

Next-in-Thread Next Message

Messages Inline: 1 All Outline: 1 2 All

1. Sad also get "no port available" msg for REM56 by Adam Di Carlo, 1999, Nov 10
(_ Ok RETRACTION -- pcmcia not to blame for "no port available" by Adam Di Carlo, 1999, Nov 10
(_ None Re: Ok: RETRACTION -- pcmcia not to blame for "no port available" by Bruno Boettcher, 1999, Nov 10
(_ Feedback Re: Ok: RETRACTION -- pcmcia not to blame for "no port available" by Adam Di Carlo, 1999, Nov 13

Add Message to: "CEM-28 combo card stopped working...."

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10