Next-in-Thread Next Message

Question Xircom CEM56-100 not resuming 

Forum: Xircom PCMCIA Ethernet Adapter Issues
Date: 2000, Jun 05
From: Andrew Pickin <Andrew.Pickin@bullgod.co.uk>

I have a problem with my Xircom not resuming.
This is not a problem with my unbranded NE2000,
under RH 6.1 & 6.2.
If i restart cardmgr the card wakes-up.
I'm lost, the follow output has the xircom in
slot 1.

[root@wintermute pcmcia-cs-3.0.14]# cardctl config
Socket 0:
  Vcc = 5.0, Vpp1 = 0.0, Vpp2 = 0.0
  Interface type is memory and I/O
  IRQ 9 is exclusive, level mode, enabled
  Function 0:
    Config register base = 0x03f8
      Option = 0x61, status = 0000
    I/O window 1: 0x0320 to 0x033f, auto sized
Socket 1:
  Vcc = 5.0, Vpp1 = 0.0, Vpp2 = 0.0
  Interface type is memory and I/O
  IRQ 3 is dynamic shared, level mode, enabled
  Speaker output is enabled
  Function 0:
    Config register base = 0xff80
      Option = 0x67, status = 0x08, pin = 0000
    I/O window 1: 0x0300 to 0x030f, 16 bit
    I/O window 2: 0x02e8 to 0x02ef, 8 bit

Do I need to reset the IRQ (to 9) if so how?

THX 

Andrew Pickin

Next-in-Thread Next Message

Messages Inline: 0 All Outline: 1 3 All

None Known bug

Re: Question Xircom CEM56-100 not resuming (Andrew Pickin)
Date: 2000, Jun 05
From: David Hinds <dhinds@pcmcia.sourceforge.org>

It is a known bug in the xirc2ps_cs driver, and there is no fix;
someone needs to modify the driver to correctly reset the card when
the system is resumed.  I'm somewhat averse to messing with the driver
myself since I don't have any of these cards, and would hope that
someone would step forward to maintain the driver and fix things like
this.

-- Dave
Xircom CEM56-100 not resuming


Add Message to: "Xircom CEM56-100 not resuming"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10