Next-in-Thread Next Message

Question Init Strings for Xircom RealPort GSM 

Forum: Xircom PCMCIA Ethernet Adapter Issues
Date: 2000, Jun 15
From: Fabien fabien

I have a problem with calling when I am using a gsm connection kit. The xircom card works very well, and I can use ethernet, modem, isdn without problems. The gsm is a nokia 6150 When I try to call my provider, using just "atd telephoneumber", I receive a "NO CARRIAGE". I can see on the GSM "calling number" and after an error.

I've tried to use init strings from windows driver : in windows : ============================

06-15-2000 15:43:11.54 - Modem of Xircom CreditCard Ethernet 100 + Modem 56 closed.

06-15-2000 15:43:42.78 - Modem of Xircom CreditCard Ethernet 100 + Modem 56 in use.

06-15-2000 15:43:42.78 - Modem type: Modem of Xircom CreditCard Ethernet 100 + Modem 56

06-15-2000 15:43:42.78 - Modem inf path: MDMCEM56.INF

06-15-2000 15:43:42.78 - Modem inf section: Modem1

06-15-2000 15:43:43.02 - 115200,N,8,1

06-15-2000 15:43:43.06 - 115200,N,8,1

06-15-2000 15:43:43.07 - Initializing modem.

06-15-2000 15:43:43.07 - Send: AT<cr>

06-15-2000 15:43:43.08 - Recv: AT<cr>

06-15-2000 15:43:43.08 - Recv: <cr><lf>OK<cr><lf>

06-15-2000 15:43:43.08 - Interpreted response: Ok

06-15-2000 15:43:43.08 - Send: AT &F E0 &C1 &D2 V1 S0=0 S95=45 W2<cr>

06-15-2000 15:43:43.11 - Recv: AT &F E0 &C1 &D2 V1 S0=0 S95=45 W2<cr>

06-15-2000 15:43:43.11 - Recv: <cr><lf>OK<cr><lf>

06-15-2000 15:43:43.11 - Interpreted response: Ok

06-15-2000 15:43:43.11 - Send: ATS7=60S30=0M1S7=90 S10=100 S40=2 \N4<cr>

06-15-2000 15:43:43.11 - Recv: <cr><lf>OK<cr><lf>

06-15-2000 15:43:43.11 - Interpreted response: Ok

06-15-2000 15:43:43.11 - Send: AT%C3&K3B0N1X4<cr>

06-15-2000 15:43:43.13 - Recv: <cr><lf>OK<cr><lf>

06-15-2000 15:43:43.13 - Interpreted response: Ok

06-15-2000 15:43:43.13 - Dialing.

06-15-2000 15:43:43.13 - Send: ATDT;<cr>

06-15-2000 15:43:43.13 - Recv: <cr><lf>OK<cr><lf>

06-15-2000 15:43:43.13 - Interpreted response: Ok

06-15-2000 15:43:43.13 - Dialing.

06-15-2000 15:43:43.13 - Send: ATDT##########<cr>

06-15-2000 15:44:07.75 - Recv: <cr><lf>CARRIER 9600<cr><lf>

06-15-2000 15:44:07.75 - Interpreted response: Informative

06-15-2000 15:44:07.75 - Recv: <cr><lf>PROTOCOL: RLP<cr><lf>

06-15-2000 15:44:07.75 - Interpreted response: Informative

06-15-2000 15:44:07.75 - Recv: <cr><lf>COMPRESSION: NONE<cr><lf>

06-15-2000 15:44:07.75 - Interpreted response: Informative

06-15-2000 15:44:07.76 - Recv: <cr><lf>CONNECT 9600<cr><lf>

06-15-2000 15:44:07.76 - Interpreted response: Connect

06-15-2000 15:44:07.76 - Connection established at 9600bps.

06-15-2000 15:44:07.76 - Error-control on.

06-15-2000 15:44:07.76 - Data compression off or unknown.

06-15-2000 15:44:07.80 - 115200,N,8,1

06-15-2000 15:53:47.92 - Hanging up the modem.

06-15-2000 15:53:47.92 - Hardware hangup by lowering DTR.

06-15-2000 15:53:47.92 - Recv: <cr><lf>NO CARRIER<cr><lf>

06-15-2000 15:53:47.92 - Interpreted response: No Carrier

06-15-2000 15:53:47.92 - Send: ATH E1<cr>

06-15-2000 15:53:47.94 - Recv: <cr><lf>OK<cr><lf>

06-15-2000 15:53:47.94 - Interpreted response: Ok

06-15-2000 15:53:47.98 - Session Statistics:

06-15-2000 15:53:47.98 - Reads : 509579 bytes

06-15-2000 15:53:47.98 - Writes: 22298 bytes

06-15-2000 15:53:47.98 - Modem of Xircom CreditCard Ethernet 100 + Modem 56 closed.

===================== So in linux, I use :

ABORT BUSY

ABORT "NO CARRIER"

ABORT VOICE

ABORT "NO DIALTONE"

ABORT "NO ANSWER"

"" ATZ

OK

AT&FE0&C1&D2V1S0=0S95=45W2

OK

ATS7=60S30=0M1S7=90S10=100S40=2

OK

AT%C3&K3B0N1X4

OK

ATDT;

OK

ATDTmy_number

CONNECT \d\c

But I have the same "NO CARRIER"

Any solution ?

Thanks in advance...

--------------- Fabien SALVI

Next-in-Thread Next Message

Add Message to: "Init Strings for Xircom RealPort GSM"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10