Next-in-Thread Next Message

Feedback Re: Xircom RBEM56G 100 doesn't work in Linux Mandrake 

Forum: Xircom PCMCIA Ethernet Adapter Issues
Re: Sad Xircom RBEM56G 100 doesn't work in Linux Mandrake (Aishvarya Kr. Sharma)
Date: 2000, Jun 23
From: kato

As root, when you type ifconfig, what is the output?

I have a Dell Inspiron 7500 and the way I get it to work is the following:

1) On bootup, card doesn't/isn't able to get an IP address from my main Linux box, so I let it error out.

2) At the logon screen I logon

3) I su to root and restart the network init.d script by typing :

/etc/rc.d/init.d/network restart

4) While that is working I hit ctl+alt+F2 to get to another tty/terminal window and logon as root. I then type

ifconfig eth0 promisc

Then I exit out of that terminal

5) When I alt+ctrl+F1 back to the first terminal window, I see the dhcpcd command complete. But at this time the card is still in promisc mode so I just use the up arrow key to re-enter the same command in as above:

/etc/rc.d/init.d/network restart

Type "exit" to get back to your normal user status.

The network restarts, the card re-inits and is no longer in promiscuous mode. Everthings works fine. You can double check the card by typing in:

/sbin/ifconfig

I know this sounds like alot, but I can perform the steps in under 10 seconds. Not a big deal and at least the card works without alot of acrobatics.

There probably is an easier way to do this via the standard Mandrake network scripts via modification but I haven't had the time to figure it out yet.

I just got the card RBEM56G-100TX this week and it works like a charm. Hope this helps....

sji

Next-in-Thread Next Message

Add Message to: "Re: Xircom RBEM56G 100 doesn't work in Linux Mandrake"

Members Subscribe Admin Mode Show Frames Help for HyperNews at pcmcia-cs.sourceforge.net 1.10